WorldGuard Issue

Discussion in 'Plugin Help/Development/Requests' started by YetMaster64, Dec 30, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, recently I've been having some issues with WorldGuard. I am creating a Prison server and need to make it so people can't destroy blocks outside of the prison mine. What I did was disable the build, block-break, and block-place permission in global, but for some reason people were still able to break blocks... however they could not break them. So what I did as an alternative was set the game-mode for the region to adventure. That seemed to work and everything was fine... but then I went to setup one of the mines. For the mine I did the same things, but set the region game-mode to survival assuming that that block-break would not work. But now, the issue is people in the mine can break blocks outside of the mine region. I tried to change the regions around as much as I could, nothing worked. What I then tried was reinstalling WorldGuard + WorldEdit, no luck, removing all plugins that could possibly cause issues, no luck, and then reinstalling the whole server... no luck. There were also no errors or warnings in the console. So I'm not sure what to do, if anyone has any tips or advice please help me out. And yes, I was set to the default member rank, not oped, and this rank does not have any worldguard permissions.

    The WorldGuard config:

    Screenshots of the global and mine regions:

    Also I should mention the server is running off the latest version of Spigot for 1.12.2, same with WorldGuard and WorldEdit.
Thread Status:
Not open for further replies.

Share This Page