Problem/Bug WorldGuard Error

Discussion in 'Bukkit Help' started by SwitzerLad, Oct 22, 2021.

  1. Offline

    SwitzerLad

    So I put World Guard into my plugins folder but when I restarted it i got the following error:

    Code:
    [14:50:50 INFO]: Enabling WorldGuard v6.2.2-SNAPSHOT;8eeab68
    [14:50:50 ERROR]: Error occurred while enabling WorldGuard v6.2.2-SNAPSHOT;8eeab68 (Is it up to date?)
    java.lang.NoClassDefFoundError: com/sk89q/bukkit/util/CommandsManagerRegistration
            at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:171) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:177) ~[JavaPlugin.class:?]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:318) [JavaPluginLoader.class:?]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:399) [SimplePluginManager.class:?]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:477) [CraftServer.class:?]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:418) [CraftServer.class:?]
            at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:389) [MinecraftServer.class:?]
            at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:316) [nz.class:?]
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:596) [MinecraftServer.class:?]
            at java.lang.Thread.run(Thread.java:748) [?:1.8.0_282]
    Caused by: java.lang.ClassNotFoundException: com.sk89q.bukkit.util.CommandsManagerRegistration
            at java.net.URLClassLoader.findClass(URLClassLoader.java:382) ~[?:1.8.0_282]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:117) ~[PluginClassLoader.class:?]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[PluginClassLoader.class:?]
            at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_282]
            at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_282]
            ... 10 more
    I'm not sure why it is creating that error because it's the only "up to date" version available for 1.12. Would appreciate the help!
     

Share This Page