Problem/Bug WorldGuard - 6.2 : Item Frames Wont Break

Discussion in 'General Help' started by Brent147, Jul 2, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    Good evening folks,

    Earlier today, I began experiencing an issue with item frames on my 1.12 Minecraft server. Once an item frame has been placed, it cannot be broken, even by the person who placed it. If we attempt to break them, it instead breaks the block behind them.

    I've tried breaking them with my hand.
    I've attempted to World Edit these out.
    I've attempted to break them by placing a block where they are.
    I've tried these as and OP and as a regular player.
    I've tried this in Game Mode 0 and Game Mode 1.

    Up until today I had been running a slightly outdated version of WorldGuard, and when the problem began, I assumed it was because the plugin was outdated. I went ahead and updated the plugin to the most recent version, but alas the problem has carried over.

    I am running Spigot - 1.11.2.
    My Plugins are as follows:

    CleanRoomGenerator, AsyncWorldEditInjector, CoreProtect, WorldEdit, Automessage, BetterChairs, WorldBorder, Multiverse-Core, ProtocolLib, WorldGuard, LibsDisguises, AsyncWorldEdit, RoundMC-AntiSpam, Multiverse-Inventories, PermissionsEX, mcMMO, Vault, AreaShop, Essentials, LWC, EssentialsChat, EssentialsGeoIP, EssentialsSpawn, Chestshop, BossShopPro, EnjinMinecraftPlugin

    EDIT: I run Multiverse and in one of the worlds, I'm able to place and break frames, however when I place frames in this world, it doesn't tell me that I've created a private frame.

    Once I go to another world and place the frame I'm given a message that says "Created a Private CraftItemFrame successfully." Once I see this message, I cannot break the item. I've come to believe that the issue has to do with either WorldGuard or LWC. Which of the two, I am not positive.

    If anyone has any sort of insight to offer on this issue, it would be greatly appreciated!

    Kind regards,
    Last edited: Jul 3, 2017
Thread Status:
Not open for further replies.

Share This Page