Solved WorldEdit and WorldGuard not working

Discussion in 'Bukkit Help' started by Charleycat44, May 22, 2019.

Thread Status:
Not open for further replies.
  1. Offline

    Charleycat44

    Screen Shot 2019-05-22 at 18.12.03.png Screen Shot 2019-05-22 at 18.12.15.png So, I've just set up a new server recently (I've owned servers by the same provider before and never had this issue) and the plugins WorldEdit and WorldGuard aren't working. Whenever I type //wand it says "Unknown command. Type "/help" for help." and I'm not sure what to do. I've tried installing different versions of these plugins and it still doesn't work. It may be good to mention that I'm running a 1.12.2 server at the moment but I don't know if that has anything to do with the issue. It's also probably helpful to mention that when I type /help WorldEdit or /help WorldGuard, nothing comes up under the message, I will provide screenshots if you don't get what I mean (they are the screenshots above).

    Here is the console error message, I really need your help as I can't continue creating this server without these plugins. If you need any extra info i'll try my best to provide it!

    Thanks!

    Error message:

    [ERROR] Ambiguous plugin name `WorldGuard' for files `plugins/worldguard-legacy-7.0.0-rc-1.jar' and `plugins/worldguard-bukkit-6.2.2.jar' in `plugins'

    [ERROR] Ambiguous plugin name `WorldEdit' for files `plugins/worldedit-bukkit-7.0.0-rc-2.jar' and `plugins/worldedit-bukkit-6.1.9.jar' in `plugins'

    [ERROR] org/bukkit/Material.isLegacy()Z (loaded from file:/pro/bin/mc/spigot/1.12.2/spigot-1.12.2.jar by [email protected]) called from class com.sk89q.worldedit.bukkit.WorldEditPlugin (loaded from file:/home/gs-40792/plugins/worldedit-bukkit-7.0.0-rc-2.jar by [email protected]). initializing WorldEdit v7.0.0-rc-2;7be00cc (Is it up to date?)

    [ERROR] [WorldEdit] Plugin WorldEdit v7.0.0-rc-2;7be00cc has failed to register events for class com.sk89q.worldedit.bukkit.WorldEditListener because org.bukkit.event.player.PlayerCommandSendEvent does not exist.

    [ERROR] Could not dispatch event: [email protected] to handler EventHandler{priority=NORMAL}

    [ERROR] Error occurred while enabling WorldGuard v7.0.0-rc-1;d542ba7 (Is it up to date?)
     
  2. Online

    timtower Moderator Moderator

    @Charleycat44 Delete all worldedit / worldguard jar files, remove the folders.
    Install 1 version of worldguard and 1 of worldedit.
     
  3. Offline

    Charleycat44

    Thank you so much! Everything is properly working now and I'm grateful for your help! :)
     
  4. Online

    timtower Moderator Moderator

    Glad that I could help.
    Marked the thread as solved.
     
Thread Status:
Not open for further replies.

Share This Page