[WIN/MAC/LINUX][Tool]Plugin Development Kit - develop plugins easier & quicker

Discussion in 'Resources' started by tomsik68, Jan 9, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I tried readding the system library, but it still is giving me the same error. Also, I was using the new template.

    Ok it seems I fixed that problem. I had to download the ebeans library and link that library in. However, I am now getting an error when calling the constructor of my super class in my main java file.

    public meatgun(PluginLoader pluginLoader, Server instance,
    PluginDescriptionFile desc, File folder, File plugin,
    ClassLoader cLoader) throws IOException {
    super(pluginLoader, instance, desc, folder, plugin, cLoader);

    The problem is there on the super call.

    The constructor JavaPlugin(PluginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is undefined

    It seems like that constructor doesn't exist.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  2. Offline


    is there a file i can fun on mac?
  3. Yeah, just replace it with JavaPlugin()
    Sorry there are currently no mac versions. *I think* you can try to find some windows emulator or something similar. I'm always thinking about recoding this in java so there will be less issues with cross-platform running.
  4. Offline


  5. Don't worry the java version is on the way :) .
  6. Offline


  7. Offline


    I cant find any Archive download!! I only see the .txt.. Ahrg!
  8. Offline


    Are you talking about the bukkitpluginkit.exe.txt file? If so, step 2 in the first part of the post says to remove the .txt extension.
  9. Offline


    I did, but nothing happens!
  10. Check out if you have DISABLED hiding extensions of known file types. On Win XP you can find it in My Computer>Tools>Folder Options and on Vista/7 it's in Control Panel>Folder Options.
    When you remove the .txt extension windows should think it's an executable and you should see 7zip's icon there. Just launch the executable and extract it wherever you want.
  11. Offline


    Where is the bukkit.jar(/bukkit-0.0.1-snapshot.jar)? I find only the craftbukkit.jar(/craftbukkit-0.0.1-snapshot.jar).

    EDIT: I found the file.
  12. Offline


    Grate Tool Thanks!!!
  13. BTW do you( ALL USERS OF BPK ) use any other IDE(s) than Eclipse?
  14. New update is out! Read the 1st post :D.
  15. Offline

    Huw Huwson

    I'm getting this error on startup:

    "Can't load hooks! Please check the approporiate file."

    I'm using the Jar version on OSX Snow Leopard. Do you know what the problem might be?
  16. Offline


    Thank you so much!​
  17. Have you extracted entire "java version" directory?
    If you did so, try copying "java version/data/hooktypes.txt" to "java version/template/hooktypes.txt" . It should work then.
  18. Offline


  19. Offline


    Thanks for this info. I am not having any knowledge about this so, this stuff is really going to help me in same & providing knowledge to me.
  20. Offline


    Where's the download? =P
  21. I didn't notice it disappeared(it was an attachment). I'm sorry for that. It's available on SourceForge.
Thread Status:
Not open for further replies.

Share This Page