Will Bukkit update for pre-release or leaked builds?

Discussion in 'Bukkit News' started by EvilSeph, Oct 11, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    As I'm sure we're all aware, Mojang have adopted a new development and distribution model for Minecraft since around 1.8 was in development: pre-release builds. Though it really goes without saying, I'd like to make Bukkit's stance clear on these and other experimental builds:

    At this point in time, Bukkit will not be supporting any build that is not an official update for Minecraft released by Mojang. If Mojang don't feel that they can recommend and stand by the builds they've released, then what makes you think we can recommend them either?

    Keeping up with pre-release builds is an unrealistic feat. With each Minecraft update released we need to rewrite a large portion of CraftBukkit in order to make our work compatible with the Minecraft update. As it stands, the amount of work it would require to update our work for every pre-release is not worth it, especially if that work becomes outdated within two weeks or so.

    Thanks for your support and understanding in this matter.
     
    ratty, AegisZephyr, Brush and 22 others like this.
  2. I didn't say it couldn't be fixed. I said that it was a huge problem that Notch somehow managed to create.
     
  3. Offline

    Don Redhorse

    well I agree with EvilSeph.. it doesn't make sense to support constant changes to content and servers.. even if you would get a pre-release bukkit... the developers will not keep up with it.

    also I wonder why nobody commented on the fact that up to some time ago the 18th of October was the end of all new content and afterthat only fixes...

    I think the "strange way" mojang works have sneaked up to them and that we only see a feature closed BETA on Minecon (like they did on the other gaming conference too) and that the final version will take up to december to be put out.

    IF they would use the pre-releases to fix bugs it would look different, but as they are introducing new bugs with every feature they add in the pre-releases it wont... you should have learned that now...
     
  4. Offline

    ViperZeroOne

    Agreed... Seems that server hosts are the ones who are getting stuck between a rock and a hard place. Since they pre-released 1.9 my server has been empty, so like you I'm paying for something that's not being used by anyone (including myself). I'm seriously contemplating putting the Mojang 1.9 Pre4 server online, regardless of the bad coding, just to get my players back. I appreciate everything the Bukkit team does, and I do understand and respect their position, but between Mojang's pre-release fiasco and Bukkit's refusing to support pre-releases they've really left some of us out in the cold.
     
    Addicust and Bios Element like this.
  5. Offline

    ashthaniel

    so that means you Bukkit gonna wait for the 1.9 full version?

    and MC;1317 make me delay on my own server.[creeper]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 20, 2016
  6. Offline

    tunnelrat

    Fully understand/support/agree... it's not only unrealistic, it's already incredible the amount of time you guys invest to turn a good base game into something fun enough to be realistically persistent in a multi-player environment!

    One thing (yeah yeah, grammar nazi):

    Don't should be doesn't =)

    I think you mean that you experienced previously absent delays after installing MC 1317, as the underlying cause could be any number of variables.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 20, 2016
  7. Offline

    Axiz

    Because of these updates, my server is DESTROYED! Thanks >:l
     
  8. Offline

    cholo71796

    He also says "Mojang have." It's not a mistake; he's referring to the people who make Minecraft. While I don't write like this, it's pretty common.
     
  9. Offline

    JoneKone

    Yeah yet another Notch Fail
     
  10. Offline

    SwearWord

    Guys stop masturbating.
     
  11. Offline

    JoneKone

    Never
     
    PatrickFreed likes this.
  12. Offline

    Emiya Shirou

    I don't want to bitch but it's the same with 1.8, they have leave loots of bugs that in old releasing circle would have been fixed, but now they are left to be fixed in 1.9/final
     
  13. Offline

    ambientmf

    I don't really think it's a matter of Bukkit refusing to support pre-rel's, but more so being feasibly unable to. You people really need to quit bitching and contribute if you think its so easy.

    Btw, I'm mad as hell @ Mojang for these nonsense pre-releases...However, I hold none of the same feelings towards the Bukkit team who, unlike Mojang, have no financial incentive to develop Bukkit...I don't see anyone here paying for Bukkit itself, hm? You were dumb enough to pay for server hosting services for alpha/beta software, so suffer the consequences....but don't blame Bukkit, who do this shit for free.
     
    corben and Rich Boos like this.
  14. Offline

    Jon Cherwin

    I agree, wtf Mojang, release actual updates (/._.)/
     
    Monk3y likes this.
  15. Offline

    cyberdude

    1) Not one single person in this thread complained about Bukkit. Only complaints were about Mojang.

    2) @SwearWord and @Kaikz That wrote "Update to 1.9 or going to canary" and another update now message were very likely being sarcastic. Swearword is a very well respected and very close to the team, and he wouldn't say stuff like that without being sarcastic. Kaikz message about Canary is a pun on Canaries VERY SLOW release cycles because of the way Canary is build(maintained?), 3-4 days before Kaikz wrote that message Canary had just released a stable 1.8.1 build. So threatening to move to Canary is obviously a joke (For the Minecraft knowledgeable). Unless of course Kaikz is an idiot and really meant what he said, then I apologize for being wrong.

    3) Mojang should NOT just be cramming stuff in. A game should not loose so much performance just because XP Orbs and 2? new creatures where added. That is just wrong, and clearly shows that they should not just be cramming shit in. Each release have showed degraded performance each time new stuff have been added. If they continue this route, then final will be unplayable over the internet. 1.8.1 already has massive problems, and 1.9 so far haven't showed the much needed improvements either. They should add new content, but cramming shit in just for the heck of it, is wrong in such a game with so low-res but high performance requirements.
     
    PatrickFreed and scrub88 like this.
  16. Offline

    Kaikz

    No man, I'm totally serious.
    of course it was a joke. :|
     
  17. Offline

    Flextt

    Finally, I see some people who are not simply in awe of the upcoming features (hurray yet another useless dimension for a year?) but are increasingly uncomfortable with Mojangs attitude of adding features that feel... unrefined and leaving behind one mess of a code. While I barely know any Java, things like the Lagspike of Death or why my Crysis 2 viable Laptop has problems with Minecraft are signs enough for me to realize, that the code must be a battlefield. I wonder, how they want to release that much additions & bring out a _rather_ bugfree release before their codefreeze. And we can suspect, that this code freeze will pretty much be the sign for the Bukkit guys to bring out its last big release.

    While I sympathize with ViperZeroOne's issue, basing Bukkit on development builds is just unrealistic thanks to
    - fast development cycles on Mojang's side (Code being written, then rewritten, optimized, added etc)
    - tremendous amount of bugs, be they game-breaking or not
    Since I truly appreciate the work being done here from both Bukkit & the plugin developers, I will punch Mojang in the face if they implement yet another mod (I suspect Optifine to be a possibility to be included soon), that fixes the mess they leave behind. Please note, I am no optifine fanboy per se, it is simply a very popular possibility to vastly increase your FPS and it worked for me.
     
  18. Offline

    EarthBoundNess

    Hmmm...I can see you not making them recommended builds, but what about NON-recommended builds? Why don't you try that? I use those all the time and I have no problem with it...
     
  19. They are writing code using the 1.8.1 code. They haven't even bothered trying to take on 1.9.
     
  20. Offline

    Obelisk429

    Now that there has been a code freeze, wouldn't it make sense to work towards an RB of the latest pre-release version?
     
  21. Offline

    Dragonslife

    It's completly understandable and also i completly agree with this. No further comment.
     
  22. Offline

    croxis

    It isn't a code freeze but a feature freeze. That means after today no new features will be added but fixes and improvements to existing features.
     
  23. Offline

    jeexbit

    Folks, keep up the great work - it goes without saying that we support you 100%.

    Sucks about the no official 1.9 release from Notch and Co. though - I've decided (for the first time in a year of admining a server) to just go ahead and update my server to 1.9 and hope that my players are comfortable with updating their clients manually. I just can't wait any more really, and want to get on into the 1.9 features and fun!

    I'll be keeping an eye out for future Bukkit updates and again: thank you so much for all of the hard work that goes into maintaining it - I cannot even imagine the amount of energy that requires. Kudos to you!
     
  24. Offline

    EdGruberman Retired Staff

    I see two distinct topics here. The first is recommending a pre-release. The second is the amount of work that goes into updating Bukkit.

    I don't think anyone is suggesting Bukkit put out a Recommended Build for a pre-release. The same as Mojang is doing seems prudent with Bukkit; Interim builds that promise nothing but at least give those a chance that want to, the ability to experiment and take their own risks. I believe this solution fits perfectly with the Recommended Build process Bukkit employs already.

    I also don't think anyone is not recognizing the amount of work that goes into updating Bukkit currently. I'm not sure how to engage this discussion without offending anyone, but I feel it's an important topic that should be addressed; The last few updates I've seen a huge focus from @Dinnerbone on the update process. Certainly others help, but it seems very single threaded through only a few developers (I think @Grum helps a lot too?). I'm definitely an outsider, so I really have zero clue on my perception versus reality here. But I can't help but wonder if we are overlooking some other update process that might be more efficient? Is it possible to engage other/new developers in the update process? Or is this simply the only solution that exists for updating Bukkit?

    I'm honestly new to Java and development of such large projects in general. So I'm sure there is more complexity to this than I understand. But I'm hoping there are some professional developers that are familiar with these types of large scale projects and the efforts involved that might either be able to help streamline/improve some automation efforts or at least be able to pitch in and share the load somehow?

    Am I totally off base here? I really don't want to see the Bukkit team overwhelmed and burn out. Can we get reinforcements to help distribute the load of an update?
     
  25. Very good, Ed. That's how we go about it, or should, rather- having a larger crew (albeit not the normal crew, nor per se as skilled) make a build for the pre-releases. Notch has placed a code freeze (new features will no longer be added, but existing ones will be corrected and modified) on the game until it's release date (which, according to word of mouth amongst my friends, is the 18th?), so we know that new features, besides what was (as Notch did indeed tweet) "crammed" into the game, after 1.9 PR4.

    Logically, at that point, the last major pre-release will be the next one, 1.9 PR5. At that point, there'll be no new features- just content repairs. Things like performance enhancement and bug squashing. So, who's to say that there won't be a crew of people to develop, on their own or with Team Bukkit, a version for 1.9 PR5?

    Like it's been said a million times over on this server, there are already server hosts suffering who pay money to have a server running, and because Bukkit and Mojang split ways on their logic in releases. Bukkit thinks that pre-releases are too impromptu and incomplete to make into a full software, plus it takes a lot of codework and such. Mojang seems to think that the versions are good enough to compile into a new version for people to try. And of course, people are going to play it. When's the last time you heard of someone thinking to themself, "no thanks, I'll just take the older, less complete version of the game?"

    Also, what I've seen nobody mention on this thread AT ALL is the fact that Mojang also puts a great deal of work into developing Minecraft in the first place. Nobody has accredited Mojang for even coming thus far to produce 1.9. Nobody said they had to release these features in the first place to you all. Some of you, as cruel as it sounds, are just completely selfish, unaware of the kind of effort required to develop a video game, and come close to meeting the release date set for the game. You are just complaining about it because A) you're losing money as a server host in downtime or B) you want the latest and the best, and waiting for Bukkit in 1.9 is taking too long for you.

    So, while it would take a whole effort by an assisting crew, if those of you who want there to be a Bukkit for 1.9, then go ahead. Gather your finest men and make it yourself. Because, as they said, Bukkit isn't going to make it for you.

    How dedicated are you?

    EDIT: Code freeze is the wrong term, but it's the one Notch used.
     
  26. Notch said feature freeze, which is what it actually is.
     
  27. Offline

    voodoo368

    He originally called it a code freeze, then later corrected it saying feature freeze.
     
  28. Offline

    TheRealKANi

    Dudes.. What the h*** is happening for the plugin loader module in org.bukkit.plugin.java.JavaPluginLoader.
    It "litterly" throws up when i'm stopping my server.. It's all plugins, not just one. I noticed this aswell with build 1317..

    Server Info (open)


    I'm running bukkit ver 1337 with the following plugins:

    iConomy - Celty - Bukkit: v. 1317
    PermissionsEx - v1.15 - Bukkit: v. 1317
    CashFlow - v1.0 - Bukkit: v. 1317
    SimpleClans - v1.7.3 - Bukkit: v. 1317
    Citizens - v1.1.2 - Bukkit: v. 1240
    Death And Rebirth - v2.5.1b - Bukkit: v. 1185



    Server.log (open)

    2011-10-19 22:24:40 [INFO] Starting minecraft server version Beta 1.8.1
    2011-10-19 22:24:40 [INFO] Loading properties
    2011-10-19 22:24:40 [INFO] Starting Minecraft server on *:25565
    2011-10-19 22:24:40 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1126-g35eac7a-b1317jnks (MC: 1.8.1)
    2011-10-19 22:24:41 [INFO] [PermissionsEx] sql backend registered!
    2011-10-19 22:24:41 [INFO] [PermissionsEx] file backend registered!
    2011-10-19 22:24:41 [INFO] [PermissionsEx] PermissionEx plugin initialized.
    2011-10-19 22:24:41 [INFO] [PermissionsEx] p2compat backend registered!
    2011-10-19 22:24:41 [INFO] [PermissionsCompat] Compatibility Layer Initalized!
    2011-10-19 22:24:41 [INFO] [PermissionsEx] Initializing file backend
    2011-10-19 22:24:41 [INFO] Preparing level "SandBox"
    2011-10-19 22:24:41 [INFO] Default game type: 0
    2011-10-19 22:24:42 [INFO] Preparing start region for level 0 (Seed: 2854632856775260916)
    2011-10-19 22:24:43 [INFO] Preparing spawn area: 89%
    2011-10-19 22:24:43 [INFO] Preparing start region for level 1 (Seed: 7679304336462859952)
    2011-10-19 22:24:44 [INFO] Preparing spawn area: 89%
    2011-10-19 22:24:44 [INFO] [Death and Rebirth] Messages loaded.
    2011-10-19 22:24:44 [INFO] [Death and Rebirth] Graves loaded.
    2011-10-19 22:24:44 [INFO] [Death and Rebirth] Shrines loaded.
    2011-10-19 22:24:44 [INFO] [iConomy - Celty] Enabled (31 ms)
    2011-10-19 22:24:44 [INFO] [PermissionsEx] Superperms support enabled.
    2011-10-19 22:24:44 [INFO] [PermissionsEx] v1.15 enabled
    2011-10-19 22:24:44 [INFO] [ChatManager] ChatManager enabled!
    2011-10-19 22:24:44 [INFO] [Modifyworld] Modifyworld enabled!
    2011-10-19 22:24:44 [INFO] [PermissionsCompat] Compatibility layer enabled.
    2011-10-19 22:24:44 [INFO] [Citizens] NPC types loaded: blacksmith, guard, healer, quester, trader, wizard
    2011-10-19 22:24:46 [INFO] [Citizens] Permissions system found (PermissionsEx v1.15)
    2011-10-19 22:24:46 [INFO] [Citizens] version [1.1.2] loaded.
    2011-10-19 22:24:46 [INFO] [Citizens] Economy plugin found (iConomy v6)
    2011-10-19 22:24:46 [INFO] [SimpleClans] Version 1.7.5 loaded
    2011-10-19 22:24:47 [INFO] SQLite Connection successful
    2011-10-19 22:24:47 [INFO] Payment method: iConomy v6
    2011-10-19 22:24:47 [INFO] Server permissions file permissions.yml is empty, ignoring it
    2011-10-19 22:24:48 [INFO] Done (0.627s)! For help, type "help" or "?"
    2011-10-19 22:24:48 [INFO] [Citizens] Loaded 0 NPCs.
    2011-10-19 22:24:48 [INFO] [Citizens] Loaded 0 quests.
    2011-10-19 22:24:56 [INFO] CONSOLE: Stopping the server..
    2011-10-19 22:24:56 [INFO] Stopping server
    2011-10-19 22:24:56 [SEVERE] Error occurred while disabling Death and Rebirth v2.5.1b (Is it up to date?): null
    java.lang.NullPointerException
    at muCkk.DeathAndRebirth.ghost.Ghosts.onDisable(Ghosts.java:539)
    at muCkk.DeathAndRebirth.DAR.onDisable(DAR.java:48)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:172)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:978)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:24:56 [INFO] [iConomy] Closing general data...
    2011-10-19 22:24:56 [INFO] [iConomy] Disabled. (0 ms)
    2011-10-19 22:24:56 [SEVERE] Error occurred (in the plugin loader) while disabling iConomy v6.0.7b (Is it up to date?): null
    java.lang.NullPointerException
    at java.lang.Class.isAssignableFrom(Native Method)
    at org.bukkit.plugin.java.JavaPluginLoader.removeClass(JavaPluginLoader.java:245)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:992)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:24:56 [INFO] [PermissionsEx] v1.15 disabled successfully.
    2011-10-19 22:24:56 [INFO] [ChatManager] ChatManager disabled!
    2011-10-19 22:24:56 [SEVERE] Error occurred (in the plugin loader) while disabling ChatManager v1.15 (Is it up to date?): null
    java.lang.NullPointerException
    at java.lang.Class.isAssignableFrom(Native Method)
    at org.bukkit.plugin.java.JavaPluginLoader.removeClass(JavaPluginLoader.java:245)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:992)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:24:57 [INFO] [Modifyworld] Modifyworld disabled!
    2011-10-19 22:24:57 [SEVERE] Error occurred (in the plugin loader) while disabling Modifyworld v1.15 (Is it up to date?): null
    java.lang.NullPointerException
    at java.lang.Class.isAssignableFrom(Native Method)
    at org.bukkit.plugin.java.JavaPluginLoader.removeClass(JavaPluginLoader.java:245)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:992)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:24:57 [SEVERE] Error occurred (in the plugin loader) while disabling Permissions v2.7.7 (Is it up to date?): null
    java.lang.NullPointerException
    at java.lang.Class.isAssignableFrom(Native Method)
    at org.bukkit.plugin.java.JavaPluginLoader.removeClass(JavaPluginLoader.java:245)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:992)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:24:57 [INFO] [Citizens] version [1.1.2] disabled.
    2011-10-19 22:24:57 [SEVERE] Error occurred (in the plugin loader) while disabling Citizens v1.1.1 (Is it up to date?): null
    java.lang.NullPointerException
    at java.lang.Class.isAssignableFrom(Native Method)
    at org.bukkit.plugin.java.JavaPluginLoader.removeClass(JavaPluginLoader.java:245)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:992)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:24:57 [INFO] [Citizens] An error has occurred, please wait while it is sent to the developers...
    2011-10-19 22:25:02 [INFO] [Citizens]
    2011-10-19 22:25:02 [INFO] [Citizens] Citizens Error Reporting - Powered by CreeperHost.net
    2011-10-19 22:25:02 [INFO] [Citizens] Below is the stacktrace that has been transmitted to the developers, no other information has been included other than Citizens version information.
    2011-10-19 22:25:02 [SEVERE] Error occurred (in the plugin loader) while disabling SimpleClans v1.7.5 (Is it up to date?): null
    java.lang.NullPointerException
    at java.lang.Class.isAssignableFrom(Native Method)
    at org.bukkit.plugin.java.JavaPluginLoader.removeClass(JavaPluginLoader.java:245)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:992)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:166)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-19 22:25:02 [INFO] Saving chunks


    FYI.. Just tested build 1344... now only Death and Rebirth goes ballistic.. but thats an "old" plugin from 1185+...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 20, 2016
  29. Offline

    Evenprime

    Your server log from before shows that you used 1317, not 1337. The problem is fixed in 1337.
     
  30. Offline

    Sketaful

    I bought the game, payed them real money and sure as hell have a right to atleast complain some. That's the nice part about paying for something. It makes it ok to complain some. I'm not gonna be "impressed" by them coming as far as Beta 1.9 since I bought the game with the hope of experiencing the game without "beta" in the name.

    I've actually haven't noticed anyone asking for all this extra features. Rather the oposite, "don't add more stuff, fix the game" is what I've heard. So I'm supposed to credit Mojang for doing the oposite of what I'd liked them to have done?

    Oh, and if there is any grammar-police around. Yeah, I know that to. :p
     
    cyberdude likes this.
  31. Offline

    cyberdude

    Exactly my thoughts when I read that post, but I didn't really care to comment.
     
Thread Status:
Not open for further replies.

Share This Page