Whitelist plugin configuration problems

Discussion in 'General Help' started by skippyV, May 3, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Noobie here. Have a virtual private server working with craftbukkit-1.8.3-R0.1-SNAPSHOT-latest.jar.
    However at this point I can only login into the server using ssh. I can't yet play the game with a command console available within the game - if that makes any sense.

    Before I used the Bukkit Whitelist plugin this is what I did:
    If I set "whitelist=false" in 'server.properties', then I can play minecraft as a user with no problem.
    If I add a username to "white-list" (or "white-list.txt" or "whitelist.txt", I've tried all three version!), and set 'whitelist' to true in 'server.propertie', then the JSON file gets generated as expected with the username but the message comes back "you are not whitelisted".

    At this point I thought maybe I HAVE to use the bukkit plugin to do whitelists?! Since I'm using 'bukkit'.

    So I added the plugin, put 'server.properties' back to "whitelist=false" and restarted the minecraft service, and it still acts just like it did from the previous attempts at white-listing without the plugin.

    What else can I check? It has to be something I can do at the server level because like I said - I still haven't got it figured out on how to admin from within the minecraft game. I figure setting up whitelisting should be my first priority.

  2. Offline


    With the built-in Bukkit whitelist:

    Stop your server, set whitelist=false, and delete the whitelist.json from the root directory of your server.
    Start server.
    Join server.
    Do "/whitelist add <your username>"
    Do "/whitelist on"
    Relog and see if you're able to join.
  3. Offline


    Ahhh... I see. Thanks, OceanSkatr.
    Didn't realize one would have that level of control by just joining a server that is "open" with default configuration.

    Anyways, I got impatient and wound up downloading/building Spigot and repeating the steps I wrote above. And it worked with Spigot. Same steps and even same init.d script (adjusted for Spigot install). So I'm not sure what went wrong with Bukkit. I'll just stick with Spigot for now.
    Thanks again!
  4. Offline

    timtower Administrator Administrator Moderator

    Moved to Bukkit alternative
  5. Offline


    @skippyV Good choice, I use Spigot too :)
Thread Status:
Not open for further replies.

Share This Page