What is the error here

Discussion in 'Plugin Development' started by zombieman1000, Apr 28, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I Was testing my plugin and i ran into some error's

    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(
    Time: 28/04/13 4:30 PM
    Description: Exception in server tick loop
        at net.minecraft.server.v1_5_R1.DedicatedServer.am(DedicatedServer.java:257)
        at net.minecraft.server.v1_5_R1.DedicatedServer.a(DedicatedServer.java:203)
        at net.minecraft.server.v1_5_R1.MinecraftServer.run(MinecraftServer.java:416)
        at net.minecraft.server.v1_5_R1.ThreadServerApplication.run(SourceFile:573)
    A detailed walkthrough of the error, its code path and all known details is as follows:
    -- System Details --
        Minecraft Version: 1.5
        Operating System: Windows 8 (x86) version 6.2
        Java Version: 1.7.0_21, Oracle Corporation
        Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
        Memory: 992146576 bytes (946 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)
        JVM Flags: 2 total; -Xms1024M -Xmx1024M
        AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
        Suspicious classes: [net.minecraft.server.v1_5_R1.ICommandListener, IMojangStatistics, IDataManager, ...], [org.bukkit.World, BlockChangeDelegate, Server], [org.bukkit.block.BlockState], [org.bukkit.command.CommandSender, RemoteConsoleCommandSender], [org.bukkit.configuration.serialization.ConfigurationSerializable], [org.bukkit.craftbukkit.Main], [org.bukkit.craftbukkit.libs.jline.TerminalFactory, Terminal, Flavor, ...], [org.bukkit.craftbukkit.libs.jline.console.ConsoleReader, CursorBuffer, ConsoleKeys, ...], [org.bukkit.craftbukkit.libs.jline.console.completer.CompletionHandler, CandidateListCompletionHandler], [org.bukkit.craftbukkit.libs.jline.console.history.History, MemoryHistory], [org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader, Configuration, Log], [org.bukkit.craftbukkit.libs.joptsimple.OptionException, OptionParser, OptionSpec, ...], [org.bukkit.craftbukkit.libs.joptsimple.internal.AbbreviationMap, ReflectionException, Reflection, ...], [org.bukkit.craftbukkit.v1_5_R1.LoggerOutputStream], [org.bukkit.craftbukkit.v1_5_R1.inventory.CraftItemStack, CraftRecipe, CraftShapedRecipe, ...], [org.bukkit.craftbukkit.v1_5_R1.potion.CraftPotionEffectType], [org.bukkit.craftbukkit.v1_5_R1.util.Waitable, ServerShutdownThread, TerminalConsoleHandler, ...], [org.bukkit.entity.Entity], [org.bukkit.event.Event, Cancellable, HandlerList, ...], [org.bukkit.event.block.BlockEvent, BlockFadeEvent, BlockGrowEvent, ...], [org.bukkit.event.entity.EntityEvent, EntityInteractEvent, EntityDamageEvent, ...], [org.bukkit.event.hanging.HangingEvent, HangingPlaceEvent], [org.bukkit.event.painting.PaintingEvent, PaintingPlaceEvent], [org.bukkit.event.player.PlayerEvent, PlayerInteractEvent, PlayerFishEvent], [org.bukkit.event.server.ServerEvent, MapInitializeEvent, ServerCommandEvent], [org.bukkit.event.world.WorldEvent, WorldSaveEvent, WorldInitEvent, ...], [org.bukkit.inventory.ItemStack, Recipe, ShapedRecipe, ...], [org.bukkit.map.MapView], [org.bukkit.metadata.Metadatable], [org.bukkit.permissions.ServerOperator, Permissible], [org.bukkit.plugin.messaging.PluginMessageRecipient], [org.bukkit.potion.PotionEffectType, PotionEffectTypeWrapper], [org.fusesource.hawtjni.runtime.Library], [org.fusesource.jansi.AnsiOutputStream, WindowsAnsiOutputStream, AnsiConsole, ...], [org.fusesource.jansi.internal.Kernel32, CONSOLE_SCREEN_BUFFER_INFO, COORD, ...]
        IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
        CraftBukkit Information:
      Failed to handle CraftCrashReport:
        at org.bukkit.Bukkit.getName(Bukkit.java:68)
        at org.bukkit.craftbukkit.v1_5_R1.CraftCrashReport.call(CraftCrashReport.java:20)
        at net.minecraft.server.v1_5_R1.CrashReportSystemDetails.a(SourceFile:74)
        at net.minecraft.server.v1_5_R1.CrashReport.h(CrashReport.java:41)
        at net.minecraft.server.v1_5_R1.CrashReport.<init>(CrashReport.java:28)
        at net.minecraft.server.v1_5_R1.MinecraftServer.run(MinecraftServer.java:426)
        at net.minecraft.server.v1_5_R1.ThreadServerApplication.run(SourceFile:573)
        Profiler Position: N/A (disabled)
        Is Modded: Definitely; Server brand changed to 'craftbukkit'
        Type: Dedicated Server (map_server.txt)
    Main plugin class
    package frostpvp;
    import org.bukkit.Material;
    import org.bukkit.command.Command;
    import org.bukkit.command.CommandSender;
    import org.bukkit.entity.Player;
    import org.bukkit.event.EventHandler;
    import org.bukkit.event.Listener;
    import org.bukkit.event.player.PlayerJoinEvent;
    import org.bukkit.plugin.java.JavaPlugin;
    import org.bukkit.inventory.ItemStack;
    public class FrostPvp extends JavaPlugin implements Listener {
        public void onDisable() {
            // TODO: Place any custom disable code here.
        public void onEnable() {
            getServer().getPluginManager().registerEvents(this, this);
        public void onPlayerJoin(PlayerJoinEvent event) {
            event.getPlayer().sendMessage("Welcome to this Server Hope you have a good time, " + event.getPlayer().getDisplayName() + "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!");
        * @param sender
        * @param cmd
        * @param label
        * @param args
        * @return
        public boolean onCommand(CommandSender sender, Command cmd, String label, String[] args){
        if(cmd.getName().equalsIgnoreCase("archer")){ // If the player typed /archer then do the following...
            if (sender instanceof Player) {
                  Player player = (Player) sender;
                  player.getInventory().addItem(new ItemStack(Material.DIAMOND_SWORD,1 ));
                        return false;
                    return false;
    name: FrostPvp
    main: FrostPvp.FrostPvp
    version: 1.0
        description: gives player an archer kit
        permission: frostpvp.kits.archer
        usage: just type /archer
        description: gives player a pvp kit
        permission: frostpvp.kits.pvp
        usage: just type /pvp (requires FrostPvp.kits.pvp)
        description: gives player a endermage kit
        permission: frostpvp.kits.endermage
        usage: just type /archer
        description: gives player a stomper kit
        permission: frostpvp.kits.stomper
        usage: just type /stomper
        description: gives player a fisherman kit
        permission: frostpvp.kits.fisherman
        usage: just type /fisherman
        description: gives player a superman kit
        permission: frostpvp.kits.superman
        usage: just type /superman
    so what is making this error

    As you can see in the plugin main class all the plugin has to do is load the plugin.yml archer file and then give me a sword

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 1, 2016
  2. That's a crash and it doesn't seem to point to your plugin. Have you tested more than one time ? Does the server actually crash or do you have errors in console, those would be useful.
  3. Offline


    It's not caused by your plugin.
    Try redownloading craftbukkit.
  4. Offline


    Off topic:

    MCPVP kits, how original.
  5. Offline


    i just get error's in the console. And i tested it 2 times and it still has error's

    ya as a matter of fact i think i had downloaded a beta craftbukkit build

    also you may want to fix the setting_up_aserver page cause i click download latest recommended build and it gave me craftbukkit-1.4.7-r1.0.jar

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 1, 2016
  6. Offline


    That is the latest recommended build. There's nothing wrong with that page.
  7. Offline


    ya found that out after posting it.
    anyway back on topic i was reading the error in the console and it says the plugin does not have a plugin.yml but im 99.9% sure that if you hit the hammer in netbeans it will put the hole project in the jar
  8. zombieman1000
    Open the jar with an archive program to be sure that it's there, it needs to be in the root.
  9. Offline


    Digi i looked in the folder frostpvp and there was frostpvp.class and plugin.yml
  10. zombieman1000
    The plugin.yml must be outside of that folder, in the root.

    Also I suggest you use more descriptive package naming... "me.zombieman1000.frostPVP" for example, if it overlaps with other packages you'll have silent issues.
  11. Offline


    Digi now in the jar file i got Frostpvp folder (took the jar out) Meta-INF and the plugin.yml is that correct
  12. Offline


    Digi i did but im still getting error's
  13. zombieman1000
    Then why didn't you say that ? And is it the same error or ... just post the error from the console.
Thread Status:
Not open for further replies.

Share This Page