What do these errors mean?

Discussion in 'Plugin Development' started by Rmarmorstein, Dec 2, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    So i wrote a plugin, and on my server it worked perfectly.

    Here is the Error:

    13:57:30 [SEVERE] Could not load 'plugins\ezdonor.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError
    : us/rivertech/ezdonor/ezDonor : Unsupported major.minor version 51.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:227)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:205)
        at net.minecraft.server.ServerConfigurationManagerAbstract.<init>(Server
        at net.minecraft.server.ServerConfigurationManager.<init>(SourceFile:11)
        at net.minecraft.server.DedicatedServer.init(DedicatedServer.java:111)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:398)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:856)
    Caused by: java.lang.UnsupportedClassVersionError: us/rivertech/ezdonor/ezDonor
    : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$000(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
        ... 9 more 
    Any ideas on what this means, or what it could be, and if it is the plugin or the server? I can give more information or the code if needed.
  2. Offline


    You compiled against Java 7, while your server is using Java 6. Just use Java 6 as there are a lot of servers using that
  3. Offline


    so for the JRE use Java 6, i was using 7 on my server and it worked fine, i was getting complaints this was happening.
  4. Offline


    you should use JDK 6 to compile. I am not talking about JRE
  5. Offline


    Ohhhh! Ok, Thank you. So i can use JRE 7 in eclipse, i just need to compile with JDK 6?
  6. Offline


  7. Offline


    when i go window > prefrences > copiler > then choose 1.6 that is the same as JDK 6, and 1.7 is the same as jdk 7 or?
  8. Offline


    Yes you can just change to 1.6

    You can do it this way..

    or right click your plugin name and then select build path, and configure build path then double click the jre to change it
Thread Status:
Not open for further replies.

Share This Page