Inactive [WEB] Webstatistic for Minecraft v1.10b [1337]

Discussion in 'Bukkit Tools' started by Terra-Network.org, May 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Survivorman

  2. Damn it .. it works with Windows and Apache for me .. do i forgot something ?!
    I'm really sorry, i will look and look again!

    Ohhhhhh!

    Did you had a look into Changelog?
    Because the two lines i wrote are missing inside the config.php!
    I will add them now.

    *edit*
    Changed the config.php inside WS-Core
     
  3. Offline

    Survivorman

  4. Thanks for your patience and your feedback! :D
     
  5. Offline

    GmK

    Ohhh...I thought those two lines were optional if you want the feature :D

    Gosh, such an easy fix :D Thank you so much for the work on this!
     
  6. My pleasure!
    Now I know why I have not found the error ;)

    Next step is Jobs 2.0 and McMMO-Support! :)
     
  7. Offline

    kush

    Hey again, was the edit for my problem? I did upload the new functions.php and still have the same problem with player achievements. Or are you still working on a fix for this?
     
  8. It's still uptodate, i will work on it tomorrow!
    I have to test some things with the achievements.txt, maybe there's the problem or something with the database-connection.
    I'll find it! :)

    Had a look at the script and tested the sql-query again.
    Did you set the correct database-name for the achievements-plugin?
    For me it's "playerachievements" and content is: "player", "achievement", "count"
    Correct?
    The table "ws_achievements" is the script-table of WS-Achievements with content:
    "ws_a_id", "ws_a_name", "ws_a_points", "ws_a_category", "ws_a_stat", "ws_a_value", "ws_a_description", "ws_a_reward", "ws_a_amount"
    Correct?

    If not, please post your table-names.
    The achievements-page is loading properly, so there is no error with the installation, i think it's a problem with the connected sql-query.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 16, 2016
  9. Offline

    kush

    Tables and titles match up. Only difference is in the playerachievements table I have "time". I removed that and everything is showing up correctly. Thank you very much!
     
  10. Fine!
    Maybe i should switch the kind of query to be more resistant to such things.
     
  11. Offline

    kush

    Can you add pages to the currency page please?
     
  12. Offline

    tha d0ctor

    isn't the stats/achievements plugin this is based off currently broken?
     
  13. No, works fine for me with CB 803
    Didn't tested it with 818 yet.
    New Blocks, not supported by Stats, will be included with Webstatistics, so there's no problem.
     
  14. Offline

    kush

    stats/achievements seems to be working fine on 818. I'm at 820 for multiverse and still seems to be working. I hope someone picks up the plugins. I really hate to see such useful plugin die.
     
  15. Offline

    hofec

    @Terra-Network.org

    please make Jobs 2.0.0+ compatible :confused: i really love this webstats and i want all your stuff up-to-date and functional [diamond]
     
  16. Already had a look into v2. Shouldn't be hard, but actually my freetime is limited. Maybe weekend.
     
  17. Offline

    tom

    ETA on the mcmmo release?
     
  18. Offline

    11RJB

    I've been fighting with the achievements and jobs portion of this for days... I can't figure out how to configure them.

    Both plugins are working properly in-game, however, I don't see how to configure the WS for them like with the iConomy WS plugin, using the iconomy-config.php file.

    Both plugins do not use the default prefix... would this affect WS in any way? I've added the correct prefix to the config.php, but is still doesn't read the tables properly.
     
  19. Added support for Jobs-Plugin version 2.0
    Download "ws_jobs.zip" again!

    I'm sry with McMMO!
    I will add it, but actually i've got no time to work on.
    I'm on vacation at end of June / begin of July and i will try to add it after!
     
  20. Offline

    andrewpo

    Looks great :D You should put this in the plugin releases forum to give it more attention :)
    Remember to put [RB860] in the title too as per the guidelines :p

    I'll give it a go on my server later.
     
  21. Offline

    tom

    Ok, thank your time :)
     
  22. Offline

    kush

    Hello, are you going to be added pages to the iconomy part? also can you add a search function please?
    Thanks!
     
  23. Pages for iConomy, ok!
    Search for Players? Should be easy! :)
     
  24. Offline

    moose517

    I'm having an issue with this, just came across it tonight and so far i love it, the first time i view a specific players stats page there avatar shows up, but then any time after that nothing, any clue why?
     
  25. Offline

    MikeThePickle

    I keep getting this error but I didn't specify mikethe_stats as a username. I put mikethe_mikethe as a username.

    Fixed it...on line 15 of functions.php, I changed

    mysql_pconnect(WS_CONFIG_DBHOST.":".WS_CONFIG_DBPORT, WS_CONFIG_DBNAME, WS_CONFIG_DBPASS);

    to

    mysql_pconnect(WS_CONFIG_DBHOST.":".WS_CONFIG_DBPORT, WS_CONFIG_DBUNAME, WS_CONFIG_DBPASS);

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 16, 2016
  26. Thought i changed this a time ago, will have a look :)

    @moose517
    No idea at the moment, maybe a problem with your directory-permissions?!

    @everyone else waiting for updates
    I wish i would have more time for WS, but i hope i can start working on it again next days.
     
  27. Offline

    moose517

    I actually found the problem. Line 10 of large_player_image.php i changed it to be this:
    $cache_file = '/image-cache/large_'.$_GET['nick'].'.png';

    the only difference is the / at the beginning of the string, works for me now. Still more errors i see with achievements looking through those now

    EDIT: working through the achievements stuff now, might i ask why you didn't program the achievements part itself like the plugin does? i set the table name to that of the plugins but the naming doesn't match up, i think i've about got it but the score part is wrong for sure LOL.
     
  28. Because the Achievements Table itself is missing alot of information that is stored inside the txt-file, that's why i'm using my OEM table.
     
  29. Offline

    moose517

    hmmm i understand that, but i got it working for the most part without the extra data. I just would prefer to have a single database table to update with achievements if i add more. I guess if i create a gui to add them though then it won't be a problem.
     
  30. Offline

    rbs

    I don't get it working:
    http://91.226.88.173/mcstats

    my Database contains the following:

    Code:
    mysql> SELECT * FROM mcstat.mcstat;
    +--------+----------+------------+------------+
    | player | category | stat       | value      |
    +--------+----------+------------+------------+
    | rbs90  | stats    | playedfor  |        136 |
    | rbs90  | stats    | command    |          5 |
    | rbs90  | stats    | lastlogin  | 1312648596 |
    | rbs90  | stats    | login      |          1 |
    | rbs90  | stats    | move       |         21 |
    | rbs90  | stats    | lastlogout | 1312648734 |
    +--------+----------+------------+------------+
    6 rows in set (0.00 sec)
    
    this is my config.php-file:

    PHP:
    <?php

    // Script by Jan-Eric Dre´┐Żler, Terra-Network.org, Webstats for Minecraft (c) 2011

    // Database-Information

    //Insert your host!
    define('WS_CONFIG_DBHOST''localhost');
    //Insert your port! (optional)
    define('WS_CONFIG_DBPORT''');
    //Database username
    define('WS_CONFIG_DBUNAME''mcstat');
    //Database password
    define('WS_CONFIG_DBPASS''**********');
    //Database name
    define('WS_CONFIG_DBNAME''mcstat');

    //Stats Table
    define('WS_CONFIG_STATS''stats');
    //Jobs Table
    define('WS_CONFIG_JOBS''jobs');
    //Jobs Table
    define('WS_CONFIG_LEVELCRAFT''experiencetable');
    //iConomy Table
    define('WS_CONFIG_ICONOMY''iconomy');
    //WS_Achievements Table
    define('WS_CONFIG_ACHIEVEMENTS''ws_achievements');
    //Achievements-Plugin Table
    define('WS_CONFIG_PLAYERACHIEVEMENTS''playerachievements');

    //Default Langue (de, eng, fr)
    define('WS_CONFIG_LANGUAGE''eng');

    //Default Logo "http://....."
    define('WS_CONFIG_LOGO''images/site_logo.png');
    //Server Name
    define('WS_CONFIG_SERVER''rbs_server');

    //Menu Signs (the signs between two links in the main menu!
    define('WS_OPTICAL_SIGNS''-----');

    //Number of users per page
    define('WS_CONFIG_PAGENUM'25);

    //Time in seconds, images are cached 86400 = 1day, 259200 = 3days
    define('WS_CONFIG_CACHETIME'259200);

    ?>
    I think the problem is, that I only have one table...what should I do to get multiple tables?
     
Thread Status:
Not open for further replies.

Share This Page