Inactive [WEB/ECON] WebAuction - Website based item market [1597]

Discussion in 'Inactive/Unsupported Plugins' started by Exote, Aug 24, 2011.

  1. Offline


    WebAuction - Website based item market [1597]

    Moving over to bukkitdev - New Project Page
    nicom1997, tom, andrewkm and 2 others like this.
  2. Anyone else get this?
    [SEVERE] Could not pass event PLAYER_INTERACT to WebAuction
    java.lang.NoSuchMethodError: org.bukkit.inventory.ItemStack.getEnchantments()Ljava/util/Map;
            at me.exote.webauction.WebAuctionPlayerListener.onPlayerInteract(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
            at net.minecraft.server.ItemInWorldManager.interact(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet15Place.a(SourceFile:39)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at org.getspout.spout.SpoutNetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.w(
    Using iConomy 6 and the Craftbukkit 1522.

    EDIT: I should mention that I can still add and withdraw currency using signs. Just not deposit any items to auction.
  3. Offline


    Tnx, btw bug:
    When someone adds fire resistans potion, the web auction says it is "clare potion"

    Found it, just added
    case 8259:
    return "Fire Resistance Potion (8.00)";

    It was missing from ItemInfo.php
  4. Offline


    I need some help, I'm not sure how to get this to the server, i've installed this on my server and website ... now i'm wondering how to get it to work on the server like when you do /wa password and then a password it should send it to the website and so so you will be able to login with it, it just says login failed, and when i type /wa password and a password it just says type /wa password [password] bla bla blah... again and again when i type example /wa password lolman1918 and it still says type /wa password and so on so i don't know how to fix these things, i've tired and worked and i never found any tutorial how to install this on a website and so and to get it work inside the server and on the website.... i hope you all understand what i mean I NEED HELP with this.
  5. Offline



    I have the problem that "/wa deposit set" does not work.
    The console just show me"/wa password [password]",
    but i have an Account on the webside and it work.
    Money deposite and withdraw works, too.

    Edit: My fail i read the patchlogs too late,
    but now a second question, how to use the sign?

    I have Bukkit v.1337
    and WA v.0.6.1

    I hope someone could help my and my server
  6. Offline


    here are the new signs for depositing and withdrawling
    Line 1: [WebAuction] Line 2: MailBox Line 3: Withdraw (not actually needed but makes it neater with the other deposit sign :p)

    Line 1: [WebAuction] Line 2: MailBox Line 3: Deposit
  7. Offline


    And how to use the deposit Sign?

    It dont work with right klick on the sign. How its works?
  8. Offline


    Are there permissions for removing webauction signs? I had to limit the signs being created because of people not being able to destroy signs they created.
  9. Offline


    i have an error
  10. Offline


    same here
    also im having command conflict issues with signutilities both are using /wa command any chance of a /ah alternative ah= auctionhouse
  11. Offline


    I know that earlier in the posts it was mentioned but did not see any solution. When loading the Home page in any browser all of my users receive "DataTables Warning: JSON data from server could not be parsed. This is caused by a JSON formatting error." It will go away when there is an item in the Current Auctions however comes back when the page is empty again. Any help would be great! Love the plugin thus far, so much easier than making a chest shop that would take hours to create and then hours to maintain!
  12. make sure that the account the shop database is using to connect has full privileges to the iconomy database, and that the max queries is set wayyyy high for it. I had a similar error that was fixed when i turned the max queries up to 99999 :p
  13. Offline


    EEP... People couldn't put items up for auction so I decided to redo the install... I deleted the plugin and the plugin's folder, and now when craftbukkit is started the webauction folder is made but there is no config in it...

    Help would be appreciated...

    EDIT: That no longer is a problem... I have a completely new web folder and a NEW .jar worked (I was using an old one)... but still people don't see on the webauction the line that allows people to post new auctions! One player watched a video for webauction and it seems the little dropdown box is missing! Help still would be appreciated.
  14. Offline


    Here's a pastebin of the config.yml:

    Alternatively, go here and get the file he has linked in the main page, it has the config generation fixed.

    Also, @Exote added new config nodes, you need to have the wa.cansell and wa.canbuy given to people you want to be able to start auctions - we only also found that out yesterday when people complained they couldnt sell/buy anymore.

    @odielag ^
  15. Offline


    YAAAAAY!!! adding the wa.cansell node fixed it!
  16. Offline


    Also, just changed everything again, new config file generation should be working properly. And sort of changed the permissions.

    Well the permissions are the same, but there are no more default values.
  17. Offline


    is no Longer Supportet Chest Deposit?
  18. Offline

  19. Offline


    I get this Error in Log:

    23:27:46 [SEVERE] java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: YES)

    and the JSON Error on the website.

    I used db4free, but i have changed the config.yml.
    And why "root" and "localhost"?
    The MySQL part of the config.yml:

    Username: webauction****
    Password: ******
    Port: '3306'
    Database: webauction*****

    passwort and username is right :D

    Sorry for bad english, I'm German :p
  20. Offline


    It looks like when you updated the config file, then restarted the server it wrote over the config file again. This could be a mistake with the plugin (but I have found no one else with this problem) or the plugin is unhappy with how you edited the file.

    Make sure you have no spaces on the ends of any of the lines, and that you don't use tabs.
  21. Offline


    I think this can't work to CB 1.1.
    When I created sign then say 'u do not have permission' But Im op and have '*'
    Can't Use 1.1?
  22. Offline


    Will this plugin work on a server/website that are not hosted on the same box? It is unclear.

  23. Offline


    does global shout works?
  24. Offline


    GRAND SOLUTION!!!!!!!!!!!!!!
    GO config.yml in the password enter "" if not use your password in the DB
  25. Offline


  26. Offline


  27. Offline


    whats with the cant keep up messages since i put this on, the server actually lagg and spikes now...
  28. Offline


    My Items Page says "No Data" Why?
  29. Offline


    Yes it will work, only if your website host allows remote connection via MySQL (most allow it)
  30. Offline


    Plugin won't load with Craftbukkit #2083
  31. Offline


    Please update your plugin, i need it for my RPG server!!!!
    Very good work, pls kepp it on.
    Wergio likes this.

Share This Page