[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    same. Im using Cent OS and httpd

    Apparently you need to install php-mysql
  2. Offline


    Hmm, perhaps re-upload the web files again?

    Failing that try:

    cd to your spacebukkit directory

    sudo chmod 0777 app/tmp/cache/models
    sudo chmod 0777 app/tmp/cache/persistent
    sudo chmod 0777 app/tmp/cache/views
  3. Where is the problem in the link? It shows me an error on your forum :p

    also, this would be correct:
    chmod -R 777 app/webroot app/tmp app/configuration.php app/Config/database.php
    chmod -R 644 app/webroot/3d_skin
    and this is correct if the webserver is run under the user www-data (standard under apache):
    chown -R www-data:www-data /path/to/directory
    If you have the httpd webserver the user is apache:
    chown -R apache:apache /path/to/directory
  4. Deleted the directory, made a new one, tried your permissions,

    Read my latest post, I created a new directory for spacebukkit, so the redirection is just doing its job.
    Thanks for the help, tried it, still cake.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  5. Offline


    would you mind posting the output of apache2ctl -M

    PM it to me if you don't want to post it publicly.

  6. Offline


    Why cant it be as easy to install as McMyAdmin??? Why cant it just be a .zip file to unzip? The interface looks BAD, especially after MCMA2 came out. I dont see this project going anywhere much. In my opinion McMyAdmin is much better and I would recommend it to anyone.
  7. Offline


    I use debian.
    Mod rewrite on. apache and ect fine.

    How to fix that?
  8. Offline


    The plugins windows is very slow to loading (between 30/40 plugins) about 200 players.

    it is normal? (is loading since 20minutes now...)

    (is just for test only i do a full backup of my previous installation i will curious to know how spacebukkit work with my server :p )
  9. Offline


    Scheduler is not working for me, everything else however, is working flawlessly. Great job guys, very much worth the wait! Any idea when you will have backups fully implemented?
  10. Offline


    Is your /app/webroot folder permissions set to 0777?
  11. Offline


  12. Offline


    For me the plugins windows don't load

    I can't talk in the chat and on the top i have this error :

    And in the dashboard index i don't the how many member online (it still stay 0)

    Do you have an idea? The installation is a sucess (ubuntu server 11.04 / apache2)
  13. Offline


    Yes, all of that works except for
    chown www-data:www-data /path/to/directory
    . I have no idea what they mean.

    maniacmusic I found a solution, use
    chown -R apache:apache ./path/to/dir
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  14. Offline


    My last error. mb smb know.. [​IMG]
  15. Offline


    It's truly amazing to finally see this topic go live!
    If anyone has been wondering why I wasn't here, well, I spent my last 2 days getting everything ready with a cold instead of staying in bed, and now I am facing the consequences - a slight fever, and one hell of a cold.
    So I'll try and be as productive as I can, but I really need to give my personal health slightly more attention.

    In other, less boring news...
    Expect the installer to be completely rewritten in the next release. We know it has been kinda buggy, but well... t'was my first time writing an installer lol.
    Backups will be implemented soon, too, ChuckBartowski.
    The plugins page has been greatly improved during closed beta, so it should be faster now... We're on it nicquehen
    derxxf we're on it, could I know which URL you are at?
    @maniamusic, seems like your forum and spacebukkit are conflicting, maybe install it in yourdomain/spacecp instead, if possible?
    macman, thanks, I'll add that mysql php thing to the next version of the installer :)
  16. Offline


    Solve me if i do a mistake :

    I try to add another server in the same dedicated server(more light the another one)

    I use the same installation procedure :

    I just change my server port in server.properties 27050
    my remote.properties port in 25562
    and in the spacebukkit plugin folder 2013/2014.

    I try to add the new server in the dash
    adress : i put same my another server (do i need to set the port? )
    port 2013
    and i put the salt correctly.

    but it still not work (port pb) my server start correctly i have no error about port bind adress or another.
    I hope my english is understandable :D
  17. Offline


    What I like about SpaceBukkit:

    - Its design
    - Its world management system
    - Its roles system
    - Its statistics
    - It's CB build choosing system

    I would like from SpaceBukkit :

    - Log Management System a la MCMA
    - YAML parser like the Online Yaml Parser for config.yml files (option for admins/hosts to force it to be parsed correctly perhaps?)
    - Revisions for Configuration files to undo damage that may be done by faulty moderators
    - Support for ban reasons and times from systems like Commandbook and Banhammer
    - Support for bPerms and PEX
    -A detailed overview statistic from Ram/CPU usage of a server with the ability perhaps to see it over a monthly course and maybe log the amount players online every 30 minutes. MCMyAdmin does this over a few minutes or so, SpaceBukkit could take this to the next level. This would make it significantly easier for server owners to monitor performance influenced by plugins and amount of players online.

    That'l be all for now :p
  18. core_module (static)
     core_module (static)
    log_config_module (static)
    logio_module (static)
    mpm_prefork_module (static)
    http_module (static)
    so_module (static)
    alias_module (shared)
    auth_basic_module (shared)
    authn_file_module (shared)
    authz_default_module (shared)
    authz_groupfile_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    autoindex_module (shared)
    cgi_module (shared)
    dav_module (shared)
    dav_svn_module (shared)
    authz_svn_module (shared)
    deflate_module (shared)
    dir_module (shared)
    env_module (shared)
    mime_module (shared)
    negotiation_module (shared)
    perl_module (shared)
    php5_module (shared)
    proxy_module (shared)
    proxy_http_module (shared)
    reqtimeout_module (shared)
    rewrite_module (shared)
    setenvif_module (shared)
    status_module (shared)
    vhost_alias_module (shared)
    I made the /var/www/forums/ the root directory. Don't know exactly why, I kinda messed up months ago but besides that I can't get SpaceCP to work everything is fine. I installed phpMyAdmin and much more in sub directory's of forums. Are you 100% sure that's the problem? Because I don't really wanna mess up my working forum address.
    Get well soon!
  19. Offline


    Our software uses mod_rewrite and stuff that xenForo uses also. This makes it conflict.
    and /var/www/forums isn't the root directory as you still get /forums on the end :)
  20. Offline


    I think you'll need to edit your index.php ROOT constant... not sure though, I'm not on a PC right now :)
  21. Offline


    @maniamusic I was able to replicate the issue you are having and correct it. It may have something to do with permissions on the directories, to test this theory, jut chmod -R 777 /path/to/spacebukkit and try reloading the page.

    If that does work then you can start locking down the folders again.
  22. Thanks for the quick response Jamy. I can't install stuff in /var/www though
    Nothing :(
  23. Offline


    i love it its released. but i cry i dont have root rights on my server XD
    so the remote toolkit thing is impossible to install XD
    i asked my host to help me hopefully they start using SB
  24. Offline


    PM me and we'll fix your issue.

    Thanks for you suggestion but I would like to said, not especially for you, that if you're a developer, feel free to help us by sending pull requests on GitHub to add more features or to fix bugs.

    Edit: About support for X or Y plugin, we will provide soon an addon system.

    Can you create a thread on our forums and give more details?
  25. I solved it! Told ya it was a stupid mistake. Because /var/www/forums is my root directory, the adress was massiveminecraft.com/spacecp and not massiveminecraft.com/forums/spacecp
    I'm so sorry and ashamed that I massspammed the first 2 pages.
    Please forgive me.
  26. Offline


    Glad to hear it wasn't our fault. :D
  27. Offline


    Works Fine *-*
    Endlich isses da. Göttlich :D
    nur das er bei mir die ganze zeit das sagt:
    Obwohl doch eher die Beta neuer ist als die Alpha oder nicht? :D
    //Edit: Grad im Forum gelesen von dir, dann werd ich mal die "CLOSED BETA" 1.01 installiern
    //Edit2: Geh doch net -.-
  28. Offline


    I have another Problem, and hope you guys can help me ;)
    I´ve installed and everything works fine, but when i try to access the plugin page, there is this error:

    Anyone knows how to fix it ?
  29. Offline

    Nathan C

    Really, it is not that hard to install a simple webserver, mysql and php.

    If you cannot do something as simple as that, then you really have no business hosting a website or control panel either.
    half_bit likes this.
  30. Offline


    i cant go to step1 in the installation. There ist an error:

    Fatal error: Call to undefined function apache_get_modules() in /mnt/webg/c2/50/52922850/htdocs/forum/spacebukkit/app/Controller/InstallController.php on line 124

    What can i do?
Thread Status:
Not open for further replies.

Share This Page