[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Antariano, you mean half_bit :p

    Adrenaline: sorry, haven't found something yet, I will keep searching. You could search for "CakePHP and lighttpd" if you want to search yourself :)
  2. Offline


    Hey today i had want to install it :) but now i have a Error on Starting it.

    --------------------[SpaceModule v0.1]--------------------
    Checking for updates... [||||||||||||||||||||||] 100 % |
    Starting SpaceBukkit... [||||||||||||||||||||||] 100 % |
        at java
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
    at net.xereo.spacemodule.SpaceModule.load(SpaceModule.java:129)
    at net.xereo.spacemodule.SpaceModule.onEnable(SpaceModule.java:188)
    at com.drdanick.McRKit.module.Module.startModule(Module.java:45)
    at com.drdanick.McRKit.module.ModuleManager.handleToolkitStateEvent(ModuleManager.java:66)
    at com.drdanick.McRKit.McRKitLauncher.<init>(McRKitLauncher.java:144)
    at com.drdanick.McRKit.McRKitLauncher.main(McRKitLauncher.java:103)
  3. when using the console to use a command it shows that its been executed bottom right but it doesnt actually do anything - running CB 2149 & SpaceBukit 1.1-01
  4. Offline


    Yeah I figured that out this week end, it's 5h by default actually (well that was the default I had on my end).

    Thanks for the help though
  5. Offline


  6. Offline


    sad.. thanks for the feedback :) [not]

    and by the way~ why is the dev version nowhere promoted? As I see this link for the first time..
  7. Offline


  8. Offline


    stuck on Checking for Update for SpaceModules, you guys need to set a way to bypass that so we can still boot the server without checking update.

    edit : had to ditch spacebukkit for now
  9. drdanicks Jenkins Server was down for a while, it should be back up now ;)
    And yes we will be changing it to not need to check for updates.

    Adrenaline: Sorry for the late reply, try this: Pretty URLs and Lighttpd
    The mod_magnet one should work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  10. Offline


    FiendFyre basically had the whole log
    the ... is whatever the name of the craftbukkit it
    then it just says:
    press any key to continue
  11. Offline


    Hey, I was having the same issue he was having.

    I put #6 on, and am still getting this...
    necraft Remote Toolkit R10 Alpha 13
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Loading SpaceModule...Done.
    --------------------[SpaceModule v0.1]--------------------
    | Checking for updates... [||||||||||||||||||||||] 100 % |
    | Updating SpaceBukkit... [||||||||||||||||||||||] 100 % |
    | Starting SpaceBukkit... [||||||||||||||||||||||] 100 % |
    java.lang.ClassNotFoundException: me.neatmonster.spacertk.SpaceRTK
            at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
            at me.neatmonster.spacemodule.SpaceModule.load(SpaceModule.java:128)
            at me.neatmonster.spacemodule.SpaceModule.onEnable(SpaceModule.java:182)
            at com.drdanick.McRKit.module.Module.startModule(Module.java:45)
            at com.drdanick.McRKit.module.ModuleManager.handleToolkitStateEvent(ModuleManager.java:66)
            at com.drdanick.McRKit.McRKitLauncher.<init>(McRKitLauncher.java:144)
            at com.drdanick.McRKit.McRKitLauncher.main(McRKitLauncher.java:103)
    (Ps. I have been trying for 2 months to get SpaceBukkit correctly functioning on my server :( )
  12. Change your <minecraft>/SpaceModule/configuration.yml and set Developmet to false and Recommended to true then change your spcaemodule.jar to build #6 again.
  13. Offline


    Finally! It works!

    But after an hour of using it, it started spamming me with these.
    18:25:12 [SEVERE] java.lang.reflect.InvocationTargetException
    18:25:12 [SEVERE]      at sun.reflect.GeneratedMethodAccessor356.invoke(Unknown Source)
    18:25:12 [SEVERE]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    18:25:12 [SEVERE]      at java.lang.reflect.Method.invoke(Method.java:616)
    18:25:12 [SEVERE]      at me.neatmonster.spacemodule.api.ActionsManager.invoke(ActionsManager.java:90)
    18:25:12 [SEVERE]      at me.neatmonster.spacemodule.api.ActionsManager.execute(ActionsManager.java:85)
    18:25:12 [SEVERE]      at me.neatmonster.spacebukkit.PanelListener.interpret(PanelListener.java:47)
    18:25:12 [SEVERE]      at me.neatmonster.spacebukkit.PanelListener.run(PanelListener.java:105)
    18:25:12 [SEVERE] Caused by: while scanning a simple key
    in "<reader>", line 728, column 1:
    could not found expected ':'
    in "<reader>", line 729, column 1:
        flabby1: flabby1
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.scanner.ScannerImpl.stalePossibleSimpleKeys(ScannerImpl.java:398)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.scanner.ScannerImpl.needMoreTokens(ScannerImpl.java:229)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:178)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:563)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:161)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:146)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:123)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:106)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:121)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:480)
    18:25:12 [SEVERE]      at org.yaml.snakeyaml.Yaml.load(Yaml.java:423)
    18:25:12 [SEVERE]      at org.bukkit.util.config.Configuration.load(Configuration.java:88)
    18:25:12 [SEVERE]      at me.neatmonster.spacebukkit.players.PlayerLogger.getCase(PlayerLogger.java:81)
    18:25:12 [SEVERE]      at me.neatmonster.spacebukkit.actions.PlayerActions.getOPs(PlayerActions.java:176)
    18:25:12 [SEVERE]      ... 7 more
    I fixed the odd error.
    But now the the SpaceBukkit CP won't load.
    Do you think it is safe to do a /plugin reload Spacebukkit?

    Sorry, but I'm also going to have to uninstall this.
    It is causing the server to stop working completely.. Very randomly.
    I keep on having fucking problems with the players.yml file.

    Here's an example of the latest issue.

    jadebade: jadebade
    kelticterror1488: kelticterror1488
    joannou1: Joannou1
    zfaze: zfaze
    !!binary "bWlkZ2V0G29zG29yG29x": !!binary |-
    joey_smoth: joey_smoth
    ziggy7898: ziggy7898
    nijikokun: nijikokun
    jeb_: jeb_
    console: console
    macmanic77: macmanic77
    !!binary "bWlkZ2V0G29zG29yG29x": !!binary |-
    !!binary "bWlkZ2V0G29zG29yG29x": !!binary |-
    !!binary "bWlkZ2V0G29zG29yG29x": !!binary |-

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  14. Offline


    Can't wait for v1.2!
    Fuzzwolf likes this.
  15. Offline


    We're going to make an update to our java files to fix this asap!
  16. Offline



    I am running CentOS 6 and I followed automated Linux tutorial from SpaceBukkit wiki. But I ended up here:

    I have already tried to reinstall Apache2, Php and mysql database. Also I have tried to chmod 777 whole html folder in /var / www
  17. Offline


    Did you actually read what the page says?
  18. Offline


    Yes. And many times .

    I don't know how should I do this because wiki does not say anything about it. You are right I have no skills in apache . I can say only for my plead that your reply didn't help me at all :/

    a2enmod rewrite
    -bash: a2enmod: command not found
    I am running Apache2
  19. How did you install apache?
    Don't you mean httpd? (which is the same as apache but is differently configured by default)
    In that case follow our wiki on how to enable it on httpd.

    Also sorry for the late reply, bukkits forums had problems and I couldn't answer sooner.
  20. Offline



    A more comprehensive guide with detailed steps: http://www.howtoforge.com/installing-apache2-with-php5-and-mysql-support-on-ubuntu-11.04-lamp
    Fuzzwolf likes this.
  21. That's not the problem, I do very well know how to install apache ^^
    I'm just asking because CentOS has httpd built in, some people don't know that thought and install LAMPP or add extra packages. All thos emethods give you a completely differently configured apache server in the end and I'm asking to know how to help him troubleshoot better :p
  22. Offline


    Switch to Ubuntu. And I remember you saying:

    Fuzzwolf likes this.
  23. Nobody should ever recommend Ubuntu Server to anyone.
    Re-read my posts, you're misunderstanding them completely.
  24. Offline


    Too lazy to argue, but Ubuntu is pretty good @ handling my player base of 50 so I am happy with that.
    Fuzzwolf likes this.
  25. Not saying it's bad, but there's better :p (Debian stable)
  26. Offline



    When I'm on step three of web panel installation (that is, the part with connecting to the actual MC server, finding the salt, etc.), I keep getting "Server could not be reached." What could be the problem?
  27. That you mistyped the informations about your server...
  28. Offline


    Anxiously awaits Host support.
  29. Offline


    I copied and pasted the Salt and the IP, and the ports were copied and pasted also from the config file. I've tried at least 10 TIMES! I am frantically pulling my hair out as I try to figure out what is going on. I've run port checks and all that to see if the module is broadcasting, and for heaven's sake, it is! What on Earth is wrong?!? :'(
  30. Does <your-ip>:2011/ping and <your-ip>:2012/ping return "Pong!" ?
    Did you try localhost as address if Panel and Bukkit Server are on same machine?
Thread Status:
Not open for further replies.

Share This Page