[WARNING] Can't keep up! Did the system time change, or is the server overloaded?

Discussion in 'Bukkit Help' started by lattanzio, Apr 5, 2012.

Thread Status:
Not open for further replies.
  1. Offline



    I've been serving for about a year now, I've had many problems and found many solutions, but suddenly when I run my server I continuously get this warning message.
    I have 7gb of RAM dedicated to the server, it's a dedicated machine with an i3 sandybridge CPU and it's never had this problem before. When I log into the server (locally) all mob movement is really jerky and it feels like you're running in slow motion (very slightly).
    I've disabled all of my plugins and it still does it. I looked through a quick Google search and the only solution I found was to increase RAM usage to 2gb or so, considering it was already on 7 I assumed that that wasn't the problem.

    Can anyone help me?

    Looking at the server now (through teamviewer on my second monitor) I've noticed that the message comes every 19 seconds.

    And I have tried turning it off and on again.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  2. Offline


    Are you 100% positive that you are using that 7 GB?

    I will go ahead and assume you are using a 64-bit server with a 64-bit OS.

    Are you using a 64-bit Java and are you calling Java with the option to make use of all that RAM?

    screen -d -m java -d64 -Xincgc -Xmx6144M -jar /opt/craftbukkit/craftbukkit.jar nogui
    I use 2 GB and the only time I see that message is once during the initial startup (typically whenever I add a new plugin and it goes through an initialization procedure...thus taking longer to finish loading the server). I do not recall seeing that message at any other time though.

    Also, how many users to you have allowed in your server.properties file and how many are connected when this problem occurs?

    EDIT: If all options are set correctly, your next alternative is to try using a ramdisk.
  3. Offline


    I am 100% sure that it's using that amount. It is definitely a 64 Bit OS and Java.
    Usually the only time we get the message is when starting the server up, and even then it causes no problems.
    There are 20 people allowed on the server but when getting this message there is no one connected or trying to connect. It just constantly spits this out.

    If I understand what you mean by using a ramdisk I don't think that would help because it's not having problems with HDD transfer rates. It's not doing anything.
  4. Offline


  5. Offline


    Is the java virtual OS allotted enough RAM on your system?
  6. Offline


    I don't know what you mean by virtual OS.
    This isn't being run in a virtual machine, that would be silly.

    And thank you, Postbote. I am very pleased to hear that it's not just me.
  7. Offline


    Yes, virtual machine. Sorry I was confusing the client with the server.
  8. Offline


    List your plugins, your server.log and the line you use to start your server please.

    I'm running build 2150 and do not see the large CPU spikes (although I did have a bad plugin for a while causing me all sorts of grief).
  9. Offline


    I am having the same problem. My server was running just fine until later in the day 2 days ago. It started to get hardcore laggy then just started to spas out. In the logs it is just flipping out about it being overloaded. Is this from the update?
  10. Offline


    I'll not list the plugins because they're disabled (I've moved them to another directory).

    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xincgc -Xmx7G -jar craftbukkit-1.2.5-R1.1.jar
    I've uploaded the server log here.
    About halfway down you can see it begin to spam the error.
  11. Offline


    when ur computer gets extremley laggy, it displayes that message. for me it happens when i open google chrome.
  12. Offline


    My Server is a dedicated machine with 24GB RAM and a i7 920.
    You cant tell me that this Server isnt enough for Minecraft. lol
    Its a bug in the Build. "Nothing" more.
  13. Offline


    Postbote seems to be the only person who know what I'm talking about. The machine is not overloaded, there are no plugins, there is no one on the server, the machine is more than capable of running a minecraft server and i do know what I'm talking about.
    I'm glad I'm not the only one with this problem though.
  14. Offline


    i use an i5 quad 3400 16 gbs of ram 27 plugins build 2149 i have a horrible problem with it cant keep up shit
    i removed pail pail plus and craftbukkit up-to-date and i get none of that no more all i run now is the command prompt
  15. Offline


  16. Offline


    if that error do u no harm go to ur bukkit.yml in ur bukkit folder and change this to false

    allow-end: true
    warn-on-overload: false
  17. Offline


    I have the latest Java, I even reinstalled it to make sure, and suppressing the error isn't going to do anything, my server is unusable.
  18. Offline


    Have you tried increasing your heap space? Im currently doing that, and it workz.
  19. Offline


    Someone could have made a lag machine. Delete all piston is a solution I have used once...

    There used to be a plugin that would delete the configured block around players(spawner, but I used it to clean pistons)... I wish I could find a new one that does that.

    I hate mob spawner. They can cause that kind of symptons if a millions mobs are spawned. Player knows trick to do that...

    You have the latest java...I had problem when another admin updated java... we had to roll back the update.
  20. Offline


    I've constantly had this issue as well, new maps don't change it, amount of people or plugins on the server don't change it, it's not really adversely affecting my server but it's something that bugs the hell out of me.

    I am also in the same boat with specs, plenty to run the server:
    4 x Dual Core Xeon 7020's @ 2.66Ghz
    16Gb DDR2 RAM, 12Gb Allocated to minecraft
    15k SCSI's
    60mb down/ 15mb up

    Windows Server 2008 R2 Enterprise 64-bit
    64-bit Java
  21. Offline


    I don't know what you mean by "heap space", SpatulaShredder.

    No one on the server has made a lag machine, I know everything that goes on. Plus this happens when no one's on the server, so no chunks are loaded anyway. And this problem started, then I updated Java, so it's not that.

    And I'm not sure how you can have this issue and not be affected by it considering craftbukkit only runs on one thread, and it's taking up the entirety of it.
    Perhaps we have slighly different issues. Or perhaps it's just because you're running it on the side of a hydrogen bomb.
  22. Offline


    Well no one is experiencing any lag on my server, even when this is spamming my console.
  23. Offline


    I have a good amount of RAM good computer all that stuff.
    Yet I still CONSTANTLY get that stupid warning.
    I've done tons of research and went through the .jar file they are just a few bugs, no matter if you have one or if you have 20 players it'll lag the same amount. Also, I've learned using commands such as /say, /broadcast, etc. will create more lag and sometimes will display that message and give off lag.
    If you are using the server plugin Permissionsex, be careful what plugins you give each player. For example, giving people access to /home could possibly create more lag because if nobody else is near the chunks where their sethome is, it'd be ungenerated until somebody goes onto it. However when your player types /home and instantly has to load all the chunks, view distance, etc. you tend to get a good deal of lag following.

    All in all, it's mostly a glitch nothign to be worried about. Just don't worry about it enless your players are complaining about good deals of lag.

    *correct. It can be any type of permissions/group manager etc. plugin that makes it so users can only have certain commands, only an Idea.
    If you don't know how to do perms, etc. I could help you out on your server.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  24. Offline


    It could be either:

    1. The build is the problem. I have found that when I used to run my server on only 1GB of ram, it kept up fine, however, since updating to 1.3.1 and 1.3.2 builds, the message is displayed that it can't keep up.

    2. Your CPU isn't able to cope with running a Bukkit Server and Minecraft at the same time. I use a i5 system and almost 2GB of ram and it seems to display the message less when it is not running Minecraft.
  25. Offline


    Java IS a virtual machine...
  26. Offline


    .... Nope.

    The server is dedicated, it's not running minecraft and bukkit at the same time.
    This thread's really old now and as I think I mentioned previously, the problem went away randomly.

    As I've said numerous times here, yes I can ignore the warning or suppress the warning in the config files, but the server itself was UNUSABLE. No one was able to play with the amount of lag that was present. It was just not possible. And I've also said that I had removed all plugins and the problem even persisted when there was no one on the server and no chunks were loaded at all.

    Why don't people read threads?
  27. Offline


  28. Offline


    My mistake, you appear to be right about that but I believe the original comment was referring to a virtual machine as in running windows in a virtual machine like VPC (I think it's called).
  29. Offline


    ooh that makes sense then, i thought he was trying to ask you had made sure you had allocated enough RAM to java... in a very wordy manner ;)

    The last time I saw something like this happen on my server it turned out to be a glitch with my DynMap addon, and was an easy fix. Sadly this is not the case for you as you stated you tried without any addons.

    Have you run any programs to make sure you dont' have a world corruption? Or possibly an issue on the hard drive itself?
  30. Offline


    Well as I've said, the problem ended up fixing itself without changing maps or updating or anything. no clue what it was.
Thread Status:
Not open for further replies.

Share This Page