Vip system based on MySql

Discussion in 'Bukkit Help' started by smilesoft, Mar 6, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    smilesoft

    Hello all!
    I'm searching plugin to VIP system based on MySQL ( im php developer and i would like to do automatized VIP system )
    I Was trying few plugins, most do not use MySQL.
    Finally i found EasyVip ( v 0.7 for CB 1.4.6 )
    My CB is 1.4.7 ofc.

    EasyVip make some errors in console:
    Code:
    22:21:36 [INFO] [EasyVIP] Enabling EasyVIP v0.7
    22:21:36 [SEVERE] [EasyVIP] Communications link failure
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    22:21:36 [SEVERE] Error occurred while enabling EasyVIP v0.7 (Is it up to date?)
    java.lang.NullPointerException
    at com.gmail.gkovalechyn.ev.db.DB.getCon(DB.java:103)
    at com.gmail.gkovalechyn.ev.db.DbCommands.createTableCodes(DbCommands.java:53)
    at com.gmail.gkovalechyn.ev.db.DbCommands.(DbCommands.java:33)
    at com.gmail.gkovalechyn.ev.EasyVIP.onEnable(EasyVIP.java:56)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.v1_4_R1.CraftServer.loadPlugin(CraftServer.java:282)
    at org.bukkit.craftbukkit.v1_4_R1.CraftServer.enablePlugins(CraftServer.java:264)
    at net.minecraft.server.v1_4_R1.MinecraftServer.j(MinecraftServer.java:321)
    at net.minecraft.server.v1_4_R1.MinecraftServer.e(MinecraftServer.java:300)
    at net.minecraft.server.v1_4_R1.MinecraftServer.a(MinecraftServer.java:259)
    at net.minecraft.server.v1_4_R1.DedicatedServer.init(DedicatedServer.java:149)
    at net.minecraft.server.v1_4_R1.MinecraftServer.run(MinecraftServer.java:399)
    at net.minecraft.server.v1_4_R1.ThreadServerApplication.run(SourceFile:849)
    If You can, please help me to repair this errors, or please give me a right plugin.
    I will be greateful
     
  2. Offline

    Onionbro

  3. Offline

    jorisk322

    Most plugins don't break on Bukkit updates. It's best to just try things, and they will usually work.
     
  4. Offline

    Onionbro

    I am aware, but I try not to give the impression that it's 100% certain to work when I have not even used it myself. :)
     
  5. Offline

    smilesoft

    hello guys thx for answers, onionbro, i cant use paypal, its still low known in Poland where i run my serwer. I would like to get plugin to VIP acc, in which i will be able to set ( by php script ) date when VIP will end.
    Plugin which You gave is probobly verry nice one, but this is no what im looking for :)
     
  6. Offline

    toothplck1 Retired Staff

    The plugin technically does not require paypal, it just says paypal because I supply a basic example paypal ipn php script.
     
Thread Status:
Not open for further replies.

Share This Page