Solved UnsupportedClassVersion compiled at 61, but only recognizes 60.0

Discussion in 'Plugin Development' started by voltywolty, Jun 14, 2022.

  1. Offline

    voltywolty

    Code:
    org.bukkit.plugin.InvalidPluginExceptionjava.lang.UnsupportedClassVersionError: main/me/volt/dvz/DvZ has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 60.0
    I've been trying to figure out what Java I needed to download, I've downloaded 17 and 16.
     
  2. Offline

    DopeBrot

    wich version is your server and wich version is the plugin?
     
  3. Offline

    timtower Administrator Administrator Moderator

    @voltywolty Probably need to start your server with the java 17 executable then.
    Replace the "java" in your run.bat / whatever you use by the full path to the java 17 executable
     

Share This Page