Unknown error at start of minecraft server

Discussion in 'Bukkit Help' started by bcredeur97, Jun 12, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, im getting a very strange and unknown error whenever I start my friend's minecraft server (him and 8 other people couldnt solve the problem so Im trying my best :p)

    The server will not start AT ALL. Ive reinstalled Remote Toolkit, Reinstalled java x64, and Ive even reinstalled vcredist_x64 but to no avail. Ive checked all the settings and stuff and all looks well to me, but im wondering if anyone can tell me how to solve this problem as quickly as possible based on the log.

    (Windows 7 x64 btw :p)

    Now before the Log even begins this is the message I get:
    Loading Libraries, please wait...
    (date/time) WARN Unable to instatiate org.fusesource.jansi.WindowsAnsiOutputStream

    then right after that message the log picks up this error:
    [19:00:41] [main/FATAL]: Failed to start the minecraft server
    net.minecraft.util.com.google.gson.JsonSyntaxException: java.io.EOFException: End of input at line 1 column 90113
    at net.minecraft.util.com.google.gson.internal.Streams.parse(Streams.java:54) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.TreeTypeAdapter.read(TreeTypeAdapter.java:54) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.internal.bind.TypeAdapterRuntimeTypeWrapper.read(TypeAdapterRuntimeTypeWrapper.java:40) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:81) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.Gson.fromJson(Gson.java:803) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.Gson.fromJson(Gson.java:768) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.server.v1_7_R3.UserCache.b(SourceFile:156) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.server.v1_7_R3.UserCache.<init>(SourceFile:42) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.server.v1_7_R3.MinecraftServer.<init>(MinecraftServer.java:111) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.server.v1_7_R3.DedicatedServer.<init>(DedicatedServer.java:37) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.server.v1_7_R3.MinecraftServer.main(MinecraftServer.java:764) [craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at org.bukkit.craftbukkit.Main.main(Main.java:159) [craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    Caused by: java.io.EOFException: End of input at line 1 column 90113
    at net.minecraft.util.com.google.gson.stream.JsonReader.nextNonWhitespace(JsonReader.java:1377) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.stream.JsonReader.doPeek(JsonReader.java:483) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.stream.JsonReader.hasNext(JsonReader.java:403) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.internal.bind.TypeAdapters$25.read(TypeAdapters.java:666) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.internal.bind.TypeAdapters$25.read(TypeAdapters.java:642) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    at net.minecraft.util.com.google.gson.internal.Streams.parse(Streams.java:44) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.1-10-g8688bd4-b3092jnks]
    ... 12 more

    So any help would be greatly appreciated, sorry about putting the long error, I made all my text bold so it would be slightly more organized. Was not sure how to make a spoiler :/

    Thanks guys,
  2. Offline


    have you tried re installing/updating the bukkit version?

    because there is now a Ro.2

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 8, 2016
  3. Offline


    Yes i have. the problem still persists
  4. Offline


    Archive your server folder into a single zip file, upload it somewhere like mediafire and send me a PM to download it.

    If it works on my PC, that will prove it has something to do with your PC...if not, then I will figure out the source of why it won't start and fix it.

    EDIT: Please include a link to this thread if you do PM me so I can have it as a reference. I cannot remember all the places I post. ;)

  5. Offline


    Um I would do this mr Hammonds but there is one major problem - the server is over 200 GB in size, which is why I posted here, this is a fairly major server with a very active community. I guess we could try reinstalling windows but that was trying to be avoided.
  6. Offline


    Well, just don't include the world in the archive. When I start it up (if it starts) it will generate a new world. And I doubt it is the world causing the issue anyway.
  7. Offline


    The problem was fixed recently by one of the admins who said it was a player UUID issue. Now when I made Minecraft server's back in the day these UUID's didn't exist so honestly I dont know too much about what he did. The file that stores the UUID's was corrupted and replaced with a clean one and the problem is now gone and the server <removed> is up and running on its self-owned dedicated box again!

    Thanks for your help Mr. Hammonds and Mr. Jacob. I appreciate it greatly, and thank you for your time!

    [edit by JaguarJo: removed IP; sorry, but advertising isn't allowed in this section]
  8. Offline


    I have the same issue! How do I know UUID file it is, that is corrupt?
  9. Offline


    I don't know how they isolated which of the UUID files was the problem but you could temporarily move all UUID files to somewhere else, start the server and see if it works. If so, you have at least verified where the problem is located. If I had no way of identifying the file but the existence of it would cause the server to not start consistently, I'd do a binary solution tree....meaning, I'd take exactly 1/2 of the UUIDs and move them back and see if I can cause it to fail. Then continue splitting it in half until I reduced it to just 1 file causing the problem. It might take a while but if 1 file is causing the problem, it can be isolated this way (would be nice if there was a tool to mass analyze all files though)

  10. Offline


    I am having same issues with UUID's lately. One guy could not get on so there was this user.cache file in the server root. I kept deleting all of those files to no avail. I then went to the Essentials users.yml and opened up only his, deleted it, and then went to the main world, where people have a rank and are not player. Opened up the player.dat folder and found his UUID and deleted it then sorry for run on sentence, there is a part in multicraft that says players, I went through and deleted every instance of him every logging onto the server, he kept appearing to be online when he really wasnt. That fixed that problem. Today is much different. The server was running great as of the exact moment I installed the Ontime plugin because people missed it. Once I did that, the server crashed, so I immediately uninstalled it. Now the server will not start at all. Here is what I get:
    23.06 11:30:46 [Multicraft] Server stopped
    23.06 11:30:46 [Multicraft] Server shut down
    23.06 11:30:46 [Server] INFO ... 12 more
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.Streams.parse(Streams.java:44) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.bind.TypeAdapters$25.read(TypeAdapters.java:642) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.bind.TypeAdapters$25.read(TypeAdapters.java:667) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.stream.JsonReader.nextName(JsonReader.java:783) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.stream.JsonReader.nextQuotedValue(JsonReader.java:1006) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.stream.JsonReader.syntaxError(JsonReader.java:1505) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO Caused by: net.minecraft.util.com.google.gson.stream.MalformedJsonException: Unterminated string at line 1 column 24577
    23.06 11:30:46 [Server] INFO at org.bukkit.craftbukkit.Main.main(Main.java:159) [craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.server.v1_7_R3.MinecraftServer.main(MinecraftServer.java:764) [craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.server.v1_7_R3.DedicatedServer.<init>(DedicatedServer.java:37) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.server.v1_7_R3.MinecraftServer.<init>(MinecraftServer.java:111) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.server.v1_7_R3.UserCache.<init>(SourceFile:42) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.server.v1_7_R3.UserCache.b(SourceFile:156) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.Gson.fromJson(Gson.java:768) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.Gson.fromJson(Gson.java:803) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:81) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.bind.TypeAdapterRuntimeTypeWrapper.read(TypeAdapterRuntimeTypeWrapper.java:40) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.TreeTypeAdapter.read(TreeTypeAdapter.java:54) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO at net.minecraft.util.com.google.gson.internal.Streams.parse(Streams.java:56) ~[craftbukkit.jar:git-Bukkit-1.7.9-R0.2-1-ga6e0bfd-b3095jnks]
    23.06 11:30:46 [Server] INFO net.minecraft.util.com.google.gson.JsonSyntaxException: net.minecraft.util.com.google.gson.stream.MalformedJsonException: Unterminated string at line 1 column 24577
    23.06 11:30:46 [Server] INFO Failed to start the minecraft server
    23.06 11:30:42 [Server] INFO Loading libraries, please wait...
    23.06 11:30:42 [Multicraft] Loaded config for "Mod: Craftbukkit"
    23.06 11:30:42 [Multicraft] Starting server!
    23.06 11:30:42 [Multicraft] Loading server properties
    23.06 11:30:42 [Multicraft] Received start command

    Ha, I fixed it!!! Yay, I deleted the contents of the Users.cache file again and it started :) Dang UUID's Oh well, roll with the changes I guess.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 8, 2016
Thread Status:
Not open for further replies.

Share This Page