Question Unable to start my Bukkit server (MAC)

Discussion in 'General Help' started by Ekelin, Aug 5, 2017.

Thread Status:
Not open for further replies.
  1. Offline



    I need help starting up my Bukkit server and my problem is as follows:

    Having downloaded the latest version of craftbukkit.jar (currently 1.12.1), installed the latest Java version (8), I create the start.command file with the following code:

    cd "$( dirname "$0" )"
    java -Xmx1024M -jar craftbukkit-1.12.jar -o true

    I have of course granted it "executive permission" or what it may be called via Terminal. The response I receive when I try to run the server is:

    Last login: Sat Aug 5 17:07:46 on ttys000
    Simons-MacBook-Air:~ Simon$ /Users/Simon/Server\ files/Server\ 2/Start.command ; exit;
    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/bukkit/craftbukkit/Main : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...
    [Process completed]

    This does not happen when I use some of the older versions of craftbukkit.jar, but then the problem becomes that Minecraft cannot connect to an out of date server.

    Any help to sort this problem out would be greatly appreciated!
  2. Offline

    timtower Administrator Administrator Moderator

    @Ekelin remove all java installations from your machine.
    Install Java 8
  3. Offline


    I thought I did that. How do I thoroughly remove those installations from my Mac?
  4. Offline

    timtower Administrator Administrator Moderator

    @Ekelin I know windows and linux, I don't know how to do this on mac.
  5. Offline


    After having followed the Java-site instructions and uninstalling the program, and the re-installing the latest version, still no improvement has been made. Any idea why?

    From the code I posted in the start of the thread, does it specifically say that I have a too old version of Java?
  6. Offline

    timtower Administrator Administrator Moderator

    Yes it does.
    Update the entire operating system if possible.
  7. Offline


    Alright, I have updated the entire operating system. I have verified that the latest version of Java is the only one I have installed, according to my system preferences. I have tried removing and re-downloading all bukkit-files etc. Yet, when I start from scratch, the problem still persists. Do you have any further suggestions? I appreciate you responses :)
  8. Offline

    timtower Administrator Administrator Moderator

    @Ekelin Execute the next command in the terminal:
    java -version
    And throw that response in this thread.
  9. Offline


    According to terminal:

    Simons-MacBook-Air:~ Simon$ java -version
    java version "1.6.0_65"
    Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468-11M4833)
    Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)

    This is really odd since System Preferences/Java/Update says "Your system has the recommended version of Java. Java 8 update 144." There is no suggestion for updating to a more recent version, as their should be if there was one available, according to
  10. Offline

    timtower Administrator Administrator Moderator

    @Ekelin System gives the latest version, Bukkit is being started by the lower one, try to find the lower one.
  11. Offline


    Alright, so the problem is solved! Thank you so much!

    I will post the "solution" step by step for other that may encounter the same problem.

    I opened Finder and in the top left corner of the screen i clicked "Go/Go to folder..." and typed "/Library/Java/JavaVirtualMachines" (as found in a guide at Java's website,

    Here I found the JDK-file (Java Development Kit) which belonged to the 1.6-version. I simply removed it.

    I then downloaded the most recent version (googled "JDK download" and found it on Java's website).

    Once JDK 8 was downloaded and installed, I opened the server, which initiated as it should (with the slight interruption of me having to approve the eula-terms), and after that I managed to enter the minecraft world. Now I'm going to explore the assortment of plugins available.

    Again, superthanks!
    timtower likes this.
Thread Status:
Not open for further replies.

Share This Page