Solved Trying to disable gamemode with vanilla permissions

Discussion in 'Bukkit Help' started by asuperpower, May 14, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    asuperpower

    I've searched (what seems like) everywhere and have been trying to fix it for the last few days. I need to stop everyone except 2 people (someone else and I) from changing to creative mode. I'm trying to turn off gamemode but it doesn't work. Here's my (really bad :p) coding:
    http://pastebin.com/cHwrgML8

    EDIT: BTW, I'm using the permissions file that was preinstalled with bukkit. My guess is that I did some sort of really stupid mistake. :p
     
  2. Offline

    Craftiii4

    Uh, don't you use a other - to negative a permission?
     
  3. Offline

    asuperpower

    What do you mean by negative a permission and use a other? Should I be setting it to true?


    Anyone?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 25, 2016
  4. Offline

    Wendo

    In permissions files you don't traditionally use <something> = false to remove the permission

    the correct syntax for just the default permissions.yml (ie, no actual permission plugin running) is

    Code:
    bukkit.command.gamemode: false
    But, you would be better off creating another group for just the two of you, and adding a positive permission to that group. Or even better running a proper permission plugin
     
    asuperpower likes this.
  5. Offline

    andrewpo

    PEX/other lovely plugins:
    Code:
    -bukkit.command.gamemode
    Odd plugins:
    Code:
    bukkit.command.gamemode: false
     
    asuperpower likes this.
  6. Offline

    asuperpower

    So this what I did, it still doesn't work. I tried using PermissionsEx and it does not work. Thank you for the responses. ;)

    So this is my code for PEX. I've added a few 3rd party plugins.
    http://pastebin.com/V103f4L1

    Whenever I install PEX and put the code in, I get an internal server error.
     
  7. Offline

    Wendo

    As andrewpo said, when using a real permission plugin that's not how you format the permissions.

    To make what you posted work remove all the lines with false next to them, and remove the ": true" parts of every other line.

    With real permission plugins, the simple fact they you have listed them means you are granting that permission. Anything not listed isn't granted. Something like this (warning, completely untested as I don't use PEX)

    http://pastebin.com/1MtzY3yi
     
    asuperpower likes this.
  8. Offline

    ashley

    hello there,

    I'm Ashley from Bukkit Assistance and I'm here to help you out
    ---------------------------------------------------------------------------
    You can solve this problem by downloading this plugin
    http://forums.bukkit.org/threads/misc-plgdisablecmd-v2-0-disable-given-commands-1-2.6504/
    Download the OP version
    and put the /gamemode in the disable file
    now only you and other ops can use this code
    Hope this Helped
    ---------------------------------------------------------------------------
    add me on Skype or come to my live support chat(private) to get Assistance
    Skype: Ashley Daninck
    Live Support: ProjectX.No-Ip.biz -> Latest News -> Chat button
     
    asuperpower likes this.
  9. Offline

    asuperpower

    Both, thank you. ;)

    Wendo: However, even when using your exact code, it didn't work. So I removed some code and it still didn't work - I'm still getting an internal server error. Here is the shortened code that I used:
    http://pastebin.com/wgct8LJf

    ashley: I want to learn how to use permission properly and I also want some people to be able to access commands (for example, I want to be able to use /gamemode but I don't want others to.)
     
  10. Offline

    asuperpower

  11. Offline

    BobbyD441

    change
    - bukkit.command.gamemode
    to
    - - bukkit.command.gamemode
    to cancel out the permission
     
    asuperpower likes this.
  12. Offline

    jf46784

    asuperpower likes this.
  13. Offline

    asuperpower

    Thank you so much everyone, it now works! :)
     
  14. Offline

    Lolmewn Retired Staff

    Edit thread title, add the [Solved] Tag plz :)
     
Thread Status:
Not open for further replies.

Share This Page