Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    I tried setting it to none but it still links to permissionsbukkit.
  3. Offline


    This is working only since 3.0.0 b5. If you are using this, you have to reload/restart (xwarp reload should work).

  4. Offline


    What do you mean? I closed the server and turned it back on, and it still won't work.
  5. Offline


    I meant: When you are using 3.0.0 b5 and changed the file xWarp have to reload it. By restarting it (as you did) xWarp was reloaded and should read the settings file.

    Okay I need more informations:
    • What version of xWarp do you are using?
    • What does xwarp status say? Execute it in the console and copy paste the output here.
    • Could you please show your configuration/setting file.
  6. Offline


    The documentation for this is very confusing, sorry.

    All I want to do is allow a certain group in Permissions 3.1.x to do /warp [location]. I have tried *everything* I can think of. I tried:**

    What is going on here? I have checked the group and they are definitely in it, and can perform other operations such as /magiccarpet when I add permission nodes for that.

    The only way I have been able to get xwarp to work is to do warp.*, which is fine for the upper level groups but I would like observers in my server to be able to just warp to locations to view things.
  7. Offline


    Hi, this should work. At least with the second an forth permission. Only the first is invalid.

    Which version of xWarp do you using? And could you check which permissions the user has ingame?

  8. Offline


    error with spout :(
  9. Offline


    Don't use spout.

  10. Offline


    I'm running 2.12.0 and yes, I have checked this before. If I add them to the group, it says it was successful. When I check what groups they're in, that comes up fine as well. If they weren't in a group the other permissions I added such as /magiccarpet, etc, would not be working. Only xWarp is giving me a problem.

    I don't really know what to do about this problem at all. Do you need to see my permissions database structure?
  11. Offline


    Nope, simply do following steps:
    • pr g:<groupname> has|within.<world>
    • pr g:<groupname> has|invited|other|global
    Both should return that the group has these permission. Another possibility would be to execute warp permissions <player name> in the console. The player has to be online.

    @grifOndOr: Tip for future problems: Provide more information! I'm not using Spout so I don't know what your problem is.

  12. Offline


    Whenever I try to do anything with warps, I just get "/warp help"
  13. Offline


    Which version do you using?

  14. Offline


    Hi, how do I set the limit of private warps with the warp.limit.private permission to 3?
  15. Offline


    Depends on your Permissions plugin and xWarp version. If you are using xWarp 2.12.0 with Permissions 3.1.X you could use set the variable directly in the groups.yml/users.yml by adding the variable in the info section:
    groups: (or users:)
      group name: (or user name)
          warp.limit.private permission: 3
  16. Offline


    please list your permissions node in your plugin.yml so we may extract them regularly and stay updated using permissionshelper
  17. Offline


    Main problem is that there are many dynmically used permissions since xWarp 3: xwarp.warp.edit.object.<owner>.<warpname>.<operation> which I'm unable to list them in the plugin.yml. Same for the wpa editor nodes (xwarp.wpa.edit.object.<owner>.<warpname>.<operation>) and world limits.

    The rest maybe come in a future version, but to be honest but this is prone to typing errors. For example changing the permissions only in source and not in the plugin.yml.

  18. Offline


    Okay I updated xWarp to a stable 3.0.0 release.

    Don Redhorse likes this.
  19. Offline


    @xZise Why the dependance on Bukkit Pligin Utilities, what does it offer that spout does not? I only ask because I have already been roped into spout as a dependency for many things (as have others) I am in no way asking for you to change, just curious about your choice.
  20. Offline


    Bukkit Plugin Utitlites is something completely different than spout. Spout is mod for client/server while BPU simply support many uses methods/classes in my plugins. I don't want to write everything multiple times.

    BPU manages the links to economy and permissions plugins, the second leveled commands and some additional stuff like the parser for the commands.

  21. Offline


    i update to 3.00 and the members cant use warpsign
    i dont change any permissions

    i'm using permissions 3;16

    did something change ?

    in the config.yml i have :
    plugin: ''

    what should i write ?
  22. Offline


    I changed all permissions, please check the link to the permissions in the OP.

    You can check with /xwarp status of xWarp is using Permissions.

  23. Offline


    My players have been begging for a Warp Protection Area system forever. :)
    Thanks for all you do.
  24. Offline


    heeey ppl constantly getting error that they don't have permissions to warp /warp newcity, but i have permissions for it ( - '*' )
  25. Offline


    Did you fix the little buggie inside the limiter? :3
    Didnt test WPA yet, but sounds so awesome! :D

    @vanja be sure you set the permissions to warp inside "World"
    Check permissions section for info,
  26. Offline


    Check out the common questions in the OP. MuisYa has the correct tip.

    @MuisYa: What bug exactly?

  27. Offline


    That the limiter doesnt limit changing a warp from public to private...
  28. Offline


    Nope is fixed ;)

  29. Offline


  30. Offline


    How do I disable warmups? I don't want there to be a wait limit for warping. I want instant warps. How can I do that?
  31. Offline


    By default there are no warmups/cooldowns. If not here I listed all permission values xWarp supports (third last section is about cooldown/warmup).


Share This Page