Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    It not just the prices. As you can see they don't have permissions to create warps at all and they can. They don't have any permissions and they still can create warps.

    "[Permissions] The user/group does not have that permissions."
    ^ that what it said

    I was trying to see if it was my version of xwarp doing it, it wasn't

    Its ignoring everything to have to do with them, its pretending that they don't exist.


    I was able to replicate this "error" on a different machine, everything redownloaded, no other plugins. Newest permissions, newest xwarp.

    Below is me using a random name joining for the first time and creating a warp with/out permissions

    Here is a log of the server in case you cant read the above, and on this one I typed "pr g:Citizen w:world has warp.create.private" and "pr g:Citizen w:world has"
    as you can see they both aren't given to the Citizen group

    2011-06-12 05:15:45 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2011-06-12 05:15:45 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2011-06-12 05:15:45 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    2011-06-12 05:15:45 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-823-gb9d0b04-b860jnks (MC: 1.6.6)
    2011-06-12 05:15:46 [INFO] Preparing level "world"
    2011-06-12 05:15:46 [INFO] Preparing start region for level 0
    2011-06-12 05:15:47 [INFO] Preparing spawn area: 32%
    2011-06-12 05:15:48 [INFO] Preparing start region for level 1
    2011-06-12 05:15:48 [INFO] Preparing spawn area: 0%
    2011-06-12 05:15:49 [INFO] [Permissions] (Yeti) was initialized.
    2011-06-12 05:15:50 [INFO] [HeroChat] HeroChat version 4.10.3 enabled.
    2011-06-12 05:15:50 [INFO] [Permissions] version [3.1.5] (Yeti)  loaded
    2011-06-12 05:15:50 [INFO] [HeroChat] Permissions 3.1.5 found.
    2011-06-12 05:15:50 [INFO] [xWarp]: Meta table doesn't exists... Creating new
    2011-06-12 05:15:50 [INFO] [xWarp]: No Register found. Deactivating Register support.
    2011-06-12 05:15:50 [INFO] [xWarp]: 0 warps loaded
    2011-06-12 05:15:50 [INFO] [xWarp]: Linked with permissions system: Permissions v3.1.5
    2011-06-12 05:15:50 [INFO] [xWarp]: No economy system found until here. A economy plugin will be maybe activated later.
    2011-06-12 05:15:50 [INFO] [xWarp]: xWarp 2.11.4 enabled
    2011-06-12 05:15:50 [INFO] Done (0.487s)! For help, type "help" or "?"
    2011-06-12 05:16:39 [INFO] tigerfoxbear [/] logged in with entity id 381 at ([ world] 171.5, 85.62000000476837, 369.5)
    2011-06-12 05:16:39 [INFO] Creating user tigerfoxbear
    2011-06-12 05:16:41 [INFO] [Citizen] tigerfoxbear: hi
    2011-06-12 05:20:12 [INFO] Unknown console command. Type "help" for help.
    2011-06-12 05:20:16 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-12 05:20:16 [INFO] [Permissions] User/Group does not exist.
    2011-06-12 05:20:26 [INFO] [Permissions] All worlds reloaded.
    2011-06-12 05:20:30 [INFO] [Citizen] tigerfoxbear: hte
    2011-06-12 05:27:20 [INFO] [Permissions] User/Group does not have that permission.
    2011-06-12 05:28:52 [INFO] [Permissions] User/Group does not have that permission.

    I've posted almsot a full page of details about the problem. I've tested it on different machines, with new permissions, tried multiple versions of xwarp, multiple versions of permissions, able to recreate the problem, provided everything I've found. What more should I do/post..
  3. Offline

    Kevin Robbens

    Does this plugin also support an item cost instead of textbased plugin money?
    I've read the wiki and tested some config, didn't work out for me.
    If not, I'd like that a lot. If it does, could you explain how to set it up?
  4. Offline


    @Donny: This is very strange! I'm using Permissions 3.1.5 on a CB 857 server with xWarp 2.11.3 and Permissions works great. I will test this on 860 with Permissions 3.1.5 and xWarp 2.11.4.

    What you maybe could show me, is the output of “warp permissions <user>”. If there the warp.create.* permission isn't granted this could be the key.

    @Kevin Robbens: Sorry, but xWarp itself isn't something like a economy plugin. So if you have an economy plugin which supports item costs, then tell me the name, and I maybe I will implement the item cost. The only problem is, that I only have the price as an integer, but item costs implies to define a amount of items, and (at least) one material. Something like “two wood”.

  5. Offline

    Kevin Robbens

    Oh I see. I'm using TradeCraft, It has methods to replace items with another item (defined in config - so there is the item id you need, I guess) inside a chest, so you might be able to get gold replaced by nothing inside an inventory I suppose..
    I might just look in the CB API if it seems too hard.
  6. Offline


    Hmmm, okay TradeCraft sounds interesting, as the “Currency” is (by default) gold ingot. So I simply have to store, how many gold ingots the warp/creation cost. But I don't see any API there, but I will see, what I could do according to this feature.

    And I released 2.11.5! I didn't check the player's permission right. Now creation cost money (if defined) and is checking the permission. This should fix Donny's problem.

    Kevin Robbens likes this.
  7. you know what would be cool. If you could only use the warp if you where in a certain area. E.g. set up a maze and if they get lost/give up they can use /warp maze to go to the start again.. But they can only use it while they are in the maze. That way if they where miles away couldt just do the same to get there faster. Just an idea.. There might already be something out there like that..
  8. Offline


    Actually I'm planning a easier implementation, that you have a upper and lower limit. So you could warp only X meters away but not more than Y meters. X could be 0 and Y could be infinite (this is the setting at the moment) and 1 m is a borderlength of a block.

    Your maze idea is very complex, because you have to set up the maze and it seems to be something like a polygon ;) So it is relative complex to check if you are within the maze.

  9. Offline


    I can only see half of them because it fills up my chat. All that I can see are no
  10. Offline


    Use the console ;) They are to many to show them ingame. And please test with 2.11.5 and tell me if this fixes the problem.

  11. Offline

    Kevin Robbens

    xZise, okay great to hear that, hope to hear from it soon!
    Damn I was worrying about that. I kinda hoped Bukkit's API supported giving and taking items.
  12. Offline


    In basic yes, but this is a teleport and not a economy plugin. For example the walletchest idea in the TradeChest chat: This is not in the domain of xWarp ;) so hopefully an update will be there soon, and I will try to do my best. But at the moment I only planing to support one “currency” so you could only define “X somethings” costs it (and the somethings is predefined).

  13. Offline

    Kevin Robbens

    That would be great! I've read your config, i think you can keep it like it was, adding something like usecurrency bln and currencyid.
  14. Offline


    Ehr what do you mean with adding something like ... ? I simply would use a item economy plugin which does this for me. So there would be no need to define the currency item in the xWarp configuration.

  15. Offline

    Kevin Robbens

    Oh i see, that would be even better.
  16. Offline


    Got a bug for you to fix. ;)

    When an admin/op, with ALL permissions enabled, and they try and change the message of a warp, by using:
    • /warp message <name> [owner] <message> – Changes the welcome message of the warp.
      Alias: /warp msg <name> [owner] <message>
    They get the message "Type /warp help" for help.
    No matter how the command is typed, it always displays that and a warp message cannot be changed.

    Is this a bug or is it the players fault?
  17. Offline


    I will look into this tomorrow, but it would be helpfully if you tell me exactly the command you typed.

    And which version do you use? Because in a very old version, there was a bug, that the command wasn't registered. And you need to quote the message:
    >w msg foo xZise "Nix da"
    23:47:30 [INFO] You have successfully changed the welcome message.
  18. Offline


    Could you add variables such as <NAME> to warpsigns?

    I have a banking system, and I want multiple players to be able to access their own warps by clicking a single sign.

    For example, the warpsign says '<NAME>_Bank'
    If I use the sign, it warps me to Kosyne_Bank and if someone else clicks it, it takes them to Someone_Bank.

    I was trying to use CommandSigns for this functionality, but no luck, tons of permissions errors. I simply want to let my users warp by sign only.
  19. Offline


    Thanks for the idea:
    See also

  20. Offline


    I also updated to both latest xwarp version and latest permissions. They can still create warps.
  21. Offline


    Are you sure you are using 2.11.5 ? Because I especially tested this problem, and on my test server it works (means no permission to create).

  22. Offline


    Every since xWarps 2.9.4, I have never been able to get permissions to work.
    I'm using CB 860 and Permissions 3.1.5. I'm getting tired of seeing the error spam in the log, even though 2.9.4 works just the way we need it.
  23. Offline


    Sorry to disappoint you, but many versions between 2.9.4 and 2.11.5 are working great with Permissions 3.1.5. Okay there could be a Bug (as pointed out by Donny) but except that everything is working.

    So could you please describe what isn't working. Or what the error is?


    Okay important information: I uploaded a wrong file. Everybody who downloaded the xWarp (not jar!) please reload the file.

    If you clicked on the link in this thread you are using the correct version. To check if you are using the latest simply execute “version xWarp” in the server console.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  24. Offline

    Thought Ninja

    The permission node* does not work. I gave my guests* so they could tour the server using signs but they can not use the signs. I also tried doing warp.sign.* and that did not work either. The only way any warps work is with the * permission node :( Oh I also gave the guests* and that doesn't work either... I did test to see that it was not permissions causing the problem. All other commands that the guests can use work, just not any of the xwarp commands or sign warps.
  25. Offline


    The same for* because I'm playing more on my server, I haven't so much time free, to develop xWarp. But I will implement the suggestion from Kosyne. And then I will focus on releasing xWarp 3.

    @Liger_XT5 and Donny: Any further informations, if xWarp 2.11.5 is now doing the job?

  26. Offline

    Thought Ninja

    Oh ok I was unaware of that. Thank you very much it's working now.:)
  27. Offline


    No problem ;) I reorganized the OP a little, with a big “Ressources” Bar at the top ;) and the “Common problems” are now “Common questions” where I added some additional ones.

  28. Offline


    Okay version 2.12.0 is now available. I'm updating the documentation for the new warp signs. On the wiki I already updated the documentation for the new improved list.

    arpey likes this.
  29. Offline


    @xZise Users are able to create warps and warp to them, even with - -*warp* as a permissions node.

    This is a problem.
  30. Offline


    What is that for a permissions node?
    Use this one!
    - '-warp.*'
    This should work, but this is not my part! I simply ask the permissions plugin, if the user has a permission. So check with permissions, if the user has for example the "warp.create.private" permission.

  31. Offline


    Supports #928 and Permissions 3.0???

Share This Page