[TP] VoxelPort v2.033 - Travel In Style and On Schedule [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 28, 2011.

  1. Offline

    Voxel Box

    HawkIHeo, svict4, Mahagon and 5 others like this.
  2. Offline

    Voxel Box

    I threw a quick tutorial video together today for some of the new voxelport functions. this by no means covers everything, but will give you the basics of setups.

  3. Offline

    William Hall

    Hey, I just got the plugin and i followed the video tutorial, I managed to set up the portal but it won't actually teleport me something I've missed?

    EDIT: fixed it :)

    Great plugin :)
  4. Offline


    Thx ;)
  5. Offline


    I really like this idea. I have been watching this plugin for quite a while, wanting to install it on my server. One thing though, I suggest you change the /up command to something of the /vp up sort. /up conflicts with Worldedit which my server uses. Another thing, when I try to use any /vp command, just as Xlaits said, it tells me "/vp - need to write help"

    I am really looking forward to using this mod. Fantastic idea.
  6. Offline


    Well, for one there is NO /up command in this plugin, or any of my other plugins. Even the ones that aren't released. And you get the "help" message because you didn't add yourself to the admns.txt list.

    Why is nobody reading the damn instructions? Do I have to start shouting "RTFM" at everyone that tries to use the commands that isn't permitted to?
  7. Offline


    Sorry about that, I just saw you or someone else using the command /up, which I thought designated the upper part of the voxel port zone. I was thinking it was a shortcut. Sorry about the misunderstanding.
    Also, I was just a little confused with the admins.txt because I expected it to follow Operator status. The problem I have is because I am using McMyAdmin, they only allow you to upload .jar .yml and .properties
    It would be easier for us that use McMyAdmin or something of the sort if you could thread this with permissions. Just a little suggestion. Thanks anyway. Going to need to ask them to add it in for me.
  8. Offline


    No permissions, and you can try to upload it and than rename it?
  9. Offline


    Thanks for the help, but i had already defined my voxelports and everything... i had it before but i just recently installed a plugin that shows the time... for departures and stuff. turns out it was conflicting with that plugin and as soon as i took it out it worked perfectly.

    Thanks anyways
  10. Offline


    I do have permissions installed, and I have everything. My only problem was the file, which I couldnt not upload, period. I couldn't even upload a .yml and rename it. They're about to release a new version of the control pannel that allows us to, so no worries. They also added it in for me.
  11. Offline


    I like the LotR reference in the title... thing.
    Also, great plugins; in fact, great set of plugins! Awesome work!
  12. Offline


    Thanks ;)
    I've been taking a bit of a break for the past two days, but next up will be a plugin that I think you guys will like.
  13. Offline


    On my server (yes it has multiple worlds) at random times the port will stop working and not accept tickets/allow people to depart.

    Here's the startup log if it helps:
    2011-05-25 17:14:33 [INFO] VoxelPort version 2.028 is enabled!
    2011-05-25 17:14:43 [INFO] [VoxelPort] PortTick thread executing. Running at interval of 10000ms, with 200 CodeTime each Tick
    2011-05-25 17:17:27 [INFO] [VoxelPort] ContainerSize set to 100
    2011-05-25 17:17:27 [INFO] [VoxelPort] Config loaded
    2011-05-25 17:17:44 [INFO] [VoxelPort] Portals loaded! 2 portals have been loaded.
    2011-05-25 17:17:44 [INFO] [VoxelPort] Portal zones have been sorted into 1 containers.
    2011-05-25 17:17:44 [INFO] [VoxelPort] Starting thread...
    2011-05-25 17:17:44 [INFO] [VoxelPort] Thread Started!
    For example, there were some new people on and they were like "why wont this airplane work" or whatever and I at first payed no attention to them, however, I eventually did, and realized it would not take my ticket (Paper). Had to restart the server for it to start working again.

    Any idea why?
  14. Offline


    I assume this isnt working since the update? When I go into my port it says Pass accepted and then nothing happens?

    edit:When I turn ticket requirement off it just plain doesnt do anything
  15. Offline


    Who the hell asked you to update?
    MeneXia likes this.
  16. Offline



    Been using this for a while on a private server with little problems. But we did come across a problem when two people were creating a teleporter ( someone does one end , someone the other), the arrive location sometimes ended up under the block it was set at. Another was some plugins started to behave strange when using multi world teleport.

    Any info you need just ask.
  17. Offline


    Everything working great bar one thing:

    When getting on and using ticket... all items of ticket type are taken from players inventory. Not just one?

    Is this a known bug?
  18. Offline


    Whoever wrote the inventory class in Bukkit was nice enough not to allow anyone to remove single Stack instances and instead chose to remove EVERY stack that matched the ID and SIZE of the stack to be Removed. So yeah, it's theoretically a bug, I'll try to figure out a way of going around this when I get some time for VoxelPort. But for now just either create Ticket stalls that players can just grab a single ticket from or tell them to seperate the stacks. It will always remove the entire stack in your hand.
  19. Offline


    Thanks I had already done what you suggested in the mean time. Nice to know you will work on it eventually. You have a great set of plugins, hopefully once ive learnt some more about bukkit ill be in a position where i can help other plugin devs as well as write my own (in public) haha!

    I know the @Celtic Minstrel (i think it is spelt) has a way to remove numbers of items in his general plugin (i dont use it) so he might be able to give you the quick and easy answer :)

  20. Offline


    @Xlaits were you ever able to solve this? I'm coming cross this issue also. No matter what /vp command I try to use, this keeps showing up.

    EDIT: Another "D'oh" moment... never reloaded after modifying admns.txt. Works fine now; continue the good work Voxel people!
  21. Offline


    Hehe, thanks :3
  22. Offline


    Haven't use the plugin yet but THE ART IS FREAKING AMAZING.
  23. Offline


    I'm having an issue with setting /vp target, across worlds.
    I'm currently using Bukkit build 818, and VP v2.028. I have two worlds that I'm trying to connect. I follow these steps and am obviously missing something.
    Step 1. Build the structures that represent the portal.
    Step 2. use /vp point to define zone for the portal on the default world.
    Step 3. use /vp create to make the actual port
    Step 4. use /vp arrive to set an arrival port
    Step 5. use /vp instaPort to make the portal instant
    Step 6. use /vp requireTicket to set false because I don't care for tickets atm.
    Step 7. use /vp targetWorld to get to the otherside.

    After I get to the other world it is ofc in some seemingly random spot, I find a good spot and put down the structure for the next portal, following the above steps. However, when I get to step 7, I instead use /vp target to first portal, and then visa versa.

    My problem then arises that I whenever I do set /vp target to any point in the other world it will always default to that random spot. Both portals act this way. I have tried restarting the server, using /vp targetWorld on both portals to the opposite world, using /vp target on any other portal. None of those seem to work even though it gives a message saying the normal "has set target to" what you meant to. It just doesn't seem to save it.

    EDIT: Portals which have travel to points within the same world work fine.

    Thank you for your help.
  24. Offline


    [email protected]
    I've been informed that bukkit guys have this little 'feature' of Notch's fixed in the next recommended build.
  25. Offline


    Awesome Possum, can't wait. Ty for the reply.
  26. Offline



    dont have a clue what i am doing wrong here....

    i have installed it and all commands ingame works fine
    i set my points, create the port, i set the port up with instaport and then arrive location and finaly i link them together.

    but then nothing happens
    all commands i type in give back a positive answer

    but when i type /vp set it says im not inside a voxelport

    ive tried this severl times now
    dont get it, what am i doing wrong here

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 7, 2016
  27. Offline


    For some reason I keep getting this error
    23:07:11 [WARNING] [VoxelPort] Error while loading VoxelPorts
    23:07:11 [SEVERE] java.lang.IllegalArgumentException: No enum const class org.bukkit.World$Environment.
    23:07:11 [SEVERE] at java.lang.Enum.valueOf(Enum.java:196)
    23:07:11 [SEVERE] at org.bukkit.World$Environment.valueOf(World.java:572)
    23:07:11 [SEVERE] at com.thevoxelbox.bukkit.port.Zone.<init>(Zone.java:24)
    23:07:11 [SEVERE] at com.thevoxelbox.bukkit.port.newPort.readData(newPort.java:439)
    23:07:11 [SEVERE] at com.thevoxelbox.bukkit.port.newPort.<init>(newPort.java:64)
    23:07:11 [SEVERE] at com.thevoxelbox.bukkit.port.PortManager.loadPortals(PortManager.java:149)
    23:07:11 [SEVERE] at com.thevoxelbox.bukkit.port.PortManager.<init>(PortManager.java:45)
    23:07:11 [SEVERE] at com.thevoxelbox.bukkit.port.VoxelPort.onEnable(VoxelPort.java:44)
    23:07:11 [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    23:07:11 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
    23:07:11 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
    23:07:11 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
    23:07:11 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
    23:07:11 [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    23:07:11 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    23:07:11 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    23:07:11 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    23:07:11 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Any suggestions?
  28. Offline


    Very beautiful plugin, thanks for that!
    I have but one question though: What exactly is ContainerBlockSize used for?

    In your wiki you explain it like this:
    What does "to look through" other VoxelPorts mean exactly?

    From what I could see in the code, you divide coordinates by it.
    But I'm wondering what the purpose for this is? Do you divide the coordinates by it so that Java can work with smaller numbers, and because of that it runs more performant? Or does it have some more elaborate purpose?

    I hope you can help me on this, I'd really like to know, thanks in advance! :D
  29. Offline


    Well, I wasn't the one to write the documentation so sry :p

    Either way, VoxelPorts are divided into sorted buckets which are the size of ContainerSize squared. Each container gets a key by ContainerX + ContainerY*10,000. All the VoxelPort Zones get sorted into respective buckets (there is only a bucket where there is a Zone). Now is when they come into play: VoxelPorts allow you to walk into them to perform whatever they are set to do, therefore instead of ( like all these goddamn pluging ) sifting though a list of ALL the damn Object to find whether you match one of them and in 99% of cases you DON'T match those criteria. Well, it seems stupid and wasteful to me. Thats why VoxelPort only checks the Objects in the bucket you are standing in, if there isn't a bucket where you stand ... well nothing to search though rite?

    So basically, that variable varies the size of those Containers, the larger they are the more likely there will be more than one portal inside a bucket, 100 x 100 is quite an area, if you lower the number you get more buckets but less buckets where there is empty space.

    The variable is mostly there for testing stuff, but you may experiment with different sizes.
    Mansarde likes this.
  30. Offline


    can you limit who can use the portal depending on their group?
  31. Offline


    Nice, that's pretty clever. I can see now how this caters to performance.
    Thanks for the insight into this, very interesting stuff!
    Always learning something new.^^

Share This Page