[TP]Sortal -- Sign Based TelePortation! -- v5.1[1.4.7 R1.0]

Discussion in 'Archived: Plugin Releases' started by Lolmen, Mar 10, 2011.

  1. Offline


    mrarroyo, efstajas, megabobi and 3 others like this.
  2. Offline

    Matt Blair

    What do you mean by 'commands don't work yet?' Does that mean I can't set up teleports with signs yet?
  3. Offline


    It says it's bug that needs fixing... Try it out?
  4. Offline

    Matt Blair

    Bugs can sometimes mean server crashes. And server crashes can some times mean loss of items for players.
  5. Offline


    I got it installed and so far hasn't crashed it by launching the server. But I haven't used it in game yet.
  6. Offline


    With "The commands do not work yet", I mean that the commands to set up Warps are not functioning like they should. You can TP with the signs, but only based on Coords atm.
  7. Offline


  8. Offline


    Ah yes, CbutD. I will do that right away.
    For the name: Could be doable. It would be something like
    Sign Name

    Im gonna fix the bugs ive got first, but it might get implemented. Good idea!
  9. Offline


    Can only ops make signs? can only ops use signs?

    Thank you
  10. Offline


    That's for next release.
    Updated to 1.1
    Is now using iConomy, if costs is set to 0 in settings.txt, iConomy will not be used. Otherwise it gives an exception if you don't have iConomy..
    Also, the /sortal warp command is almost working!
    Also added to CbutD
    Commands are working -- not releasing yet, because the sign won't teleport for some reason.
    Just a quick question
    For me, it's easier to store the coords of a warp in one file, which would mean 1 file per Warp.
    I could also try and put all of the Warps in one File, which is more difficult to me.
    What do you want me to make?
    Well, i've got the commands working!
    And i've got the Warps working! If you only have 1 Warp...
    Going to fix that later today.
    Updated to 1.2
    /sortal warp "warpname" this/here/X,Y,Z now works!
    Warps work!
    The Command uses permissions, unless you don't have Permissions installed. (or atleast, it should be working.)
    Commands Work! Warps Work! Bump!
  11. Offline


    can you save the degrees of your view and the direction when you rightclicked on the sign? sometimes it's not wanted to spawn facing west, like it always did in the "original" sortal and does in yours now.
  12. Offline


    Let's see if I can do that...
  13. Offline


    clashes with world edit and world guard =/

    works now, was a problem with permissions, only thought it was a clash because neither worked when i installed this
  14. Offline


    Error report plz?

    I've tried, this might work. Pre-Release build: Link

    I´ve just found out iConomy isn´t working properly with my plugin -- not sure why.
    Trying to fix

    Updated to 1.2.1
    - Now includes Jaw and Pitch, which means that if ur looking west when clicking, you will end up looking west at your destination!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  15. Offline


    Works Great but how do you delete a warp u created
  16. Offline


    What a wonderful idea!
    Going to work on that tomorrow -- if I have time.
    For now, you can delete by deleting that line in plugins/Sortal/warps.txt
  17. Offline


    :) thanks for the instant update, really appreciate it! will have to try it as soon as i update my server to 531. i let 1.2 run with b522 and already placed signs work. but no new ones.
    well, should be really my problem since i shouldn't upgrade to a not-up-to-date bukkit version.
    but the handfull other plugins i run are at b522. so i have to wait :D
  18. Offline


    So how does this work? Right-clicking the sign teleports you? Or PLACING the sign with that information on it teleports you?
  19. Offline


    With a right-clcik of the mouse on the sign ;)
  20. Offline


    if it doesn't work, you might be too close. the "old" sortal wanted you to step back so one block is between you and the sign.
  21. Offline


    Yeah, for some reason, it does that.

    Updated to v1.3
    - Fixed iConomy

    Trying to add some DelWarp...
    It partually works, except for it not actually deleting anything :p <-- which means it does not work at all, but ok.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  22. Offline


    Found quite a big bug, You can make the same Warp multiple times, the Last one will be your coords to teleport to.

    Updated to v1.3.1
    - Fixed a bug where if the money was not 0, you would not have that Jaw and Pitch.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  23. Offline


    I'm doing everything right, CBB B531jnks

    Here's my process;

    Go to position A, type "/sortal warp test1 here"

    Go to position B, create a sign that says'

    Line 1; this is a test
    Line 2; [sortal]
    Line 3; test1
    Line 4; this is a test

    Right clicking the sign gives the error;

    EDIT: I couldn't get the non-coordinate warps to work, but I did get the coordinate-warps to work...

    My question is; is there no "you can use portals, but not create them" configuration / permissions?

    That makes it utterly useless for us (and many servers) as its a PVP environment, and in order to let them USE portals, we also have to let them CREATE portals, meaning they could create a portal to wherever they want, including to enemies, and kill them.

    Pretty dumb.

    sortal.warp asap please? ^.^
  24. Offline


    Could you make the iConomy message customizable, and have support for POSITIVE amounts(and make it customizable per warp)? I'm using this as an exit to my dungeon, and I'd like to change the message to something like, "You've teleported to the [Exit], and received 50 coins for completing the dungeon". Would appreciate it :)
  25. Offline


    I can always try, not sure if I can manage however.

    Line 3 should be w:test1
    Also, the creating of portals is using Permissions, and I thought I might have uploaded a new version which includes sortal.warp and sortal.coords (not sure!)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  26. Offline


    Doesn't work for me.

    When i type "/sortal warp TEST here" it says:
    An internal error occured while attemping to perform this command.

    I'm not using permissions.
  27. Offline


    Cool plugin. I've got a suggestion. Maybe make a config value called "per-sign-basis" and when its true, make the last line of a teleport sign the iConomy cost to teleport using it :)
  28. Offline


    Internal error means that you've got an error report at your Console. Please?

    I might do that, I can also make it so that the forth line can be anything OR cost:blah. <-- gonna do that!
  29. Offline


    I was able to create one warp and then later when I tried creating another I keep getting this:
    2011-03-18 10:31:51 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 2
    2011-03-18 10:31:51 [SEVERE]     at nl.lolmen.Sortal.Sortal.onCommand(Sortal.java:213)
    2011-03-18 10:31:51 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-03-18 10:31:51 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    2011-03-18 10:31:51 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:229)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:645)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:608)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:602)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-03-18 10:31:51 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
  30. Offline


    I think I fixed it now, give me a min to test...

    Positive amounts added in 1.3.2!
    - If you set the fourth line to: costs:-50, you will receive money!

    Upped new version, try again plz? Also, make sure you have the latest CB, but I guess you have.

    DelWarp is very complicated, trying to let it actually work now..

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016

Share This Page