Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Yes it was discussed. You can turn off the alternate location finding in the properties. It's a bit configuration option. Setting it to 0 should suffice I think. I don't remember if you actually get warped or not when it's set to 0 (but at least, you won't end up somewhere else).

    I posted earlier(a while back):
    Setting 'warp_configbit' in config file to 0 (numeric zero) disables the alternate location finding.
    Just to solve your problem with the vaults and stuff.

    But, if you need anything more (info, help) than let me know.

    It is a problem in Bukkit, not in privatewarp.
    Es ist eine bug in Bukkit.

    There already is a bug report for the issue, but it has not yet been solved.
  3. Offline


    Cheers mate your a good dev.

    Have changed anyone below moderator to 0

    We will do some checks and see
  4. Offline



    That setting might be global. At the least it should already be in a configuration file with a value of 3 or something. If it wasn't already there, it most likely won't get picked up as a setting for a group.

    Meaning that this is (most likely , have to dig in the code) not per group. Although I think reading your comment that it's usefull on a per group basis.
  5. Offline


    I saw it on per group in my configs for the different group settings I may have put it there though I'll just double check.

    For me its in /plugins/PluginControl/PrivateWarp/'the groups file'

    Rather then default group file.

    I'll get some testing done and confirm over the next few days.
  6. Offline


    Meh been so log away.. Well Our server don't crash anymore.. Tnx Wrecker
  7. Offline


    Upgrading the server.
    Http service is down for a moment.

    Upgrade complete. Server is back up.
  8. Offline


    Hi everyone , thank you for this plug-in but the problem is that when I enter /pw , /pwa or others it says me "not permission for ..." , I have put the permissions nodes in my permission folder , what is the problem please ?
  9. Offline


    Permissions in this plugin are a little bit different.
    In the past there was no guarantee that there was any permissions. Therefor multiple permissions compatability systems are built into PluginControl.

    So you'll have to read the logging of PluginControl to see what kind of system it is using.

    Report to me:
    What you expected it to use.
    What kind of configuration you have.
    What it says in the logging (errors/warnings/using system...).
  10. Offline


    I have a lot of errors in the screen of my server .. java errors ...

    In game it says me "PW : no permission tu use PW" , in the server screen , when I go in game , there is a lot of java errors (at least 50 lines .. lol)
    I have windows 7 32 bits (is it the config ?)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  11. Offline


    Those 50 lines might just be the ones of interest.
    I need more information from you (unable to help you otherwise).
    32 bits should be fine, unless you have a lot of plugins/worlds/whatever.
  12. Offline


    Here is my plugins folder :
    and error when I tipe /pw :

    Maybe be could you upload youre permission et plugins folders ?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  13. Offline


    Sorry, I personally don't use permissions. Just the built-in one (from PluginControl that is).
    I could post up an example to use the built-in config, but I can only do that when I'm at home.

    Looking at your screens there is something wrong with your portalstick thingy (that where the 50 lines are coming from?). And or maybe your configuration.

    When you start the server, can you post those lines, the first 50 ~100 lines (including privatewarp/plugincontrol startup)?
  14. Offline


    I have deleted all plugins which created problems :

    I think I just need good permission file ...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  15. Offline



    But you'll need a bridge plugin so my plugin can use that.
    Right now, it is not using the permissions system.

    Seen by the log line:
    PC: Using built in group system

    Which is just 2 text files groups.txt and users.txt
    I have an example of those 2, but not at home yet.

    Groups.txt contain the command(s) you are allowed to use.
    Users.txt, which group a user is in.

    I cannot provide you with a good permissions.yml, I don't have one. You might find one when you search the forum, wiki. I thought there were some plugins which can edit that file from ingame on the fly. Might be called superperms (bridge?) or PEx or something. Kinda depends on what you need.


    found in the directory of plugincontrol

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  16. Offline


    is there a way to set it to where we can invite others that have a permission to accept the invites?
  17. Offline


    Sorry, I don't understand the question.
    You mean like a global warp point of some sort?

    Or do you mean invite other players into a (built-in)permissions group from within PluginControl?
  18. Offline


    after removing an user in /plugins/PrivateWarp/players now, that nickname, when enter in the server say "Internal server error" and can't enter, how can I fix it?
  19. Offline


    Did you remove that player file at runtime?

    Than it is a caching issue.
    That user should log out/wait. <- probably not enough.
    Ultimately I suggest a restart of the server.

    The cache has a reference to that file I suspect (which did not get unloaded yet).
  20. Offline


    Yes :(
    however I have already tried to restart the server and doesn't work too.
  21. Offline


    The cache does have some sort of timeout. Not sure to what it is set though.

    When the player disconnects/logs off the data gets unloaded from memory. So I suspect the player was also still connected to the server.
    • Can you stop the server.
    • Recheck if the file is gone
    • Delete it if it is there
    • Start the server again

    Let me know if this works.

    I'll be able to test this this evening with my own account(on my own test server).

    I'll reply you to notify you, seeing your signature ;). I'm sure this is fixable.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  22. Offline


    • Can you stop the server. <done>
    • Recheck if the file is gone <done, the file there isn't after the server stop.>
    • Delete it if it is there <obviously no>
    • Start the server again <done>
    The problem persist
  23. Offline


    do you have some logging of the issue?

    can you move/backup the entire privatewarp folder and see if it is a corrupt file or something?
    Must be frustrating. Any way how I can help you directly? Do you have msn?

    I'm gonna do a quick test on my dev machine now...

    Unable to reproduce tbh.
    When I delete the file it just pops back up (because it was in memory at runtime).
    I don´t even get an IO error.
    Probably more to this.
    Why did you want to delete that userfile?
  24. Offline


    I contacted you via PM.
  25. Offline


    Like i create a private warp and want to invite others to use that warp. But I want to limit who can accept the invite through permissions so there would be a permission node such as

    Something that I can give to my members that will allow them to invite members BUT to where I can limit who gets invited such as if I want to keep it between donators only etc
  26. Offline


    I haven´t made that part yet.
    Last few weeks were too demanding. Christmas holidays are coming though.
  27. Offline


    understandable. Didnt know if you had plans for it or not though either :)

    also not to bug but is there a way to add warm ups at the very least before using the warp?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  28. Offline


    Yes there is a timeout option before you actually get teleported away to the location. That is in the PluginControl directory/Privatewarp configuration
  29. Offline


    ah wasnt sure that will help solve some issues!!
  30. Offline


    Hello Wrecker.

    I've been using your plugin on my server for some time. I recently switched away due to crashes when teleporting from nether (with dev bukkit and outdated plugins) however now the new plugin I'm using multihome has ran into similar issues and the author has yet to update the plugin.

    I'm using Permissionsbukkit, and privatewarp is not directly compatible with it, only with superpermsbridge. I'm willing to forgo groups being handled by my permissions plugin and let the plugin control groups take control, but as soon as I enable the superpermsbridge it finds that and can't obtain a group, and therefore assigns everyone to default group. which means If i choose to use privatewarp (as i need groups with seperate warp amounts), I must disable superperms bridge so that it defaults to the builtin group system. needless to say, That doesn't allow me to use some older chat plugins that still work great, but are not compatible with permissions bukkit.

    I'd like to try again with privatewarp , so my basic questions are as follows :

    Is there a way to manually specify plugincontrol to use the builtin group system?

    When is permissionsbukkit support planned? (I noticed you wanting to add this feature in september, but Its not shown as planned yet on this plugin listing)

    Has the nether teleport issue been resolved? (I noticed a comment about a race condition , i assume you mean memory leak, is this the same issue i'm mentioning?)

    Thanks so much for your time, my users all prefer your plugin over others, and I'm very much looking forward to permissionsbukkit and warp sharing support.
  31. Offline


    The race condition was not a memory leak, more a concurrentmodification exception.
    That has been fixed.

    Didn't know warping to nether did not work?

    About the PermissionsSupport. I think I can fix up something. It is not yet possible to force it to use the built-in permission. Quite easy to implement though.

    On a side note, I always thought of permissions as a hassle.
    That is why I use the built-in without any permissions system on my private server.
    I don't have a nether either on my server. Maybe I should go to the nether some day and check that out. I do have some nether portals in my old worlds, but that is just in the client(single player).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016

Share This Page