Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Please use BukkitDev, with it I can remain updated via e-mail about upgrades or similar :(
  3. Offline


    I'm not a fan of BukkitDev to be honest, but :

    You can always subscribe to this topic to get email messages, and my plugin(s) are also compatible/listed with "bukkit up to date" (a plugin telling there is a new version of Bukkit and other plugins).

    (The link in bukkitUptodate are stables only by default btw.)


    Hmm CraftBukkitUpToDate does not support plugins with direct links anymore. So my plugins are not supported anymore(I think)! To be supported by craftbukkituptodate I would have to move to, but not sure I would want to.

    If need be, I could always set up a forum, issuetracker on my own webspace, but that's not something I like to do since Bukkit is/was in one place with 1 account. If it ever comes to that though, just check my domain (see download links for example) and or use google.
  4. Offline


    Is this plugin compatable with PermissionsEX (PEX)?
  5. Offline


    It should be. I did a compile/run against PEX.
  6. Offline


    It doesnt work anymore for me :(.
    Our server really depends on this, this is the error message:
    Show Spoiler
    [SEVERE] Could not load 'plugins/PrivateWarp.jar' in folder 'plugins': PluginControl
    org.bukkit.plugin.UnknownDependencyException: PluginControl
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(

    Seems to be PluginControl?

    Using CB#1185 with bPermissions
  7. Offline



    seems you are also victim of the loading order of plugins. Did PrivateWarp load before PluginControl?

    See for example this post
  8. Offline


    Thank you so much! It is working now :D

    My users finally got their warps back :p
  9. Offline


    yeah this a nice plugin. people even says its more safe to use then homes :p they dont die in teleport holes or nothing

    keep up the good work ;-)

    p.s hope you update this when 1.9 come's around..
  10. Offline


    I have a humble feature request, have a permission node for /pwa <name> goto, so users can share warps without also being able to set warps for other people.
  11. Offline


    Don't know if its this or the latest spot but I went to my vault i loaded fine but got this error.

    A server reload and I'm getting no errors

    It could be because I'm on RB 1240 of bukkit.

    2011-10-06 01:04:18 [SEVERE] Could not pass event CHUNK_LOAD to Spout
        at java.util.ArrayList$Itr.checkForComodification(
        at java.util.ArrayList$
        at org.bukkit.craftbukkit.CraftWorld.getPlayers(
        at org.getspout.spout.SpoutWorldListener.onChunkLoad(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.ChunkProviderServer.getChunkAt(
        at org.bukkit.craftbukkit.CraftWorld.loadChunk(
        at org.bukkit.craftbukkit.CraftWorld.loadChunk(
        at org.getspout.spout.SpoutNetServerHandler.getFastPacket51(
        at org.getspout.spout.SpoutNetServerHandler.playerTeleported(
        at org.getspout.spout.SpoutNetServerHandler.updateActiveChunks(
        at org.getspout.spout.SpoutNetServerHandler.queueOutputPacket(
        at org.getspout.spout.SpoutNetServerHandler.sendPacket(
        at net.minecraft.server.NetServerHandler.teleport(
        at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(
        at Source)
        at Source)
        at Source)
        at Source)
  12. Offline



    I do not use the Chunk_Load event directly. Seeing a lot of Spout messages it could be Spout related, but I'm not sure.

    I do know what the error means (seen it before, in another Java program), and it could be some kind of List modification when an iterator is used. Might be some kind of race condition which could occur once in a while. Seems like it is happening to a List of players. Maybe while another player logged on / logged off at that exact moment while doing some command?


    I have something similar on the todo list. The difference is that it's an extra command (/pws).

    It does mean that the player needs to give out it's warp to another player instead of letting another player getting a warp. For your exact idea I'd have to add a flag of some sort to make warps accessible to other players. Might be an option worth considering later.
  13. Offline


    Hey The_Wrecker,

    I am looking for a TP plugin that allows me to place a limit of warps per group. Does this plugin have that feature or is it only users? For example, I would like it where my normal players get 1 warp and my donators get 2 warps and my mods/admins get 3 warps
  14. Offline


    Yes this plugin will do that. Please note that unlike other plugins, PrivateWarp stores its configuration data in PluginControl's directory. On my system that's at /plugins/PluginControl/PrivateWarp in my minecraft folder. Each group has a config file in that directory and you can set the maximum warp limit there.
  15. Offline


    Ah okay thanks robnar. I have installed privatewarp and now setting it up. At this state, its very intimidating/confusing. So if i have any trouble with it ill let you guys know
  16. Offline


    I saw robnar already answered your question and he is correct. I probably could not say it better.
    Let me/us know if it works out.

    Other note.
    I was actually hoping for an official 1.9 release. Unfortunatly mojang is not going to release an official 1.9 beta (only prereleases it seems). 1.9 releases are fairly stable as far as I could tell. Although the latest (pre 3) had a somewhat performance hit on my system.
  17. Offline


    It dont work with PEX :(

            prefix: '&c[Admin] &f'
            - rankup.*
            - permissions.manage
            - permissions.manage.reload
            - magiccarpet.*
            - falsebook.*
            - changedat.load
            - changedat.scan
            - essentials.*
            - PrivateWarp.pwa
            - PrivateWarp.pwv
            - PrivateWarp.pwr
    And Admins have NO Permissions for the Command "/pw help", or "/pw", ... .

    PrivateWarp 1.6.0
    PermissionsEx 1.15
  18. Offline


    Any errors in the console (while starting the server, and while executing the command)?
    Any messages in the chat ?
    What version of Bukkit?

    If there are error messages it makes it a lot easier to debug. Or give you pointer on what is going on.
  19. Offline


    Bukkit 1317
    No errors ... nothing in the Serverlog, only that PrivateWarp, PermissionsEx and PluginControl "normal" starts.
    If i type "/pe help", or "/pe" i get the message "PW: No permissions to use: pw"
  20. Offline


    Loading goes wrong looking at your log

    Take a look at these log lines:
    2011-10-16 21:39:45 [WARNING] PC: PluginControl is not yet running
    2011-10-16 21:39:45 [INFO] PC: Loading PluginControl Version 1.2.0
    2011-10-16 21:39:45 [INFO] PC: Using builtin group system
    2011-10-16 21:39:45 [INFO] PC: PluginControl started

    In other words it is using it's built-in system instead of pex.

    I do not know the exact reason, but PluginControl started after PrivateWarp (which is not right).

    There is a post a few posts back about this. Referring to another post. Can you check that?

    This post:
    See for example this post
    Might fix some issues. And pex should load before PluginControl (which it already does looking at the log).

    An then there is something about not finding permissions.... Gotta check pex for that.



    did you install the Permissions compatibility wrapper (permissions.jar)? My plugin needs that. Since it didn't find that it reverts to its built-in system.


    did you get it fixed with the pointers I gave in my previous post?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  21. Offline


    It works now :) I have not installed the "Permissions.jar". Thanks!
  22. Offline


    Hey Wrecker, thanks again for this awesome plugin. I have a few suggestions I thought about because I want to help.

    1. I say remove the "Download Waypoint Converter (to convert and maintain warp files)" because nobody has been using that since last year.
    2. Start creating a BukkitDev page now, it has very cool developer features =)
  23. Offline


    Thanks for the pointers! I love getting input.

    The response got a little long... Might explain my hesitation on BukkitDev though.

    Download Waypoint Converter:

    Yes, it is a bit dated isn't it?
    But it does have a use for server admins moving from Canary to Bukkit. It allows the admin to convert those PrivateWarp files (from the Canary plugin) to PrivateWarp files (for the Bukkit plugin). And yes that plugin from the old hmod days is still in use (although I don't exactly know too what extend).

    The plugin for Canary lacks some feature that this plugin has. I am planning a port from the latest Bukkit code to Canary. At least looking at the options I have for that. I am the Author of both versions btw. Both use the same core.

    All in all the Converter is not pretty, I agree. But removing it... it's not in my way to be honest. I do agree that the top post could do with some polishing in general.

    About BukkitDev:

    I personally do not care about the developer features since I have my own setup (but might come in use though).
    I'm a developer by profession, so I am lucky enough to have the tools handy. This little project is just a exercise/fun to me (but I am serious about it).

    What does worry me is some of the terms:

    For one is that deleted work is archived and not really deleted.
    It does not feel right to me. Especially when they mention rights of use. Seems I'm handing my work out to them.

    I am not the only one, looking at this thread (various reasons there):

    But hell, I might just be a bit paranoid. My experience tells me that nothing comes for free though.
    For users like you it probably is a bit frustrating to go to different places for updates?

    hmm post got a little long.

    oh well. Just my thoughts :)
  24. Offline


    To be honest I'm not fond of BukkitDev either, but I am confident they will get the problems sorted.

    Ugh, I read entirely too many of these agreements for my own health. I'm not a lawyer, but that's pretty standard corporate "cover our own butts" language. Basically it means that they cannot guarantee that something you delete will not still be stored somewhere on their service, be it an off-site backup, a cached copy on a proxy, Google search results, etc. The language about giving them rights to distribute your work over their network just means you give them permission to host your project on their websites. Seems sort of obvious that you give them permission when you post a file, but lawyers require that language in agreements these days. They do say that once you delete something they will stop publishing it (see the 3rd bullet point under the User Submissions section). "You also acknowledge that Curse, Inc. may retain, but not display, distribute, or perform, server copies of Submitted Projects that have been removed or deleted."

    As far as legal agreements go, that's actually not too bad.
  25. Offline



    I know what you mean, but I think I'd rather use my own hosting at the moment. We'll see where it goes. I have an account so it can't be taken.

    On a side note. I mentioned it a bit already. I have been thinking about doing some more for Canary.

    After a small test Canary seems to need less memory compared to Bukkit. But needs a bit more CPU (probably Garbage Collection running).

    The folks there are planning a rewrite of some sort. So I'm kinda following that as well. Quite interesting. On top of that they don't have 10 Permsission systems/dependencies. A big plus since I'm mostly trouble shooting permissions when something goes wrong.... :(

    and they do not use yml... (not a fan of that either)
  26. Offline


    can ervy body help me pls with MYsql

    and i have a error

    08:53:57 [SCHWERWIEGEND] Could not load 'plugins/PrivateWarp.jar' in folder 'plugins': PluginControl
    org.bukkit.plugin.UnknownDependencyException: PluginControl
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.<init>(
            at net.minecraft.server.ServerConfigurationManager.<init>(
            at net.minecraft.server.MinecraftServer.init(
    08:53:57 [SCHWERWIEGEND] Could not load 'plugins/PublicWarp.jar' in folder 'plugins': PluginControl
    org.bukkit.plugin.UnknownDependencyException: PluginControl
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.<init>(
            at net.minecraft.server.ServerConfigurationManager.<init>(
            at net.minecraft.server.MinecraftServer.init(
    08:53:58 [INFO] LWC: Loading shared objects
  27. Offline


    You will need this jar as well:

    If it still does not work read the posts a page back, try that.

    If that does not work out, post the complete startup (console) log here and I'll have a look at it.
  28. Offline


  29. Offline


    see this post

    Plugin Control loads after PrivateWarp in your log.
    As far as I can tell it is that problem.

    The post describes a workaround.

    I think this might be a bug in Bukkit's plugin loading.
  30. Offline


    Hey The_Wrecker, i just want to say its also affecting my server too. Perhaps its beacuse i have lots of plugins as the guy above me I dunno. Since you are too busy to help (Pilots need time to fly =P ) I will create a small workaround tutorial.

    PrivateWarp not loading?
    Description: Is there an error on PrivateWarp when loading up your server? One problem is that while your server is loading, Plugin Control tries to get loaded up after PrivateWarp and it should be the other way around! PC should load up before PW in order for PW to work. This tutorial will help resolve that loading order issue.

    Step 1: Open the PrivateWarp.jar with winrar program (get winrar here)
    Step 2: After thats open, download that plugin.yml on your desktop
    Step 3: Open that plugin.yml thats in your desktop with notepad. It will look like this:
    See the word depend on that file? Edit that word to softdepend
    Step 4: Save the changes
    Step 5: Place plugin back inside the opened winrar window of plugin.jar
    Step 6: Exit winrar
    Step 7: Place plugin.jar back to your plugin folder
    Step 8: Save changes and restart server

    Edit: I tried even doing the above steps, It didnt seem to work and the issue is still there.

    The alternative fix to this is downloading pluginloader.jar and whenever my server restarts, i would type: /plugin load PrivateWarp everytime :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  31. Offline



    thanks for the help. Appreciate it. I think I'm gonna file a bug report of some sort. I can't say that this is a fluke anymore.

    I think the problem might be recursive (softdepend/depend through plugins).

Share This Page