Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


  3. Offline


    Do you also have PluginControl in you plugins folder?
  4. Offline


  5. Offline


    Yes I'm using an older method,but that didn't seem to be the error you posted.

    I'm on the road so I'm not much use to you right now.
  6. Offline


    what can I do now? is better wait an update of PrivateWarp?
  7. Offline


    Yes it might be best to wait for another update. I have accesss to the internet again so I can download/upload stuff again.
  8. Offline


    i found a heavy bug and i think it is with PrivateWarp.
    Following to reproducable this problem:

    I reduce the map size with the latest stable MCEdit and start the server with the new (smaller) Map. You need a private warp where the location is now empty (chunk deleted). Warp to this point and then you crashed the server with PW. Then comes this:

    2011-09-06 20:05:18 [SEVERE] at Source)
    Unknown Source. Is this the prob??

    2011-09-06 20:05:18 [SEVERE] Unexpected exception
        at net.minecraft.server.World.doLighting(
        at net.minecraft.server.MinecraftServer.h(
    2011-09-06 20:05:18 [SEVERE] Exception in thread "Thread-19115"
    2011-09-06 20:05:18 [SEVERE] java.lang.NullPointerException
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.World.a(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.World.a(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.Chunk.a(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.World.setRawTypeId(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.WorldGenMinable.a(SourceFile:57)
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.ChunkProviderGenerate.getChunkAt(SourceFile:478)
    2011-09-06 20:05:18 [SEVERE]     at org.bukkit.craftbukkit.generator.NormalChunkGenerator.getChunkAt(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.ChunkProviderServer.getChunkAt(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.ChunkProviderServer.getChunkAt(
    2011-09-06 20:05:18 [SEVERE]     at org.bukkit.craftbukkit.CraftWorld.loadChunk(
    2011-09-06 20:05:18 [SEVERE]     at org.bukkit.craftbukkit.CraftWorld.loadChunk(
    2011-09-06 20:05:18 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.getFastPacket51(
    2011-09-06 20:05:18 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.playerTeleported(
    2011-09-06 20:05:18 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.updateActiveChunks(
    2011-09-06 20:05:18 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.queueOutputPacket(
    2011-09-06 20:05:18 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.sendPacket(
    2011-09-06 20:05:18 [SEVERE]     at net.minecraft.server.NetServerHandler.teleport(
    2011-09-06 20:05:18 [SEVERE]     at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(
    2011-09-06 20:05:18 [SEVERE]     at Source)
    2011-09-06 20:05:18 [SEVERE]     at
    2011-09-06 20:06:08 [INFO] Forcing save..
    2011-09-06 20:06:09 [INFO] Save complete.
    2011-09-06 20:06:20 [INFO] Read timed out
    2011-09-06 20:07:09 [INFO] Connection reset
    2011-09-06 20:07:21 [INFO] Read timed out
    2011-09-06 20:07:55 [INFO] Read timed out
    2011-09-06 20:09:54 [INFO] Read timed out
    2011-09-06 20:11:44 [INFO] Read timed out
  9. Offline


    That's a tricky one.

    Nasty too. I'd expect that the trunk gets regenerated and you either get teleported in blocks or air. I did warp somewhere where there was no generated terrain before and that worked as I expected above.

    Not with the use of MCEdit though, just a new map. I have yet to test that out.
  10. Offline


    I also can't use PrivateWarp anymore after switching to bPermissions. Using CB#1060
  11. Offline


    I've fixed the core of PrivateWarp.

    This weekend I'll probably be back home so I can release an update. I'll put in a fix for the permissions when possible.

    The core is now fully multithreaded and does not delay the minecraft server code itself!
  12. Offline


    Today my server froze (permanently) when a specific user logs in. I found (by trial and error) that this was related to PrivateWarp and a look at the users datafile in PrivateWarps/players shows that it is gigantic in comparison to all other users (even so the number of warps is limited to 5). The file has over 18kByte. (All the other users have between 20 and 260 bytes. I moved the file away for now so the server now runs again.

    Is there a way to repair this file?
  13. Offline



    Maybe there is. Can you send it to me? (sent you a PM)

    I've uploaded a new version. It's a release candidate containing a (hopefully) working fix for permissions. It also has the multithreading.

    Please report any errors/bugs. Although most functions are the same, the code behind it changed quite a lot.


    you can find it here:
  14. Offline


    I installed the 1.6.0RC Version and ran into two problems:

    First: /pw does not report any stats.
    Second: /pw set does not work

    Both throw the same exception:

    00:02:16 [SEVERE] Exception in thread "Thread-19414"
    00:02:16 [SEVERE] java.lang.NullPointerException
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
    00:02:16 [SEVERE]       at Source)
  15. Offline


    Not sure where it goes wrong, but it's gotta be a permissions thing...

    working on it.

    RC1 is out
    Got a method call which was supported in one permissions system, but not in another...

    I also would like to note that I was testing the plugin with a 1.8.1 build just now. I had no troubles related to the upgrade.
  16. Offline


    Same errors as before. I run he last RB Version (1060) and tried with Permission 3.1.6 as well as PermissionsBukkit+SuperPermsBridge.

    I was able to reproduce the file corruption. I found that Privatewarp does have a problem with special characters indeed. I create a new warp with a special character in the name. Fine. /pw lists the warp correctly, warping to this name works fine. NowI restart the server and log back in. /pw shows me the warp name without the special character, but I can't use or delete it. A look inside the warp file shows that there definitly is some character(s) in there:

    hütte   164.25  102.0   12.0    63.338432       17.549994       World
    The character should be a german umlaut-u (hütte)

    Now I created two additional warps, named "abcd" and "zyx". I stopped the server and took a loot into the warp file.

    zyx     164.8125        102.0   11.6875 66.78843        17.849993      World
    abcd    164.8125        102.0   11.6875 66.78843        17.849993      World
    hï¿ï¾¼tte  164.25  102.0   12.0    63.338432       17.549994      World
    Each subsequent del/set of a warp point + server restart causes the garbage in the last entry to grow.

    Seems like the name is written with a UTF-8 char but read as single-byte characters only, effectivle doubling the garbage on every save/load cyle.

    Just tried with my 1.8.1 server (using PermissionsBukkit):

    22:13:37 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
            at Source)
            at Source)
            at Source)
            at Source)
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetLoginHandler.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:94)
            at net.minecraft.server.MinecraftServer.h(
    22:13:37 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
            at Source)
            at Source)
            at Source)
            at Source)
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.h(
    22:13:37 [INFO] [BBROTHER] Removed 0 records older than 168h00m00s in 0h00m00s.
    22:13:38 [INFO] [FalseBook IC] Loaded selftriggered ICs: 0 done
    22:13:38 [INFO] [FalseBook IC] Loaded selftriggered ICs: 0 failed
    22:13:39 [SEVERE] Exception in thread "Thread-38"
    22:13:39 [SEVERE] java.lang.NullPointerException
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    22:13:39 [SEVERE]       at Source)
    The first two exceptions happend before I entered any command, during or shortly after login. The last one was thrown when I entered /pw. Again the stats line is empty.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  17. Offline



    thanks for the testing.

    It's the first time that there are errors related to character encoding. I'm just using a byte like system in the library which gets converted when saved in memory. Ar you using linux or windows? And what version of Java are you using?

    I still think the nullpointer errors are permission related. I did not experience them with bPermission or PermissionsEx. Is the Permissions plugin loaded after or before the plugin loads?

    I'll be testing this stuff, thanks for the pointers.

    As for the character encoding thing. It's happening when the file gets loaded. So I'll take a look at the loading part. It's real not in the plugin itself actually because I can reproduce it in another piece of software using the same lib. Would it be happening because I've switched to Java7? Haven't noticed this before.
  18. Offline


    It's a linux system running CentOS 5.6, 64bit with java 7:

    $ java -version
    java version "1.7.0"
    Java(TM) SE Runtime Environment (build 1.7.0-b147)
    Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

    SuperPermsBridge and PermissionsBukkit are enabled way before PluginControl and PrivateWarp load.
  19. Offline


    Nailed the charEncoding part.
    Seemed I never needed the 'special' 2 byte characters before.
    Now onto the Permissions part.
    ** feels stupid doing a toString() on a null....
    I'm building a RC2 right now.
    Files are up in the unstable section. I'm rather confident that this version should be working again.

    If it is working, than I'll promote it to be a final release.
  20. Offline


    Yeeha! The exceptions are gone. Multibyte Characters work like a charm.

    But now there is another issue... it does not warp me. No message on the server, on the client I get the "Warped to xxx" message, but I don't actually get teleported. I cleaned out the player warpfiles just in case and started from scratch for this test too.
  21. Offline


    That might be a multi threading issue.
    Is it possible that it is only just delayed? There is a delay function in there....
    Unfortunately I'm at work at the moment, otherwise I'd be looking into it straight away.
  22. Offline


    Tried again and waited for about a minute without daring to move. Nope, I wasn't teleported.
  23. Offline


    After a look in the code I understand why it didn't work. The actual warp code was commented out. I was testing shifted locations with a delay. Gosh.

    But I'm building a final 1.6 version instead of an unstable release...
    Have to do some extra effort to get there, but it'll be worth it.

    Running through the final TODO items...

    1.6 final has been uploaded
  24. Offline


    Fantastic! Just updated my "production" server to 1.6.0. Thanks again for this great plugin! If you ever need a betatester I'd be happy to help out ;)
  25. Offline


    You already were a great help with the unstables. Thanks!
  26. Offline


    Sorry to bother you again. Is it possible to use group-based configs with BukkitPermissions/SuperPermsBridge? After updating from 1.5.0 to 1.6.0 users in all groups now have the default group values.
  27. Offline


    I thought that it should be possible,

    except I did not test that specifically with superperms. What happens is that PluginControl asks in what group the player is in and retrieves the settings for that group. If no group is found than a default value is used as a group(ie 'default').

    I did notice that the permissions plugin returns null for groups, but I figured that that was due to a misconfig on my end (bukkit test environment). That was also the stacktraces/errors you saw earlier. In previous behavior the default check was already in there, so it's not new.

    I've been peeking around and debugging The Superperms Bridge a bit.

    Seems I cannot access/ask the SuperPerms in what Group the User/Player is in (always returns nothing, hence the errors you had before). Thus it is not supported by the SuperPermsBridge unfortunately.

     public String getGroup(String world, String userName)
        return null;
      public String[] getGroups(String world, String userName)
        return new String[0];
    Seems to me that it is known by the developer of SuperPermsBridge.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  28. Offline


    From what I read Bukkit's itself has no knowledge about groups. SuperPerms handles permission nodes only. SuperPermBridge provides a Permissions 2 compatible API to SuperPerms, but can't return a groupname since SuperPerms does not know it.

    No Idea how much work it would be to add direct support for PermissionsBukkit.
  29. Offline


    some work, but perhaps not a whole lot. The most time consuming part is to find the API calls for it.

    I have some free time this Thursday. Maybe I can add support than.
  30. Offline


  31. Offline


    Not so much free time left as I thought I would have. TimeTable got ruined by traffic....

Share This Page