Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Thanks for the input.

    I'll leave it as required, but maybe it helps someone else.

    It could also be because you saved it again... Might affect some rights on the filesystem or something.
  3. Offline


    Wrecker, sry for wasting your time but i rly need your Plugin :p Its great xD I need it. I don´t get what is wrong...

  4. Offline


    I could not find the time to figure out the problem you are having (I was up 2500 feet in the air today).

    Let me see if I can reproduce the thing.

    I've installed/done the following:
    [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    [INFO] [Permissions] version [3.1.6] (Yeti) loaded
    [INFO] WorldEdit 4.6 enabled.
    PrivateWarp 1.5.1
    PluginControl 1.1.1
    JDK 1.7

    I had no problems with PrivateWarp. In one account where I am admin I can use all commands (tested /jumpto /snow and /pw). With my second test account (guest, no rights at all) I can do only the worldedit commands (/snow /jumpto). No errors occurring in the console.

    When removing PrivateWarp PluginControl, same thing happens (except without /pw). I can't reproduce the exact same thing, but it seems WorldEdit doesn't recognise the permissions or something?

    I had 3 other plugins installed (just to try those out), namely
    CraftBukkitUpToDate 2.5.3
            default: true
                prefix: ''
                suffix: ''
                build: false
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
    I recommend you try out the 1.5.1 release under unstables. Update both pluginControl and PrivateWarp. Other than that I can't find anything wrong, except WorldEdit ignoring Permissions on my part (would it use the one built into Bukkit?).

    Can you try out a full clean bukkit install just to test it out? Maybe it's another plugin that gets in the way.
  5. Offline


    Uh nice. Are you Pilot? :p Well i cant try a clear Bukkit installation on my Server. My people want play^^ But i think i can download everything and try it out local on my Laptop. ;) You´ll here from me. I am now going to install it again on the server and we will see.

    Thx so far

    EDIT: Just enabled the Plugin again and i got a fresh new fail :D Maybe you can get something out of it. Ah yes and its still 1.5.0...i´will give 1.5.1 a try now. Here we go:
    2011-08-15 13:47:04 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
    	at Source)
    	at org.bukkit.plugin.RegisteredListener.callEvent(
    	at org.bukkit.plugin.SimplePluginManager.callEvent(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.EntityPlayer.a(
    	at net.minecraft.server.BlockBed.interact(SourceFile:93)
    	at net.minecraft.server.ItemInWorldManager.interact(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.Packet15Place.a(SourceFile:57)
    	at net.minecraft.server.NetworkManager.b(
    	at net.minecraft.server.NetServerHandler.a(
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    	at net.minecraft.server.MinecraftServer.h(
    EDIT2: i was looking around for PW 1.5.1 but i cant find it. But i found a zip with "PublicWarp". What is it for? :D
  6. Offline


    PublicWarp is for a public set of warps. Accessible for everyone. It's another plugin.

    You can find 1.5.1 under the unstables here:

    2011-08-15 13:47:04 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
    at Source)
    at org.bukkit.plugin.RegisteredListener.callEvent(

    This exception is so weird. Probably happens when warping/teleporting, but I don't see what is wrong. What set of jar's do you have in your plugins folder?
  7. Offline


  8. Offline


    Howdy Wrecker. :) About that warp maintenance feature we discussed a while back... You've said before that you want to keep your source closed, but if you were to add some hooks for your plugin I could knock the maintenance features out in no time. Example Hooks:
    GetWarp(Palyer p, String warpName) // Returns the Location that this warp points to.
    GetWarps(Player p) // Returns some sort of collection of this player's warps.
    SetWarp(Player p, Location loc, String warpName) // Add a warp to loc with the given name.
    DeleteWarp(Player p, String warpName) // Delete warpName from the specified player's warp list.

    That would be a bare minimum, but it's a good start. It's fairly straightforward to set up and it allows us to help out without revealing the source. Let me know what you think, and thanks for the awesome plugin. :)
  9. Offline


    Since we are currently leveraging SuperPermsBridge for the plugins that do not yet support PermissionsBukkit, I had to use the true node in the PermissionsBukkit config. That seems to have done the trick, so far as allowing users to access the command is concerned.
  10. Offline


    Nice! You got it working as well.

    I agree it's not very user friendly the way it is (The Converter app that is). And I looked at the code last week to remove the MyWarp code(which I haven't removed yet).

    You talked about deleting worlds, I don't think I got that in the Converter part. Although my plugin will just respond that it cannot find the world... (you could rename the world to deleted_world, but that is it I guess)
    I'm not really fond of doing those things inside of bukkit. Can screw things up.
    Your proposal does have some other uses though. I'll think about it.

    I think I should add a command which reveals world information alongside coordinates and a description. That one is listed on my todo (except without the coordinate and world info).

    I think it's one of the plugins you have that is interfering.
    I use dynmap myself so that is probably not the one causing mayhem.

    Remove all the plugins except PrivateWarp/PluginControl and keep adding them one by one to see where it goes wrong. Does PrivateWarp even work without all the other plugins?

    Are you perhaps using PrivateWarp warp files from an older PrivateWarp version (<1.3.0 or Canary/hmod for example)?. You can convert those using the Converter app.
  11. Offline


    No no, delete a warp not the whole world. :D Sorry for the confusion & thanks for the consideration!
  12. Offline



    thanks for the clarification.

    I can confirm that the new Bukkit build does not break PrivateWarp btw. (Tested 1.5.0)
  13. Offline


    any chance on spout support?
    a command that opens up a screen with all your locations (as buttons)
  14. Offline


    Not sure,

    bit early to say. Spout just got out.

    One thing I might not like is that it makes porting of this plugin more difficult in the future. For example when the Bukkit project stops, or when spout stops.
  15. Offline


    What is a warp ?
  16. Offline


    A warp is a location or teleport point. You can go to a warp by teleporting with the /pw go <warpname>
    So each warp has a name in my plugin which you can define when setting.

    This plugin is multi-world so each warp's location points to some coordinates within a certain world.

    For the record:
    I'm updating part of my server again.
  17. Offline


    is there a way to set the pw like /pg instead of /pw goto and /ps intead of pw set
  18. Offline


    Maybe with the use of commandhelper or another command scripting plugin.
  19. Offline


    got a request:
    Can you modify the program, that private warp only create a player file if a player use a pw for the first time?
    For each player, who hasn't got the pw permission, an empty file will be created.

    That slow down the download via ftp => many small files
  20. Offline



    That's a feature of the upcoming 1.6 version. I'm revising the codebase... I know about the empty files.

    It's partly because of the /pwr functionality.
  21. Offline


    ok when do you think will 1.6 released :cool:
  22. Offline


    Somewhere in the next few weeks.
    I'm going on a vacation. In the meantime 'll be working on the new version.

    I hope I have internet access though.
  23. Offline


    I'm also getting the problem where PermissionControl loads at the very bottom of the list, so PrivateWarps fails the dependancy check and refuses to load.
    I removed all plugins except for PermissionsBukkit, Permissions, PrivateWarp and PluginControl.
    And I'm using CB1060 and I still have the problem, so its not related to any other plugins.

    Its really odd that it loads after all the other plugins, does Bukkit loads plugins alphabetically? It doesn't seem to care what I rename the jar files, it always just loads PluginControl last, so I don't know how it works.

    One thing I should add is I'm using Linux, where filenames are case sensitive even for reading. I do have the jars named PluginControl.jar PrivateWarp.jar

    I tried this in a fresh install of Bukkit on Windows, and it all worked just fine.
    I also did a fresh install on linux, and the problem still occurs, so I'm pretty sure this is a linux specific problem.
  24. Offline



    I thought that because I've entered a dependency in the plugin.yml of privatewarp it should load in the correct order.

    For some reason it obviously does not. Bukkit bug? I'm not sure.
  25. Offline


    I found a fix just now, I edited PluginControl's plugin.yml and took out the dependancy on [GroupManager,Permissions] and now it loads in the proper order. I'll leave it to the professionals to figure out why, it probably is a bug in bukkit. No idea why it would only affect Linux.
    Permissions still dont work for me though, I'm using PermissionsBukkit, and even with " true" and " true" and even "PrivateWarp.*: true" it just denies me. I can see those nodes are being set to true when I do permissions check. At least I get no console errors now, it at least looks like everything is loading right.
  26. Offline



    When you look at the logging you can see what kind of permissions system is being detected and used. PermissionsBukkit is not (directly) supported yet, but superPerms should work.
  27. Offline


    18:50:37 [INFO] Loading properties
    18:50:37 [INFO] Starting Minecraft server on *:25568
    18:50:37 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    18:50:37 [INFO] [SuperpermBridge] Superperm/Permissions bridge initialized
    18:50:37 [INFO] Preparing level "world"
    18:50:37 [INFO] Preparing start region for level 0 (Seed: 3841594328861398080)
    18:50:38 [INFO] PermissionsBukkit v1.1 is now enabled
    18:50:38 [INFO] [SuperpermBridge] Superperm/Permissions bridge enabled
    18:50:38 [INFO] PC: Loading PluginControl Version 1.1
    18:50:38 [INFO] PC: Using builtin group system
    18:50:38 [INFO] PC: PluginControl started
    18:50:38 [INFO] PW: Starting initialization of PrivateWarp 1.5.0
    18:50:38 [INFO] PW: Copyright: Wrecker Technologies
    18:50:38 [INFO] PW: PrivateWarp 1.5.0 initialized
    18:50:38 [INFO] PW: Just got enabled
    18:50:38 [INFO] Server permissions file permissions.yml is empty, ignoring it
    18:50:38 [INFO] Done (0.051s)! For help, type "help" or "?"
    18:50:41 [INFO] Plugins: PermissionsBukkit, Permissions, PluginControl, PrivateWarp
    18:50:45 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    18:50:45 [INFO] This server is also sporting some funky dev build of Bukkit!
    SuperpermsBridge shows up as Permissions of course.

    And I can see I get the right permissions with the permissions check command.

    [INFO] Player kilorat sets to true.
    [INFO] Player kilorat sets to true.

    If this should all work, maybe its related to that hack I had to do to make it even load at all. But the console does make it look like it happily found everything.
  28. Offline


    18:50:38 [INFO] PC: Loading PluginControl Version 1.1
    18:50:38 [INFO] PC: Using builtin group system
    18:50:38 [INFO] PC: PluginControl started
    It's definitly not using permission, but it's using its built in fall back system. So yes it all loads, but it won't question SuperPermBridge for permissions.

    This is the scenario I implemented when no permissions system was found at all. But you do have permissions, strangely its does not find it.
  29. Offline


    That was the clue I needed, I got it working!
    If I download a fresh PluginControl (either stable or dev version), and run it without PrivateWarp, it says
    00:00:31 [INFO] PC: Loading PluginControl Version 1.1.1
    00:00:31 [INFO] PC: Using Nijikokun's Permission plugin (new detection system)
    And when it is loading PluginControl after PrivateWarp, it still at least detects Nijikokun's Permissions (the bridge).
    So it had to be that messing with the plugin.yml that broke it. But if I don't modify it, I'm back to that problem of them loading out of order.
    So I modified it to only depend on Permissions and not GroupManager:

    softdepend: [Permissions]

    and now it works perfectly. I hope that helps you figure it out, I don't understand this stuff. :) But at least I have a fix and can finally upgrade my server to BukkitPermissions, PrivateWarps was the last critical plugin.
    Thanks so much for the help, and of course making the plugin!
  30. Offline


    Umm im a noob. But what does this mod do?
  31. Offline


    Gives you the ability to set more "homes" or "teleport points".

    For example: i can give my "VIP" users the awesome feature to set 5 personal "warp points" ;)

    Ah yea: Its working now. I don´t really know why. I just updated my shitty bunch of plugins :D to 1060, so i also updated my craftbukkit.jar and it works xD THX for the help ;)


Share This Page