Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Stable version is out!

    One little thing with this version is:

    I fogot to reset the default 5 seconds when doing a goto. You'll actually warp like 5 seconds later...

    It's a config issue so you can change this behaviour in your configuration files found under the plugincontrol data directory!

    Also it's a per group configurable setting....

    [edit ]
    before anyone wonders, Issue of oliverw92 is already handled by pm
  3. Offline


    when i start up:
    12:02:53 [INFO] PW: Starting initialization of PrivateWarp 1.4.9
    12:02:53 [INFO] PW: Copyright: Wrecker Technologies
    12:02:53 [INFO] PW: PrivateWarp 1.4.9 initialized
    12:02:53 [SEVERE] Exception in thread "PWClean"
    12:02:53 [INFO] PW: Just got enabled
    12:02:53 [SEVERE] java.lang.NoSuchMethodError:;
    12:02:53 [SEVERE]     at Source)
    12:02:53 [SEVERE]     at
    did i do something wrong?

    and when someone tp's:
    12:04:12 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
        at Source)
        at Source)
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet10Flying.a(SourceFile:126)
        at net.minecraft.server.NetworkManager.b(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(
    and when someone tries to set a warpspot:
    12:21:03 [INFO] <username> tried to use command /PW set sky
    12:21:03 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'pw' in plugin PrivateWarp v1.4.9
        at org.bukkit.command.PluginCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.NetServerHandler.handleCommand(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet3Chat.a(
        at net.minecraft.server.NetworkManager.b(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NoSuchMethodError:;)I
        at Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at org.bukkit.command.PluginCommand.execute(
        ... 12 more
  4. Offline


    Seems like a classloading issue.
    You can redownload the PrivateWarp, PluginControl combination and restart the server with the new jar files (not just reload).

    .. note the timeout function mentioned earlier (configurable).

    What version of bukkit are you running?
  5. Offline


    I'm currently getting this error:

    00:00:35 [INFO] PC: Loading PluginControl Version 1.0
    00:00:35 [INFO] PC: Using Essentials Group Manager plugin
    00:00:35 [INFO] PC: PluginControl started
    00:00:35 [INFO] PW: Starting initialization of PrivateWarp 1.4.9
    00:00:35 [INFO] PW: Copyright: Wrecker Technologies
    00:00:36 [INFO] PW: PrivateWarp 1.4.9 initialized
    00:00:36 [INFO] PW: Just got enabled
    00:00:36 [SEVERE] Exception in thread "PWClean"
    00:00:36 [SEVERE] java.lang.NullPointerException
    00:00:36 [SEVERE]       at Source)
    00:00:36 [SEVERE]       at Source)
    00:00:36 [SEVERE]       at Source)
    00:00:36 [SEVERE]       at
    Plugins: Essentials Suite, Group Manager, SimpleSave, Worldedit, LWC, Dropchest

    953 version of bukkit. I have attempted to also delete the Public and Private folders and restarting the server only to get the same error.
  6. Offline



    That's an interesting error. I will try to reproduce that. It's the cleanup process that errors out. The plugin might still work though(unless your have more errors).
  7. Offline


    I love this plugin. Great work.

    I've one strange phenomenon though. For each category or private warp name a user is created in my world's permissions users.yml file.
    For each private warp and for each category an entry in the users.yml of my world is created (with the username beeing the name of the private warp or category). It happens with creation as well as the use of a category or warp point.

    Another thing I just stumbled over when I tried to set limits based on permission groups. I set max_warps=15 for the group "Moderator". The limit shows correctly using the /pw command but when creating a new warp the limit of the "Default" group is applied (where max_warps=3).

    I use cb953 with permissions 3.1.6. pw version is 1.4.9, plugincontrol 1.0
  8. Offline



    I downloaded the exact configuration you had and I see the same thing happening. Ruling out set up or configuration issues I guess. I don't quite get how the name got there yet. Might be a switch in a variable which has gone wrong...


    I made a mixup between a local and global variable. I'll debug some more if I made that same mistake somewhere else too.

    Fixed You can download 1.4.9a and PluginControl 1.0a which has the fixes .

    I haven't been able to reproduce this. Can you try downloading the new version and completely restarting the server? Let me know if the problem still exists after that...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  9. Offline


    Alright, got the same error, but I decided to get some more information for you. I don't use Permissions, could that be a problem?

    When starting the server:
    21:13:08 [INFO] PC: Loading PluginControl Version 1.0a
    21:13:08 [INFO] PC: Using Essentials Group Manager plugin
    21:13:08 [INFO] PC: PluginControl started
    21:13:08 [INFO] PW: Starting initialization of PrivateWarp 1.4.9a
    21:13:08 [INFO] PW: Copyright: Wrecker Technologies
    21:13:08 [INFO] PW: PrivateWarp 1.4.9a initialized
    21:13:08 [INFO] PW: Just got enabled
    21:13:08 [SEVERE] Exception in thread "PWClean"
    21:13:08 [SEVERE] java.lang.NullPointerException
    21:13:08 [SEVERE]       at Source)
    21:13:08 [SEVERE]       at Source)
    21:13:08 [SEVERE]       at Source)
    21:13:08 [SEVERE]       at
    When logging in:

    21:13:26 [INFO] StirredToFU [/-removed-] logged in with entity id 121 at ([world] -11.0625, 91.0, -46.9375)
    21:13:26 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
            at Source)
            at Source)
            at Source)
            at Source)
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetLoginHandler.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
            at net.minecraft.server.MinecraftServer.h(
    21:13:27 [SEVERE] Could not pass event PLAYER_TELEPORT to PrivateWarp
            at Source)
            at Source)
            at Source)
            at Source)
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(
    When I try to use a command, it says the plugin has made a booboo in the log. On the game, it says a Permissions error has occurred.

    Wuddya think?
  10. Offline


    I just updated my server to the latest stable bukkit (1000) and users can no longer use private warps. I see no errors on the server, but when trying to use a warp, players receive the following message in red...

    PW: Error could not find world
    PW: Contact server administrator

    The worlds have not been renamed/changed at all, just a bukkit update.
  11. Offline


    I think there's a change somehow in the way Bukkit finds worlds. I'll update...
    I didn't see any comments about it on the forum, but I could've missed it.

    thanks for all the info, I'll check it out. Might be Permissions related, hmm

    ... it takes some time till I'm back home, but I think I can sort some of the stuff out and release a new update (built against the 1000 version).

    Privatewarp/PluginControl is not using GroupManager. Instead it seems to use the essentials one.
    Still I don't have the problem with the nullpointer exception that you are having (installed all your plugins, dumped them in the plugin directory actually).

    What I think is happening is that my plugin gets loaded a little too early. Meaning that essentials groupmanager is not yet started. I'm experimenting with that right now...

    Private warp should also log something like a severe when it is not able to find a world. It displays the name of the world in the console. Can you check what it says when you try to warp? I wonder what it thinks it's trying to find...

    New version is up. 1.5.0
    Can you try it out and see if it fixes the problems. Loading should now be delayed till one of the permissions systems load.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  12. Offline


    Works great now. No errors at all, loads almost near the end. Good work and thank you very much. :)

    Final question. Using /pwa, say I wanted to act like Bob and see his warps. I'd do /pwa Bob /pw, correct?
  13. Offline


    No problem,

    thanks for all the reports.

    Using /pwa:
    "/pwa bob"
    Should show the warp list.

    "/pwa bob goto home"
    To go to his 'home' warp.
  14. Offline


    Was thinking of allowing our users 1 extra warp using this as you know we just have vaults atm then I came to realise I want a feature.

    The feature is a set of reserved names that players can only use.

    So we allocate players the ability to make say 3 names and only those names they can be used for example:

    home2 home3 home4

    That would make it so every player can only make a warp with one of those names and nothing else like 'thisplacelookslikechickenandyesthisispurposlylongsoyouadminsgetboredoftypingitoutandgiveup'

    Also makes it compatible with other plugins where we can set costs to commands etc.

    That way every player has the same warp names for themselves making admins jobs easier and means no-one decided to use a name not alias's trying to be smart which we have players trying to do like one of then putting I was here on top of our bedrock vault system as well as planting trees there.

    Kinda like the current template warp but one where players can set it themselves and remove it if wanted.
  15. Offline


    Interesting feature,

    One thing that comes to mind though is the maximum warp limit. When using such a template that setting is kinda obsolete. Or that limit bypasses and actually says how many warps you can name yourself.

    Also, what if those templates both have the same warpname. Do we still let them set the warp or not?

    What do you think?
  16. Offline


    Hmmm interesting response never thought of that.

    I would say works exactly the same as the assigned pwv template system with the maxwarps setting as it is in a way a assigned template but a user manageable one.

    Is not dependent on maxwarps as it should be dependent on many are set by the template for that group.

    If a player makes a warp if its assigned it auto uses that template if its not then it uses one of there free name warps.

    Good if you have a noob rank you don't trust with anything as you can set the free name warps to your trusted players and keep noobs on warp names you know about.

    It needs a extra file or even a section in the main one for each group to assign these templated names to groups so you can split the names up amongst groups for those that wish that do that.

    Assigned Name Warps

    Like members get home pirates get lairs etc for names also useful for giving a higher up group more name templates.
  17. Offline


    Great! Thanks! :D No more entries in my users.yml and per group limits work just fine.

    By the way, I'd have an idea for a feature. If I want to use a warp name in some category I first have to change into this category and then use the warp. Would it be possible to optionally use a fqwn (full qualified warp name) instead?

    Lets say I have a warp name "palace" in a category "builds". Then using /pw go builds/palace would port me there, no matter which category I have set. Or /pw go /home to use the home warp in the default category. The same could be used when creating new warps...
  18. Offline


    I'm gonna add that one on the Todo list. I think it's a great idea, The seperation character will be a space though(I think). I can easily check the amount of params for that command and seperate the logic. Not sure how to select the default group from within another group though... I'll think of something for that. The space is also for backward compatability (what if that character is used in a warp somewhere at the moment).

    I Have a little rewrite on my todo for the warp counting as is. The vault template currently 'eats' warps from players when set. The limit is not active on the pwv command so you can always set and remove, but the players themselves cannot. I didn't do this yet because of the performance impact (calculation), but... a few days ago I had an idea to keep or even improve on the performance and do the calculation as well.

    Note though, performance wise you probably won't notice anything with a rather small template/warplist. Things might start to add up when you have hundreds/thousands of warps. Right now I'm not doing that calculation so performance should be ok.
  19. Offline


    Seperation chars might be an option even if they were used by someone. You could rewrite the names on startup and escape the seperation char in existing files (eg replace / with // or . with ..). Or simply remove these characters from warp names. I see no harm in that since users can list their warp names and will see that the name has changed slightly.
  20. Offline


    It is now working, but users are complaining of a delay before the warp takes place. You type in the command, wait like 10-15+ seconds, then you get transported.
    They are also complaining about not being able to add any more warps. They are saying that the plugin is only permitting them half of what they are supposed to have access to. If a user is supposed to have 20 warps (listed when they type /pw) they can only add 10 of the 20 warps then it gives them an error saying they have reached their limit.
  21. Offline


    at cb 1000 (and 953 too) i had the problem that whenever a player tried to set a warp, that player get the message that he/she already reached the max amount and can't set a warp :(
  22. Offline


    I can explain the delay,

    a few posts back I posted about that issue that I set a default timeout. You can configure that part in the configuration files though and it should be instantanious again. The configuration is under pluginControl (look for a value with 5000 and set that to 0).

    The warp count I cannot explain yet, but I'll get to that part this evening. I can't remember I changed something in that code. Are you sure you have enough warps left? Can you check /pw and post the numbers?
  23. Offline


    If anyone is wondering,

    I'm confiuring my server again. Downtime is expected...

    I am having major issues getting things straight. I hope I can get things up and running again tommorrow. If not I'll put up a temporary alternative download location.

    Seems there is no harm done.
    The server just had a hickup. But I actually had to go to the machine itself.
  24. Offline


    Hmmm I tried to put both Download PrivateWarp and Download PluginControl (v1.1)
    And plugincontrol loaded fine, but PrivateWarp didn't load ? It didn't even show in the error log or anything at all...
    Any clue on why this happened?
  25. Offline


    What happened to the warmup function? My files don't have any values with 5000.
  26. Offline


    Look for this:
    And set it to what ever you like. I didn't remove it, I just defaulted it to 0 again with the latest release.
    So your might say:

    Note though that the entry get's added when used, not on plugin startup.
    I'm guessing you're running Vista or Seven (I'm testing on Seven myself, private server is a winxp 64 VM). What I have noticed on Seven is that when copying files some strange thing happens to rights. Bukkit than completely ignores the jar/plugin like it's not there (which may actually be so, I can't really tell).
    Try downloading it and saving it in a download directory and copy it from there into the plugins dir.

    I hope it helps. If not vista/7 than disregard I guess.
  27. Offline


    It doesn't seem to work... Idk why/how, but when I start my serever, it doesn't say ANYTHING about PrivateWarp, and the commands comes with: "Unknown command." (from Default Commands), meaning it was not detected
  28. Offline


    My server is rented, sorry I can't really do that sadly :(
    If you figure anything else out let me know please! I really want this ;)
    I'll try and talk to my host and see if they're able to do something about this matter.

    Oh and I did try it locally, where it didn't work aswell :(
    I run Win 7 on my pc though...

    Look at the post above yours - I had the same problem, that The_Wrecker answered.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  29. Offline


    The problem is, that I downloaded the .jar file, put it in my Plugin folder, run the server, and that's it... NOTHING.
    No folder, no properties, nothing... When i start the server, it doesn't say ANYTHING about PrivateWarps... It is like .jar file dont exist... :'(
  30. Offline


    That's exactly what happened to me aswell.
    He already answered my post regarding that.
  31. Offline


    As you know,

    I have been a bit occupied getting my server back up again. It is running now at max performance/stability and all, but to keep it that way I'll probably need to do some extra work during this month. I'll try to keep downtime as low as possible (I'll post it up here).

    Further more. I've installed java 7 for testing purposes on my server. I've have yet to test, but I'm excited how that actually runs. I'm still compiling against java 6, but I'll be making the transition once the official 7 release comes out.

    I'm now also going to check out some of the issues which are posted. Maybe do some code changes and a release if necessary.

Share This Page