Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    In the plugins data directory
  3. Offline


    Works perfect with CB #798. :)
  4. Offline


    when i set node for of normal users they don't can't use /pw help, why?
  5. Offline


    Hey Wrecker, any chance of the following:
    1) A way to view warp coordinates in the warp list.
    2) A safeguard to prevent people from warping to a deleted chunk.
    3) A way to delete all public/private warps for a given world.

    When people go to a nonexistent chunk (say a chunk that gets corrupted and has to be removed) it produces a lot of lag and sometimes crashes the server. Likewise when worlds are removed from the multiverse there is no way to clean up the old warps. Thanks man. :)
  6. Offline


    @EmanuxJade ,
    I don't know. I just tested it and it didn't work with my config either. I'll try to solve it. What version are you running?

    @robnar ,
    I'm doing some checks in the unstable builds before actually warping to a section (whether there is a block of dirt and so on). Still working on that part though, but it might help you.

    The removal of world warps is planned for the conversion tool. Server need to be offline to do that (makes sure none of the files are in use). Haven't gotten around to do that yet. Now it probably just says that the world can't be found, but I've never tried it.
  7. Offline


    How come when I type /pw set name it doesn't do anything at all?
    I have the mod installed and permissions enabled.

    Stupid mistake on my part.
    I didn't read, sorry about that. :p

    Thanks a lot for the plugin, btw!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  8. Offline


    i use bukkit build 803 with pw 1.4.6 thx for this awesome plugin :D
  9. Offline


    New unstable build,

    fixed the help. Fixed nullpointer. Against latest RC.
    --Added warping checks in PrivateWarp. When a block is in the way it tries to warp around it (give or take a few blocks).

    Would like to know how this build turns out so I can promote it as a stable!
  10. Offline


    New Stable build is out!

    Featuring safe warping (and not into blocks/void)

    Also checks and notifies you when your warping to something that you should not be warping to (tracks/rails for example).

    I'm wondering what happens when warping from a far though. I don't know yet, but on my private server I had no problems playing (actually why I promoted it to stable).
  11. Offline


    Thank you The_Wrecker. :)
  12. Offline


    Working great with CB #815. :)
  13. Offline


    Hey Wrecker great mod.

    My problem is odd, at least to me, we are using CB b803 and running Minecraft v1.5_02, not sure on the version of PW but the last time it was updated was March 26th, we recently updated to the latest version of permissionsplus and ever since /pw has been returning this error when anyone uses "/pw" on one of our servers.

    "an internal error occurred while attempting to perform this command"

    We have 2 servers and its working fine on our survival server but on out creative server it is giving that responce to everyone that has permission to use it.

    Here is a short sample of the error text in the console:

    "<n3cr0> 16:55:01 [INFO] ?7[MiniAdmin]?f ?4DodgeWatt?f?7:?f try /pw
    <n3cr0> 16:55:05 [SEVERE] null
    <n3cr0> org.bukkit.command.CommandException: Unhandled exception executing command 'pw' in plugin PrivateWarp v1.4.0
    <n3cr0> at org.bukkit.command.PluginCommand.execute(
    <n3cr0> at org.bukkit.command.SimpleCommandMap.dispatch(
    <n3cr0> at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    <n3cr0> at net.minecraft.server.NetServerHandler.handleCommand(
    <n3cr0> at
    <n3cr0> at net.minecraft.server.NetServerHandler.a(
    <n3cr0> at net.minecraft.server.Packet3Chat.a(
    <n3cr0> at net.minecraft.server.NetworkManager.a(
    <n3cr0> at net.minecraft.server.NetServerHandler.a(
    <n3cr0> at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    <n3cr0> at net.minecraft.server.MinecraftServer.h(
    <n3cr0> at
    <n3cr0> at
    <n3cr0> Caused by: java.lang.NoSuchMethodError: com.nijiko.permissions.PermissionHandler.getGroup(Ljava/lang/String;)Ljava/lang/String;
    <n3cr0> at Source)
    <n3cr0> at Source)
    <n3cr0> at Source)
    <n3cr0> at Source)
    <n3cr0> at Source)
    <n3cr0> at Source)
    <n3cr0> at org.bukkit.command.PluginCommand.execute(

    Ignore the <n3cr0> bit its a copy of a message our server owner sent me from an irc channel.

    If you need any more info just let me know, i don't know if i'm right but i think it has something to do with permissionsplus seeing as after we installed the update it started returning these errors.
  14. Offline


    @DodgeWatt you are right,
    it is the permissionplus plugin. Seems to me it does not have the method that I'm trying to call (getGroup). I'll see if I can find an alternative.
  15. Offline


    Thanks i'm keen to see what you find.

    EDIT: Just to make clear both our servers have the same mods, but this is only happening on the creative server, Everything works fine on our survival server, for now lol

    EDIT2:I posted a link to this DigitalTyrants PermissionsPlus thread.
    I can also provided the permission files for both servers on pastebin if you want.
  16. Offline


    after some investigating.
    it seems the plugin uses a different package, but my plugin seems to see Permissions though. Did you rename the jar itself? To Permissions.jar?

    You'll probably see this in the console:
    "Using Nijikokun's Permission plugin"
    , but since it is not nijikokun's permissions plugin things go haywire (and not fully compatible it seems).

    I'm aware that I'm using the name of the jar and it's existence. Possibly not the best option nowadays.

    In short I think I would have to create/add support.

    Wait I got it wrong I think.

    PermissionsPlus is only a front end right? To alter the permissions? What Permissions are you using exactly?
  17. Offline


  18. Offline


    Can you make a option that if there's a block a in the way instead of warping to the closest free block it denies the warp with a message or something?

    Out vault system is all smallish bedrock boxes in one complex if they and have done before block there warp or vault they have appeared in one next to them etc.

    I do not want this to happen as people will abuse it to get into other vaults and steel stuff.
  19. Offline


    I didn't think of that. I'll make an option to disable that on vaults.

    So you are using essentials? I'll have to check that out.
  20. Offline


    Private warps are working fine but our users are not getting any output from the /pw help command (nothing in the console either). The ops (anyone with '*') are not having an issue. I have only applied the permission node to the groups in question... are we missing something?

    PW 1.4.7, CB 766, Permissions 2.7.4
  21. Offline


    I did a fix for that a version back. Seems like the same problem, I'm testing it out. Did you restart the server to be sure everything is loaded properly?

    Doing server maintenance,
    links can be offline during this time.

    -Maintenance finished

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  22. Offline


    I've done quite a few restarts over the past few days for various other issues. I will download the latest jar and re-apply just in case.

    Edit: That worked. Thanks The_Wrecker, and great plugin btw! We've been using since the dawn of CB.
  23. Offline


    No problem,

    I've actually looked at that piece of code again and made another small improvement because of your post.
  24. Offline


    Does this work on CB 818?
  25. Offline


    I don't know yet. I was just about to test it out.

    I'm planning to use config bits to set functions on and off.
    something like this : 10101010101 except as a number. So 3 would be 00011 and 4 is 000100. The config file has the number, with that number you'd be able to set a lot of things on and or off.
  26. Offline


    Oh, well after you've tested it, would you let me know if it works or not? I really enjoy having this plugin
  27. Offline


    Tested it out and worked. Released a new version for 1.6.6

    Setting 'warp_configbit' in config file to 0 (numeric zero) disables the alternate location finding.
    Just to solve your problem with the vaults and stuff.

    Although most of the version numbers didn't change. I recommend downloading all the jars since I've build against the latest Bukkit release!
  28. Offline


    Ty I haven't gotten arround to testing this as our main system is using plugins that are stable abd a little behined as its stable and working.

    We are in the process of a new system so this would be handy for that.

    Also for the multiple private warps can we get some short alias like mentioned I want to use the 'buy commands' plugin to set a price for 1-2 extra private warps for people then reapply that price every time they change the location, but our players even have problems using simple home and vaultwarp allot of the time.
  29. Offline


    I have been thinking about the data directory of PrivateWarp and some of its logic.

    The plugin currently saves data even if there isn't any. This means that for every player that logs on you'll probably get a data file. Although they are compressed it could be a lot of files. I'm thinking about limiting that a bit. I don't think there is much use in keeping empty data files around.

    If you, the admins, could take a look in your data directory and tell me how many files are there (and how many you'd expect, ie members) that would be a great help.

    So next(unstable) release will be more of a code review and update to current functionality than anything new. Although I am thinking about adding some timestamps to the privatewarps.
  30. Offline


    when do you think that next privatewarp version will be released.

    PW: CacheCleanup got interrupted
  31. Offline


    I don't have an ETA for the next release. Probably somewhere this week I'll have some new unstable releases.

    The above code you pasted happens when the plugin gets disabled. It is normal behaviour when it happens during disabling/reloading. When it happens during normal operation something might be wrong.

Share This Page