Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    It works on 1.2.5 but the permissions are not reliable, if you tell it to enableopperms and bypass perms it does work.
  3. Offline

    Lord Chaos

    I am getting this error:

    No idea what is wrong. This is on 1.2.5 :(
  4. Offline


    I am getting same erorr liek Lord Chaos - it started suddenly. And also MyHome doesnt get settings from config file. Like sethome cd, home cd etc. ... it was working fine, but suddenly stopped.

    I tried to reinstall plugin, but it doesnt helped.

    ====> FIXED It was coused by bPermission plugin

    Btw, what mean abort on move? I thought that u cant move when warming up - but it looks liek it's ok...

    Also abort on dmg, when i am drowing, and getting dmg, i can still go /home ... :-/

    Also what about PvP combat, when ppl are in PvP they wouldn't use /home <- i don't know if this coudn't be done by some permissions? :-/
  5. Offline


    Pls update! I was trying some another Home plugins, but they are all crap! :-(

    I think abort on move, and abort on dmg doesn't work...
  6. Offline

    Lord Chaos

    This problem only started happening in 1.2.4 and 1.2.5 :( I haven't changed any plugins)

    And where do I get the 2.3 version?
  7. Offline

    Lord Chaos

    I don't have that, I have PermssionsEX. I don't understand how to make this work. :( Can the author please update this?
  8. Offline


    Thank god!!!! :D A plugin that allows non ops to mark their own home!Thanks a bunch!! XD

Share This Page