Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    hey, I put it on there because someone asked for it to be updated and didn't believe me that it worked so I just put it on there and claimed it to be 1.2. Not my fault you server admins are stupid!
    ACStache likes this.
  3. Offline


    It's hardly obvious that you are telling the person there that you just dropped a version that the dev already compiled into that folder and renamed it. It suggests to me that it was one that you had already sorted.

    When I said Dirty Dev it was in jest :) you thread is very helpful for people the reason I posted a link was because I knew it would invoke some kind of reaction from Spathizilla.
    Who was being more then helpful to the above user.

    The clue about the intent of my post is above when i say us owners/trolls need to stick together. I actually thought that bigwig was trolling :) . So i posted my trolling link.

    Im sorry that you mistook my powers for confusion and I will try to ensure that I correctly bracket my responses in future to reduce further confusion.
  4. Offline


    Heh, I didn't get the sarcasm there my bad :p
  5. Offline

    James Lawrence

    Does MyHome by default give all players all the commands? I'm trying to get my permissions to work and it's annoyingly not working for me lol.

    I'm trying to only give them /home /home set and /home delete or whatever to delete their home.

    I don't want them teleporting to each other's homes or any of that stuff... but I can't figure out how to stop them.
    I've only got the 3 permissions in there...

    I use PermissionsBukkit if that makes a difference or not...
  6. Offline


    m8 im having a problem with this pluggin :( i used to play without permissions and it worked fine.
    Now im using GroupManager and i cant use /home or /sethome..
    i have this message: /sethome - Srts the home position if enable in the configuration.

    And my Yml is like the post -.-

    compassPointer: true
    allowSetHome: true

    help? :)

    no one?
    Here a pick with the problem im having[​IMG]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  7. Offline


    Hi. It seems MyHome does not stop warm up time on damage and movement anymore. I'm running 1.2.3 2060. could you pls fix it?
  8. Speaking of warm up. It says "you will have to warp up for x seconds" instead of warm.
    There should be an option to edit these messages yourself.

    Anyways, thanks for a great mod!
  9. Offline


    Permission nodes don't work anymore with PermissionsBukkit (I think because they removed the superpermsbridge)
  10. Offline


    Having the same problem here.

    Seeing as a RB for 1.2.4 is out, think this plugin will be updated?
  11. Offline


    Yeah, I am having the same problem, bPermissions isn't working with this plugin right now. I think it is because superperm's were removed. When I am op I am able to use the plugin fine, but when I try to use bPermissions, all I get is help about the commands, no actual commands are working.
  12. Offline


    That is exactly what is happening with me as well. MyWarp is also broken, which is another plugin Spathizilla supports. I tried a few forks of MyHome but they aren't as good as the original as they have added features that I do not need. Do you think it will work if I switched permission plugins?
  13. Offline


    Not sure if another permission plugin will work from what I have been reading on the forums and on devbukkit. It seems that it is being frowned upon to support older plugins that haven't updated their permission system, which is why the big permission plugins have dropped support for it. bPermissions removed their superperms bridge a while ago as a result.

    I am tempted to switch to another Home plugin and deal with the downfalls if this one isn't updated soon. People really loved being able to trick other players into using '/home public'. I have been using uHome (fork of MyHome) but it is too multi-home oriented. I wonder if it would help the dev here if he looked at their source to see how to fix permissions?
  14. Offline


    I heard good things of uHome, but like you said, it isn't what I am looking for either.

    Since a RB for 1.2.4 came out, we will see a lot of supported plugins being updated this weekend. I can only hope this one is updated with it as well because it's truly a wonderful plugin.

    FYI: I seen a bug report posted in the devbukkit for this plugin that was posted yesterday so the dev will see the this issue in a few channels other than just the forums. Do you know how many people are involved with this plugin decosun?
  15. Offline


    Are you ever going to make the plguin work for bPermissions now that Bukkit has a build for 1.2.4?
    I really liked MyHome and wish you could continue it. So does everyone else on the sever I play on!
  16. Offline


    Typing all the nodes works. It's not a nice solution, but it will work. So do not add
        - myhome.home.*
    But instead:
        - myhome.home.basic.home
        - myhome.home.basic.set
        - myhome.home.basic.delete
        - myhome.home.soc.others
        - myhome.home.soc.list
        - myhome.home.soc.invite
        - myhome.home.soc.uninvite
        - myhome.home.soc.public
        - myhome.home.soc.private
  17. Offline


    Still does not work.
  18. Offline


    Have problem!
    2012-03-31 16:20:31 [INFO] [MyHome] Enabling MyHome v2.2
    2012-03-31 16:20:31 [INFO] [MyHome] Creating Database...
    2012-03-31 16:20:32 [INFO] [MyHome] 0 homes loaded
    2012-03-31 16:20:32 [INFO] [MyHome] Using localization: English (en)
    2012-03-31 16:20:32 [INFO] [MyHome] Access Control: Using PermissionsEx v1.19.1
    2012-03-31 16:20:32 [WARNING] [MyHome] Help plugin not detected. Only providing help via /home help.
    2012-03-31 16:20:32 [SEVERE] Error occurred while enabling MyHome v2.2 (Is it up to date?)
    at me.taylorkelly.myhome.MyHome.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.t(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
  19. Offline


    Hmm that's too bad, I don't know then... Good luck with it.
  20. Offline


    update it pls for 1.2.4. Error on startup...
  21. Offline


    What other plugins do you have with a /home command?

    This is not helpful.

    MyHome 2.3 development changes: (so far)

    Economy Stuff:
    * Register has been depreciated and removed because it is not as supported as I'd like.
    * Economy support is now via Vault.
    * MyHome will support all economy plugins that Vault does.

    Permissions Stuff:
    * Vault will now provide permissions support where MyHome fails to natively hook it
    * The aliases like myhome.home.* were not registering except for SuperPerms.
    * MyHome will support all permissions plugins that Vault does.
    * Vault's support will not allow for per group/per user values.

    Feature Additions:
    * You can disable respawning to /home in certain worlds - Thanks to Matejdro

    Other fixes/changes:
    * Fixed ConcurrentModificationExceptions - Thanks to ks07
    * A typo in the english localization
    * Fixed a typo in default config

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  22. Offline


    Does it work on Craftbukkit 1.2.5?
  23. on my server...all my users can interact with the commands, but admins and the owner rank cannot. admin and owner ranks have the '*' and i use PermissionsEX. please help us!!!!!!!!!!
  24. Offline


    please post there compiled 2.3dev version, i am using 1.2.5 R1.0 + latest PEX and MyHome still does not detect it.. so we have extreme issue with permissions + MyHome.

    From log:
    2012-04-20 17:32:12 [INFO] [MyHome] Access Control: Using SuperPerms
  25. I gave the admin group * but whenever they do /home, it just says /home help. All other groups work fine. Can you help?
  26. Offline


    we have the same problem on my server, a quick fix is to use a plugin to reload the plugin (PluginReloader is what we use), but perhaps reloading the server works too? i haven't tried that yet but it may work. hope this gets fixed soon though, sorta annoying to keep reloading the plugin after a restart
  27. Yeah I used to play on mcfaction!
  28. Offline


    well.. that's a little weird, i had no idea i was replying to you :p didn't really read your name
    M1dude@MCAtlantis likes this.
  29. ji Jac0b_ remember me???:)
  30. Offline


    I tried this on 1.2.5, just shows /home help
    please fix i've been using it since i got my server

Share This Page