Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    really having problems here with myhome not letting admins use the home commands. Just /home point.

    How can I fix this?
  3. Offline


    MyHome isn't working for me, I have 1597. What do I do?
    Here's the log:
    19:18:30 [SEVERE] Could not load 'plugins/MyHome.jar' in folder 'plugins':
    java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.loadClassInternal(
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(
    at net.minecraft.server.MinecraftServer.init(

    I figured out the problem. I'm using CraftBukkit 1.0.1-RB not 1597 heheh...

    *edit* It SHOULD work with 1.0.1-R1 but it isn't. The log is still the same. Help!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  4. Offline


    Can we please get a fix for admins not being able to use any of the /home commands.

    *edit* Not using permissions, and don't want to use them. All non-ops can use the commands just fine but ops just get what looks like help text.
  5. Offline


    This is unhelpful. I can do all the commands as an "admin" therefore I have to assume user error.
  6. Offline


    I've been doing a bit of testing with this plugin and it seems great!
    You've got some awesome functionality in there, and I love the amount of customization.
    There's just one feature I'm looking for that is pretty huge for a /home plugin on my server,
    Would you be able to add the ability to set a limit to the number of homes a player can own, based on groups?
    That'd be amazing!

    Awesome plugin, keep up the great work.
  7. Offline


    Well I'm having it too and what kind of user error could there be? Its fresh bukkit release and then myhome put in the plugins folder and that's it. Not exactly a lot of room for wildcards in there.
  8. Offline


    Yes, there is a lot of "room" there. MyHome uses other plugins for various things (permissions & economy) and you make no mention of those at all. Those very things are where your problem is. So yes, I'm sticking with user error here.

    MyHome asks your permissions plugin whether you have a specific permission (via their well documented/published methods). If you cannot run a MyHome command in a specific group but can in others then I suggest you check your permissions config as it clearly isnt right.
  9. Offline


    I don't use permissions and I do not use economy.

    That's why I made no mention of them.
  10. Offline


    @Spathizilla Reporting an issue if not running Permissions of any kind. Right now I am an Op on my server, and I can not use "/home". If I deop myself, I am then allowed to use "/home" and get ported to where I set my home. I haven't tried for any of the other commands, but that one stands out the most to me.

    Edit: when typing "/home" it tells me to use "/home help" for the commands, and upon doing so the only command it shows me is "/home point"
  11. Offline


    See I am not the only one with this issue. It can't possibly still be "user error". The problem seems to lie with those who don't use permissions and economy plugins. Can you please look into fixing this now please?
  12. Offline


    It doesn't seem so complicated. Just that on its own myhome doesn't give admins the rights they used to have in previous versions of myhome. Perhaps it just hasn't been tested enough on its own without permissions.
  13. Offline


    That isn't it - I've set up my permissions file (I'm using PermissionsBukkit) as a test now, to give the admin group / or op group (i.e. - me!) access to the home commands, and it doesn't work.

    I'm wondering if it's a hiccup with permissionsbukkit and the number of nodes it can handle, as there's some odd worldguard things going on, where it's ignoring the third group...
  14. Offline


    I have found a problem with raw SuperPerms (ie not using permbukkit or bpermissions). An option will be in 2.2 to enable opPermissions. I tested 1597 with only MyHome installed and no other plugin. Seems PermissionDefault.OP isnt applied as it should be.

    Apologies to those who were having this problem.
  15. Offline


    The key is to give as much detail to show it isn't user error before saying it's the plugin's fault ;)
    I have been known to be wrong in the past, so I try to make sure it isn't me before saying "fix please"

    Thanks for working on this :)
  16. Offline


    This is exactly why I assume it is user error sometimes. If people dont mention what permissions system they use (even superperms) then I have to assume they have screwed something up. Stupid part is superperms is the very system which defines PermissionDefault.OP but then ignores it totally. Every other permission system doesnt ignore it.


    When people have problems I need to know the craftbukkit version, the permissions system (and version), the economy plugin (if applicable), the MyHome config, any errors etc.

    Also... Put it in a ticket on BukkitDev! I dont always watch this thread and tbh if you have missed the "please use bukkitdev" in the original post then the chances are you didnt read other things too.
  17. Offline


    I am having the same issue, it is really weird. I am using bPermissions but I am an op so it doesn't matter. Every home command I try to use it just refers to the help section.

    The same thing is happening in MyWarp.
  18. Offline



    sorry to bother you but I have a quick request, can you make it so it /homes when you use an Ender Pearl and have the command /home optional?
  19. Offline


    When i do /home set it works fine...
    But when i do /home it says: "an internal error has occured while trying to perform this command"
  20. Offline


    hey my players cant set a home . it says "/sethome - sets the home position if enabled in configuration"

    i think i have configured it already idk what could be wrong
  21. dlia ''home invite'' cacoi plugin nujno
  22. Offline


    how to convert sql db on mysql ?
  23. We're all OP but, we can't use any commands.
    [MyHome] Access Control: Using SuperPerms

    any reason?
  24. Offline


    have the same issue as above

    /home as an op errors with "/home help"

    not an op and and it works...i cant keep opping and de oping myself lol
    please fix
  25. Offline


    It has been some time since 2.1b release. Just curious when we will be seeing 2.2 with the permissions fix?
  26. Offline


    2.2 will be along shortly, I've just been doing some other cleanup/overhauls.

    If you insist on a dev build I can upload one but you will need to remake your entire config.
  27. Offline


    Thank you for you time and effort put into MyHome! I look forward to the new v2.2 :)
  28. Offline


    I will gladly use the dev build for the time being.
  29. Offline


    For those wanting a current dev build of MyHome 2.2:

    You WILL need to remake your entire config as the format has changed.
    This should fix the OP permission issue with superperms (turn it on in the config)
    It is likely that Russian localization is *totally* broken.
  30. Offline


    Cheers for that - will ask my host if they will add the Dev version - much appreciated.

    One question - you say it works with superperms - does that means it will work with PermissionsBukkit which 'should' obey Superperms?
  31. Offline


    Should do since PermBukkit has no api to hook into like the others.

Share This Page