Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    Have you removed the old JAR? 1.9.4a used a different file name for the JAR 'MyHome-1.9.4a.jar' and if you have both in at the same time it will cause it to fail on load.
  3. Offline


  4. Offline


    Since Essentials is one big jar file now, it seems not possible. Anyway, MyHome worked for me, still with essentials, until i updated it (MyHome) some days ago to the latest version

    Yes. MyHome is loading properly, but it does not find any previous set homes. When using /home, there is no corresponding line in the logfile. [/quote]
  5. Offline


    I'm afraid I can't replicate the problem on #684 other than by adding in two myhome jar files. Perhaps @Spathizilla can shed more light on the problem.

    Where are you obtaining Essentials from? Because from what I can tell Essentials made the switch from one big JAR to multiple components due to compatibility issues with other plugins and I can't find one with all of them in any more.

    What version of MyHome were you using before? If it was 1.9.4a have you moved the homes.db file from the MyHome1.9.4a folder into the MyHome folder in the plugin directory?

    Edit: I've just found the essentials you're speaking of I believe, is it Essentials v2.1 (The collection pack)? If so, then I've tried adding that to our server and MyHome still functions fine. So the problem is probably down to the database, your log showed 0 homes loading, which means the database is empty.
  6. Offline


    @desmin88, do you have a Help.jar or possibly the tkelly Help plugin? It isnt required but tkelly added support for it but I havent tested this myself.
  7. Offline


    okay, thank you!
  8. Offline


    I have a really strange bug using this plugin "Internal excepetion : received string longer than maximum allowed (16>15)"
    I use bukkit 709 and the last Myhome
  9. Offline


    I havent done any testing with anything beyond 684 yet. Waiting for the 1.5 RB before I start fixing things (as required)
  10. dude lolz... when i do /home set it says set doesnt have a home xD plz help fast :) my permissions are

    default: true
    prefix: ''
    suffix: ''
    build: true
    - 'myhome.home.soc.*'
    - 'BlockHead.hat'
    - 'raveblox.set'
    - 'raveblox.clear'
    - 'raveblox.sync'
    - 'raveblox.del'
    - 'raveblox.use'
    - 'raveblox.list'
    - 'MyHome.home'
    - 'MyHome.home set'
    - 'MyHome.home private'
    - 'MyHome.home public'
  11. Offline


    Those aren't permissions, they're just made up, remove those.
    The ones you want (which you already have one of) are;
    - 'myhome.home.soc.*'
    - 'myhome.home.basic.*'
  12. thanks :)
  13. Offline


    No problem. Hope that's got it working.
  14. Offline


    Just did some quick testing on cb714 and everything appears to still work correctly.
    khamseen_air likes this.
  15. Offline


    I'm not sure what my problem is... I'm running cb714, and everything seems to load fine, but when i do /home, /home set, /home help, or anything else like it, it just says "/home help - displays the MyHome commands"
  16. Offline


    Have you checked the server log file for the area where MyHome starts up? This is the response I get when I don't have permissions set for 'myhome.home.basic.*'. Are you running Permissions at all and if so is it loading correctly on #714?
  17. Offline


    oh wow, my whole world.yml was deleted somehow...
    time to rebuild that

    EDIT: Remember to make your backups, kids.
  18. Offline


    Every time I run the server I get this message:
    [INFO] Need to download 2 object(s)
    [INFO]  - Downloading file :
    No sqlite.jar appears inside MyHome folder (or anywhere else). Everything seems to work fine tho.

    CB714, MyHome 1.9.4b
  19. Offline


    Why I backup every few days. :)

    Spathizilla may have forgotten to update the link when he migrated his site, but try this link. Download it and put it in the lib directory.
  20. Offline


  21. Offline


  22. Offline


    Looks like I made a huge typo in the downloader code then if it is trying for lib/lib
    I'll symlink lib/lib on the server and fix it in the code.

    Edit: Yep, I fail. I forgot the code would check to see if lib/file existed then add the updater url onto the front of it so it all became lib/lib/file. Fixed in github but I wont release 1.9.4c since I've symlinked the lib/lib directory so 1.9.4b will work
    khamseen_air likes this.
  23. Offline


    Does this work with #733?
  24. Offline


    Works on 733 !
  25. Offline


    Confirmed, working well on #733.
  26. Offline


    Getting this error in console on server startup. When I remove myhome jar the error goes away. Is there a simple permission setting on a file that is wrong? Running on centos5.

    [SEVERE] java.lang.UnsatisfiedLinkError: /tmp/ /tmp/ failed to map segment from shared object: Operation not permitted
    It appears to have downloaded the sqlite driver and everything. I also tried importing the old lib folder from previous version and still get the same error.

    CB 733

    Plugins (all latest as of this afternoon)
    World edit
  27. Offline


    Nice plugin, but were it possible to add multiple homes as a configurable function? Pls, it were good for homes in other worlds...
  28. Offline

    Scott Cassaday

    I downloaded the link at the top of this thread and I get the following error when a user logs in "22:06:21 [SEVERE] Nag author: '<NoAuthorGiven>' of 'MyHome' about the following:
    onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)"

    I also get this "22:05:25 [INFO] - Downloading file :
    e.jar" everytime i start the server.

    *** I figured it out, I did not know the two files referenced above needed to go in the lib at the root of the server folder.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  29. Offline


    Sounds like Runescape Spell :)
  30. Offline


    Are you still getting the Nag author about playerjoinevent? If so that's an outdated version of the MyHome plugin you're using.
  31. Offline


    First of all I'd like to thank you for forking this. MyHome always appeared to be the most elegant /home plugin and I refuse to switch to another one.

    I would like to know if it would be possible to setup the permissions via myhome.setting like it is possible with sk89q's config.yml

    I run very few plugin and don't feel the need for the full permissions system.

    Again, thanks for maintaining MyHome. You saved my server.

Share This Page