Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    Woop, thanks for fix! But I thought there was another thread like this already with a fixed version, oh well, moved to releases.
  3. Offline


    I made that fix in the original tkelly thread which is now in the inactive plugins folder. Just did a quick search on the plugins list and this is the only MyHome it found.

    Figured I'd make this thread with the fix since the original wont show up now.
  4. Offline


    Ah, so that explains it. :)
  5. Offline


    Thanks for this. Will you be maintaining myhome going forward, and adding new features?
  6. Offline


    Thanks for taking this on Spathizilla! Makes it so much easier to track updates with a new thread. :)
  7. Offline


    I second this. Thank you Spathizilla. :)
  8. Offline


    Trying to remove essentials from my server at the moment so I have asked this on a few home and warp threads now but none of them see to support the bed based home set I would rather my users use beds to set home and disable the sethome command all together are you planning to add the bed system at anytime?
    Darkaegis likes this.
  9. Offline


    Hm, thanks for the update, but, however, it doesn't work on my server (the old myhome versions always worked)

    It loads:
    2011-04-18 09:23:06 [INFO] [MYHOME]: 0 homes loaded
    2011-04-18 09:23:06 [INFO] [MYHOME] Permissions enabled using: GroupManager v1.0(alpha-5)
    2011-04-18 09:23:06 [WARNING] [MYHOME] 'Help' isn't detected. No /help support.
    2011-04-18 09:23:06 [INFO] [MYHOME] MyHome 1.9.4b enabled
    But the Command /home or /home set doesn't do anything. No error, no entry in the server log, just nothing. :s
  10. Offline


    I'll have a look into this - Perhaps for version 2

    I am using 1.9.4b with GroupManager(1.0a5) and have no issues and cannot reproduce your problem. Do you have any other plugins which add the functionality which might conflict? I'm guessing you didnt use the old MyHome database either since it said it loaded 0 homes.

    I just installed a fresh copy of 1.9.4b to check:
    06:11:38 [INFO] [MYHOME]: 75 homes loaded
    06:11:38 [INFO] [MYHOME] Permissions enabled using: GroupManager v1.0(alpha-5)
    06:11:38 [INFO] [MYHOME] MyHome 1.9.4b enabled
    I tried /home and /home set - Both work as expected.
  11. Offline


    I have a problem. My users can't home, but they have permission
      - 'myhome.home.*' 
    They get an error that they're not allowed to use home. What can i do?
  12. Offline


    Do you have any other plugins which provide the /home functionality?

    Personally I use:
    - myhome.home.basic.*
    - myhome.home.soc.*
  13. Offline


    Well, my users have the following permissions now:
                - 'essentials.mail'
                - ''
                - 'essentials.getpos'
                - 'essentials.motd'
                - 'essentials.msg'
                - 'mywarp.warp.*'
                - 'myhome.home.basic.*'
                - 'myhome.home.soc.*'
                - 'petition'
                - 'mcdocs.*'
                - ''
                - ''
                - 'wormhole.use.compass'
                - 'wormhole.use.dialer'
                - 'wormhole.list'
                - '*'
                - 'tpp.request'
    And still no permission to use the /home command.
  14. Offline


    @Spathizilla Just thought I'd let you know I've got 1.9.4b running on RB 684 without any problems. :)
  15. Offline


    I think essentials has a /home command and causing you problems.
  16. Offline


    Well, no. EssentialsHome is not enabled.
  17. Offline


    Have you tried removing it completely though? As in the associated JAR file, as even if it's disabled via a properties file it could still cause a disturbance for this plugin.

    Have you checked the server.log file to see if the home plugin is activated correctly or if it says there is an error on loading it? Are you using the correct commands, /home set instead of essentials /sethome.

    Sorry if it seems I'm asking obvious questions but these are all helpful in troubleshooting so providing answers like those help to narrow down the source of the problem for you. :)
  18. Offline


    The static link doesn't appear to be working unless you're using a browser:

    [syn@sashimi plugins]$ wget
    --2011-04-20 16:02:19--
    Connecting to||:80... connected.
    HTTP request sent, awaiting response... 403 Forbidden
    2011-04-20 16:02:19 ERROR 403: Forbidden.
  19. Offline

    Alex Berndt

    Download links are broken
  20. Offline


    i get this message at startup

    2011-04-21 14:23:50 [SEVERE] Nag author: '<NoAuthorGiven>' of 'MyHome' about the following: onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)
  21. Offline


    Not Found

    The requested URL /MyHome/MyHome.jar was not found on this server.

    Seems some sort of mainentance is going on
  22. Offline


    how to switch off for essential home?
    when admins have '*'

  23. Offline


    You're not using this version. You're using Tkellys old version which has been outdated since MC 1.4 was released. Update.

    Not sure what the essentials permission is. But to remove a permissions simply add '-' for example '-myhome.home.basic.*' would remove that permission from a person or group.
  24. Offline


    thanks I try it
    any link that works for download v1.9.4b?
  25. Offline


    I'll provide a temporary link until @Spathizilla can get his links sorted. Hope he doesn't mind.
  26. Offline


    Yeh apologies, the links are dead as I'm migrating the entire server over to a new one. I just need to restore the htdocs directory which I will do shortly.
  27. Offline


    I'll leave that link up until you get things sorted out then. :)
  28. Offline


    Already fixed. However if you want I can put your link in the first post as a mirror. Up to you.

    Thanks for providing the backup though.
  29. Offline


    Yeah if you'd like to list it as a mirror that's fine by me. Not a problem. :)
  30. Offline


    Any idea why I'm getting this error?
    23:30:11 [WARNING] [MYHOME] A permission plugin isn't loaded.
    23:30:11 [SEVERE] me/taylorkelly/help/Help loading MyHome v1.9.4b (Is it up to date?)
    java.lang.NoClassDefFoundError: me/taylorkelly/help/Help
            at me.taylorkelly.myhome.HomeHelp.initialize(
            at me.taylorkelly.myhome.MyHome.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException:
            at Method)
            at java.lang.ClassLoader.loadClass(
            at java.lang.ClassLoader.loadClass(
            ... 12 more
    Build 699, but occured on 677 and 684.

Share This Page