Inactive [TP/MISC] DreamLand v3.5 - Skylands are in your dreams [1.2.5-R4.0]

Discussion in 'Inactive/Unsupported Plugins' started by Naitsirhc Hsem, Jul 2, 2011.

  1. Offline

    Naitsirhc Hsem

    DreamLand is a plugin that allows your players to "Dream"!

    DreamLand is now on BukkitDev!


    Happy Dreams!
    d100, himdo, Asimov and 7 others like this.
  2. Offline


    After a while this error spams the console and leaks memory until the server crashes:
    Otherwise a nice plugin. Please fix it, I really wanna use this plugin :)
  3. Offline

    Naitsirhc Hsem

    ok, that is caused when players tp to dreamland instead of sleeping. will fix in 2.4
  4. Offline


    can i use only the generator? like this
            generator: DreamLand
  5. Offline

    Naitsirhc Hsem

    no, but dreamland uses the skylands generator.
    I can add the option to select what generator you want to use for your dreamland world
  6. Offline


    Neither of your download links seem to be working. :'(
  7. Offline


    I appreciate the work you have done, but I would like to try it, both of your links are crap.
  8. Offline

    Naitsirhc Hsem

    Power went out last night, ergo my web server went down. Everything should be back up now
  9. Offline


    Both links are down.
  10. Offline


    can not download:(
  11. Offline


    Yes, sorry. Both links are still down. Please provide an alternate site?
  12. Offline


    still can't download it :(
  13. Offline

    Naitsirhc Hsem

    Sorry, I was at work. Links are back up, the server's IP had changed on the internal network.
    flap likes this.
  14. Offline


    BLOODY HELL. Literally. So I used the bed and I was in a nether kind of place, but just bedrock as far as the eye can see. How do I fix this?

    Fixed it.

    Wait, no, how do I turn the nightmare off?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  15. Offline


    i just downloaded it. i really like it!the problem i have with it is that when you "wake up" it is still night time. how do i fix this? no one else is in the server, and it still stays night time.

    when you go in the config file, there should be a "dreamland 100 " and "nightmare 50" just get rid of the nightmare 50 bit.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  16. Offline


  17. Offline

    Naitsirhc Hsem

    I will try to work a fix into the next version, thanks for the feedback!
  18. Offline


    Ok first off, I do not entirely understand the permissions thing listed. I have none set up, will it work ok?
    I do not want to have the nightmere setting so set it to 0?
    And lastly my screen goes black right when its supposed to prepare the dreamlands but I can have a "nightmere" every time if I want to.
    Thanks in advance!
  19. Offline


    Hi! I just downloaded and installed your plugin - now everytime i try to connect to my server it say "End of Stream"

    Is this because my server is running with the new 1060 bukkit version?

    This code shows up at the console:
    Show Spoiler

    2011-08-16 09:10:16 [INFO] Montor [/] logged in with entity id 187 at ([world] -38.07024825766973, 73.0, -26.23016546151489)
    2011-08-16 09:10:16 [SEVERE] java.lang.NullPointerException
    2011-08-16 09:10:16 [SEVERE]     at java.lang.System.arraycopy(Native Method)
    2011-08-16 09:10:16 [SEVERE]     at
    2011-08-16 09:10:16 [SEVERE]     at
    2011-08-16 09:10:16 [SEVERE]     at net.minecraft.server.Packet51MapChunk.a(
    2011-08-16 09:10:16 [SEVERE]     at net.minecraft.server.Packet.a(
    2011-08-16 09:10:16 [SEVERE]     at net.minecraft.server.NetworkManager.f(
    2011-08-16 09:10:16 [SEVERE]     at net.minecraft.server.NetworkManager.d(
    2011-08-16 09:10:16 [SEVERE]     at
    2011-08-16 09:10:16 [INFO] Connection reset
    2011-08-16 09:10:16 [INFO] Montor lost connection: disconnect.genericReason

    //edit: Went back to built #1000 - working now (seems 1060 has some problems...)
  20. Offline


    ok restarted my computer from last night. i started my server up again, the server loads up what looks like perfectly. when i attempt to join it says "Connection lost. Internal client error: connection refused: connect."
    i don't know what this means. i am using some of the essentials collection, supernaturals, runecraft, bookworm and pumpkin diver. can anyone help?
  21. Offline


    If you updatet to bukkit #1060 this may be the reason - the only thing a can tell you sry xP
  22. Offline

    Naitsirhc Hsem

    If you want to have nightmare 10% of the time, set nightmare to 10. Java random number generators are a finiky thing, I will try to give it a better seed next release.

    I don't think this is a dreamland bug, I tried it on a fresh server where it was the only plugin and it worked fine. It might be another plugin you have.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    Swany likes this.
  23. Offline


    I deleted your plugin and restarted my server - i still couldn't connect.
    Your plugin is awesome, the new bukkit built is the buggy thing^^
  24. Offline


    how do you disable going to the skylands with beds
  25. Offline


    Great plugin! :D
  26. Offline

    Naitsirhc Hsem

    do you mean go to the nightmare only?
  27. Offline


    Just discovered it is working flawlessly, however I cannot get into the dreamland on the same computer thats running the server. I only get a black screen.
  28. Offline

    Naitsirhc Hsem

    Any exceptions? if not, that sounds like a minecraft issue.
  29. Offline


    no just normal sleep and use StarGate to get to skylands
  30. Offline


    The two things I'd like to have added on would be smooth transitioning between worlds (That'd be an amazing effect for filming) and sand somewhere. Not sure how the sand would work out though, considering that gravity affects it....
  31. Offline


    Tried reinstalling. No luck.

Share This Page