Inactive [TP/HOME/WARP] Waypoint v1.6.4(beta)- Teleportation points, home, spawn, and warp management. [1609]

Discussion in 'Inactive/Unsupported Plugins' started by miyoko, Jul 12, 2011.

  1. Offline




    Waypoint - simple teleportation point and home/spawn/warp management plugin:
    Version: v1.6.4 beta


    *New in 1.6: modular command hookins, reworked command system, SuperPerms, ????*

    Waypoint is an easy teleportation point management and home location
    management plugin. You can create teleportation points to go back to later
    as well as share privately with other users. You can also create public warps that only certain groups of users can access.

    Waypoint's Features:
    • Add/delete waypoints for later access
    • List all of your waypoints simply
    • Share your points privately with other users
    • Points are private, and only accessable by you, unless shared
    • Multiworld support
    • Permissions/SuperPerms/OP support with strict nodes.
    • Home location management
    • Home location is automatically set to the bed you last exited (only if enabled in config.)
    • Create and manage public warps
    • Control which groups of users can access these warps
    • Save/Load the spawn points for all of your worlds
    • Selective showing of warps (you only see what you can access.)
    • Teleport easily between worlds
    • Create and import other worlds
    • Create and teleportation signs to travel to warps or world spawnpoints
    Download: JAR | SRC
    Development build (bleeding edge): JAR
    Integrity (CI): Waypoint project

    If you like my work, please consider sending a dollar or two my way so my little development company can pay for a server to do work and testing on :)

    For those of you that want to contribute, or even just watch progress get made on this, check this out:

    Phabricator: Source Code/Collaboration

    • /wp add <name> -- add a waypoint to your list
    • /wp del <name> -- remove a waypoint form your list
    • /wp tp <point> -- teleport to your point
    • /wp invite <player> <point> -- send an online player an invite to your point
    • /wp accept <point> -- accept an invite to a point
    • /wp decline <point> -- decline an invite to a point
    • /wp list -- list of all of your points
    • /home -- teleport to your home
    • /home set -- set your current location to your home
    • /spawn [world] -- teleport to the world's spawn point
    • /spawnadmin <save|load> [world] -- save or load the spawn point of the specified world
    • /spawnadmin set -- set the spawn point of your current world
    • /warp [warpname] -- teleport to the specified warp, if you have access
    • /warp add <warpname> -- create a public warp with the default permissions
    • /warp del <warpname> -- delete a warp you own
    • /warp set <warpname> <owner|permission|or a custom value> <newvalue> -- set property values in the warp's metadata
    • /warp list -- list all warps that *YOU* have access to
    • /warpadmin <set|del> <warp> [key] [value]
    • /tp <player> [target] -- teleport to another player, or teleport one player to another.
    • /tphere <player> -- ejects the target from a vehicle (if applicable) and teleports that player to you.
    • /tploc <x,y,z> -- teleport to a set of coordinates.
    • /world [worldname|create|import|list] -- displays what world you are in and your current position, or if given a worldname, teleports you to that worlds spawn.
    Installation and Configuration:
    Download the jar file and drop it into your minecraft server's plugins/
    folder and reload/restart the server. The configuration will be
    automatically created for you.

    Teleportation Signs:
    To create a teleportation sign, you must format it like this:
    Line 1: [WP:WARP] or [WP:WORLD]
    Line 2: world name or warp name
    Line 3: (optional) description # maybe economy cost at some point soon
    Line 4: (optional) description
    It is case insensitive btw.

    Configuration options:
    'set_home_at_bed': set this to true if you want your home to be reset
    whatever bed you get out of.
    'autoupdate': check for updates and download upgraded jars automatically
    'warp.groups': permission groups for warps
    'warp.string': message sent to user after teleporting to a warp, %w is warpname, %p is playername
    'limits': self-explanatory.

    Permissions Nodes: (should each be self-explanatory)
    • waypoint.basic.add
    • waypoint.basic.delete
    • waypoint.basic.teleport
    • waypoint.basic.invite
    • waypoint.basic.invite.accept
    • waypoint.basic.invite.decline
    • waypoint.basic.list
    • waypoint.debug.config_node_test << debugging *ONLY*
    • waypoint.home -- you *must* add this if you want to be able to use home commands
    • waypoint.home.set
    • waypoint.home.set_on_bed_leave
    • waypoint.admin.spawn
    • waypoint.admin.spawn.set
    • waypoint.admin.spawn.load
    • waypoint.admin.warp
    • waypoint.teleport.teleport -- for general teleportation actions
    • waypoint.teleport.location -- for coordinate-based teleportation
    • -- for teleporting players to you
    • waypoint.spawn -- you *must* add this if you want to be able to use spawn commands
    • waypoint.warp -- you *must* add this if you want to be able to use warps
    • -- you *must* add this if you want to be able to use /world
    •<worldname> -- more info on this below
    • waypoint.warp.access.<permission category>
    • waypoint.warp.create
    • waypoint.warp.delete
    • waypoint.warp.list
    • waypoint.sign.warp
    • waypoint.cost_exempt.teleport -- teleports do not cost a single dime.
    Known Bugs:
    • Set home at bed is not disabling, ever. Currently looking into it. T3
    If you find a problem, report it at Github.

    Permissions Setup:
    Here is a sample Permissions 2.7.4 configfile with Waypoint's nodes already set up, and a user set up to give an example. Change it to your liking.

    << Thanks Pr0Failure :D

    World Access
    As of about 1.6.1, I added a few new things that implement a whole "world access" type schema of features. Players will NEVER be able to access a world unless they have the "<worldname>" or "*" permissions. I will add a configuration option to disable this, but for now, it's always on. If you want to effectively disable it without a config option and your permissions system supports inheritance, simply place the "*" node at the lowest level and it should filter up through everything that inherits that or its children. I only added this because I felt it would be handy in the case of servers wanting to prevent griefing in creative worlds, but leaving whitelisting off, and just spawning all new users in the spawn world, but not letting them traverse your minecraft universe of worlds. There will be a config option to turn this off soon. By the way, if you didn't catch the gist of what I was really saying, this prevents ALL teleporting between worlds (only if you don't have the permissions for that world) no matter what you use to teleport. This catches events at a low level and checks each user's permissions as they change worlds. But enough about this.

    Bugs and Errors
    If you get a "An internal error has occurred" message when you use a command, * PROVIDE A TRACEBACK PLEASE. * (hint: a traceback is the error code in the server console that shows the error and its callers)
    And for those of you that didn't read this text, maybe this image will catch your attention:


    • Fix PermissionsEx not being detected correctly.
    • Rewrite command structure again with sk89q's command framework.
    • Add configuration options to disable various things.
    • Clean up core support code (me.pirogoeth.Waypoint.Core.*)
    • OpenAuth integration in the future?
    Version 1.6:
    • Completely rewrote the command parser from the ground up.
    • Added SuperPerms support
    • Split commands apart into categories (much cleaner for anyone who works through the code)
    • (Supposedly) Fixed NPE from LoadWorlds during plugin load.
    Version 1.5:
    • Rewrote the configuration loader and put it in its own class
    • Restructured config storage
    • Added new warp limitations
    • Added an autoupdater
    Version 1.4.5
    • Fixed warp permission loading and detection
    Version 1.4.4
    • Fixed the internal errors spewed on /warp set
    Version 1.4.1
    • Removed some unneeded imports
    • Removed some unused variables
    • Now using String.format in checkperms
    Version 1.4
    • Added warp management
    • Restructured most of the config file formatting.
    • Homes-per-world (you can have one home per world now.)
    • Added spawn management
    • Added backup/restore of world spawn points
    Version 1.3
    • Added home support
    • Fixed configuration node bugs
    Version 1.1
    • Added invite support
    Version 1.0
    • Wrote all base code
    And some thanks.
    Definitely got some big thanks here, especially to Pr0Failure, who been testing the crap out of this, even during its magical beta stages. And some more thanks to all of you that put up with me not being around for weeks on end due to school. And thanks to others who at one point sent in a pull request to fix something I had missed. I love you all, you're a very supportive community :) Also, some big thanks to Ctark who's been following this like crazy and even digging through my messy code to find nodes to help others while I'm not around :) Again, THANK YOU ALL <3
  2. Offline


    Hi Pr0Failure :)!

    Oh hey guys, merry christmas :)

    I actually have a present you all :)

    Beta 1.6.4 with cooldowns and some other little things :) enjoy <3 AND HAVE A FREAKING GREAT CHRISTMAS :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  3. Offline


    :DDDDDD Also I created some things on Phabricator incase you didn't already see it.
  4. Offline


    No, I didn't see. But now I have :) Thank you my friend.
  5. Offline


    I noticed you have commandbin installed. This plugin uses the same "/warp" command. Commandbin might be taking the "/warp" part of the command before WP processes the command. So when you type "/warp add" commnadbin might be taking priority of /warp instead of WP processing "/warp add".

    You also do not have a permissions installed? so you said you were op and if your op status, you have access to all commandbin's commands.

    Try to remove commandbin or install permissions or just use commandbin (as commandbin has all the commands and functions as waypoint except /wp?)

    If you install permissions try the following node (depending on what permissions you install)
    "CommandBin.general.warp: false"

    This should disable "/warp" for commandbin and WP SHOULD take priority over the command.

    Also does it say "[Waypoint] Warp skylands does not exist" or "[Waypoint] Warp add does not exist" or "warp does not exist"?

    Fuck :( I might have to get individual plugins for all these commands. My data in the files keeps getting wiped on server restart.
    Anyone else use clan forge to config their server?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    Ctark likes this.
  6. Offline


  7. Offline


    Merry Christmas again, everyone. Let it be a great day for everyone, stay safe..

    As much as I wish it worked like that, I don't think it prioritises. Hell, I could be wrong.
  8. Offline


    Restructured config storage.

    Can you enlighten me on how you store the data? I really want to use your plugin but just can't because of data being erased.
    Do you have to use *.yml? Would it be possible to use *.txt?
    I think this is my last string on figuring my problem out. If this don't work then I guess I have to uninstall waypoint :'(
    I ask this because when I test "/ban <playername>" clan forge will update banned-players.txt with the banned name.
  9. Offline


    I'll see if I can get a hold of a clan forge slot and I'll see if I can figure out what the problem is. All the big piles of data that the server admin SHOULD NOT touch is stored in Waypoint/data/*.yml and everything else that the admin CAN touch is just in Waypoint/*.yml. It's not a huge structural thing. But you shouldn't be having this data loss problem.

    And I don't think I can get a clan forge slot.

    Also, I'm going to add gamemode signs to Waypoint. I don't feel like they belong there, but since I already have per-world gamemode stuff going on, I don't see why not.

    Is it sad that I did this for fun on Christmas day?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  10. Offline

    Smokie23 way man. As long as your still spending time with fam you can it. Just don't spend all day doing it :)
    Unfortunately I had to uninstall this epic plugin.
    I has to install all these just to get the functions of WP (and no /wp commands :():
    - Buttonwarp
    - HomeSpawnPlus
    - TeleportSuite
    This also using 8%-15% more cpu :mad:
    But what can you do eh? Wow you been a member since Feb 12! That is my birthday!
  11. Offline


    This makes me sad:/ Maybe I'll be able to solve your problem when I have more time.
  12. Offline


    custom jar using a .txt instead of .yml file? it's just the name of the file shouldn't make much differance?
  13. Offline


    I'm just not sure if that's even the problem.
  14. Offline


    Its not the name of the file but the extension. I thought the same thing but this isn't the only plugin I've had this issue with. Clan forge seems to write to most plugins that use hmod style .txt files. The data is written its just not being updated by clan forge (what I use to config my server). If I manually config my server it works. I just thought it might be this because I tested PlgWarp which uses hmods warps.txt format and it works fine.

    Its no biggie. Ill just suck it up and use 3-4 different plugins or maybe I can find a lightweight plugin kind of like WP, also still have multiplay looking into this for me.
    Ran some more cpu test and performance tests and its actually only using about 2%-5% more cpu.
  15. Offline


    I'll make a special jar of 1.6.4 that uses .txt files. diff'd

    @Smokie23 Here is a jar that has .txt support. Before reloading your server to run it, go to your minecraft directory, and do this:
    mkdir plugins/Waypoint; touch plugins/Waypoint/.usetxt
    And your problems should hopefully be fixed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  16. Offline


    What to do?:
    Under the User "/home set" writes:
    Under the Administrator works "/home set".

    permissions it is not established

    In advance thanks for the answer.
  17. Offline


    Wait, do you have a permissions plugin installed?
  18. Offline


    NEVERMIND! I had two extra lines at the end of the code which was messing it all up

    Hey man, love the waypoint mod but I am having a few problems. I've been trying so hard to get these permissions to work but shit just isnt happening. I found a few things in my server log that may be of assistance.

    26.12 14:52:48 [Server] INFO in "<reader>", line 41, column 1:
    26.12 14:52:48 [Server] INFO found character '\t' that cannot start any token

    26.12 14:52:48 [Server] INFO [Permissions] (Yeti) disabled successfully.
    26.12 14:52:48 [Server] INFO [Permissions] (Yeti) was initialized.
    26.12 14:52:48 [Server] SEVERE [Permissions] Shutting down Permissions due to error(s).
    26.12 14:52:48 [Server] SEVERE [Permissions] Unable to load permission data.

    26.12 14:52:50 [Server] INFO java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
    26.12 14:52:50 [Server] SEVERE Error occurred while enabling Waypoint v1.6.3 (Is it up to date?): com/nijikokun/bukkit/Permissions/Permissions

    I have no idea why permissions was unable to load the data.

    Are you able to help me with any of this
  19. Offline


    ok, so i am having the same issue with the signs.... i cannot figure out how to format this.... lets say i had a WARP called RES, an i wanted a tele sign that goes to it... It is in a world called CC. how do i format this? i tried more recently... although i have tried so many different combinations, that i have somewhat given up. any help is appreciated.
  20. Offline


    Nono :p

  21. Offline


    Am i making a distinction between a waypoint or a warp when i do [WP:WARP]? like would it be [WP] or [WARP] or is it [WP:WARP] just like that?

    And of course, thank you for all the help :D
  22. Offline


    [WP:WARP] = Warp
    [WP:WORLD] = World
  23. Offline


  24. Offline


    Ok, thank you. I will work on it... for some reason i am not having much luck getting it to work though..
  25. Offline


    Hey guys sorry this is a noob question, I am new to this. I am using PermissionsEX and I'm really confused about<worldname> permission. There is a great explanation for<worldname> but none for the 1st. Maybe you could add a explanation? Help would be greatly appreciated, Thanks!

    Also how do you get Waypoint to detect PEX?? Keeps saying
    06:24 PM [INFO] [Waypoint] Reading configurations.
    06:24 PM [INFO] [Waypoint] Configuration successfully loaded.
    06:24 PM [INFO] [Waypoint] No Permissions plugin detected. Using OP
    06:24 PM [INFO] [Waypoint] Enabled version 1.6.3
    06:24 PM [INFO] [Waypoint] Saved all configurations.
    06:24 PM [INFO] [Waypoint] Auto-update is disabled.
    06:24 PM [INFO] [Waypoint] Limits enabled with threshold 10
    06:24 PM [INFO] [Waypoint] WarpLimits enabled with threshold 10
    06:24 PM [INFO] [Waypoint] Warps: loaded permission groups: Default, Mod, Admin

    I have PEX running and have added permissions for waypoint to it but it will not detect it. =(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  26. Offline


    I'm still not having any luck... at this point i feel really stupid. Can somebody send me a screenshot or something? I would really appreciate it. :D

    Thanks guys!!!
  27. Offline


    Say you have a world called candyland, the access node for it would be, if you want everyone on the server to be able to go to any world just add* for your lowest ranking class (granted you have higher ranks inheriting your lower ranks)

    If you download the PEX zip there should be 4 jars in there including PermissionsEX and another Permissions jar. Add both, and ChatManager if you want the prefix/suffix to work, and ModifyWorld if you wanna get into that, but I don't use it even though I still have it installed, I just disabled ModifyWorld in it's config. Permissions.jar will work as a layer/add-on to PEX that acts like Yeti's Permissions but is hooked into PEX's config. And when you start up a server it will say Waypoint is going off of Permissions 2.7.7 DO NOT WORRY, THAT IS STILL PEX

    Make sure you're running 1.6.4, I believe that 1.6.3 and below run on a different sign setup.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  28. Offline


    Thank you SOO much for the prompt answer!! I was really confused...

    And sorry I typed it wrong.. I ment to say i was confused about waypoint.warp.access.<permission category>

    Horay! I was missing the Permissions jar. Warp works!
  29. Offline


    If you watch the tut video (even though it's outdated) it works the same way. Go into the config of Waypoint and change the groups there. So say you have (DO NOT USE THESE GROUPS, USE THE GROUPS IN YOUR PERMISSIONS FILE!!!!)
    - Default
    - Member
    - Mod
    - Admin
    as your groups in the config file. You would go to your permissions plugin and the group nodes would be waypoint.warp.access.<groupname> which would be the groups you entered in the config. So you give the nodes to the corresponding groups:
    NOTE: waypoint group nodes are case sensitive. Make sure you have group inheritance so higher groups have lower group warp permissions! The first group listed in the waypoint config WILL BE the default warp permission whenever you make a new warp. So if you have the group Guest as your first in the config for groups, all new warps will be set to Guest permissions which would be waypoint.warp.access.Guest
  30. Offline


    Oh i think i got it.... is waypoint.warp.access.<permission category> where waypoint.warp.access. is access to a warp if you are in <permission category> such as Default, Mod, Admin

  31. Offline


    Thank you, problem solved. :D

Share This Page