The Official Java 6 Plugins List

Discussion in 'Bukkit Discussion' started by ravenclaw697, Feb 20, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    ravenclaw697

    Hi guys, i know there are a lot of people running their servers off of macs, like me. As some of you may know, Macs do not yet support Java 7. So if you have a plugin that is coded in java 6, I would like you to post it here, so all of us apple people can know what we have available to us
     
  2. Offline

    md_5

    Its more like which plugins use Java 7. Of the 8,000 plugins only a few hundred use Java 7.
     
  3. I compile with java 7. 0.0
     
  4. Offline

    nhadobas

    Macs can run Java 7 :/
     
    zack6849 and Bo98 like this.
  5. Offline

    hikeno19

  6. Offline

    md_5

    I made a count (its about 2 months old):
     
  7. Offline

    ravenclaw697

    Yes i know they can run it, but you cant put it on the server, i get the unknow class error, does anyone know how to fix this?
     
  8. Update your java. Only way.
     
  9. Offline

    ravenclaw697

    I updated my java, how do i check what version my server is running
     
  10. Offline

    zachoooo

    I still compile in Java 6 just to avoid complaints.
     
    Bo98 likes this.
  11. Offline

    Sagacious_Zed Bukkit Docs

    Code:
    java -version
    :rolleyes:

    If the version reports 1.6 you may need to adjust it in your java preferences.
     
    zachoooo likes this.
  12. Offline

    LaxWasHere

    Java 8
     
    Bo98 likes this.
  13. Offline

    McAvarice

    People need to update their darn servers to java 7. I don't like getting 40 warnings because I have them set to java 1.6 in compiler(Yes their is a way to fix this. I don't wanna)
     
  14. Offline

    Hoolean Retired Staff

    I have Java 7 but java -version seems to report Java 6. Somewhere I've screwed up xD
     
  15. Offline

    jacklin213

    I just compile with 6 cause I don't want people screaming at my face
     
  16. Offline

    Hoolean Retired Staff

    I have Java 7 yet java -version reports Java 6 (I'm on a mac) any ideas?

    Also, shouldn't this be in the offtopic section?
     
  17. Offline

    Bo98

    md_5

    What plugins use JDK 1.1?
     
  18. Offline

    codename_B

    LOL! JDK 1.1
     
  19. Offline

    Deathmarine Retired Staff

    Java Version 7 Update 15 for Mac OS
    http://www.java.com/en/download/faq/java_mac.xml

    You can download and run multiple versions of java without many issues, currently I have jre6 x86 and x86_64 as well as jre7 x86 and x86_64. Java is kinda like a playstation, you can play PSX (jre5) and PS2 (jre6) games on a PS3 (jre7) but not PS3 (jre7) games on a PS2 (jre6).
    There is a full compatibility chart if your truly interested.
    http://upstream-tracker.org/java/versions/jdk.html
    As well as Oracle Documentation.
    http://www.oracle.com/technetwork/java/javase/compatibility-417013.html

    But this is not a plugin request. Could we get a move on this TnT.
     
  20. Offline

    Bo98

    Only that the PS3 no longer supports backwards compatibility on new consoles :p
     
  21. Offline

    TnT Retired Staff

Thread Status:
Not open for further replies.

Share This Page