The Bukkit Consulting Firm - Solving all your Bukkit-related challenges!

Discussion in 'Bukkit Help' started by M1sT3rM4n, Aug 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Essentials has a SocialSpy function that does exactly that: allows you to see other players' private messages when you toggle SocialSpy on.

    Alternatively, you could get a simple plugin that logs commands to your server.log and then look at that file for any "sneaky" needs. The drawback incumbent with this alternative solution is that only you, the server owner, can "spy" on people because only you have access to the server.log (I assume). However, having this extension can prove to be useful in many situations, just in general.


    Have you tried running just a vanilla bukkit server for a few hours/ a day to see if the problem persists?

    It could be that a plugin is tampering with some of bukkit's functions, making the error seem to stem from bukkit, itself - though the problem might not be a direct result of bukkit's native functions.

    I don't have a clue why you're encountering that problem, but running a vanilla bukkit server is a good diagnostic test in situations like this.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  2. Offline


  3. Offline


  4. Offline


    On my server, both groups "default" and "builder" are not allowed to use /spawn. Also, default can't /warp. I NEED HELP!
  5. Offline


    the permisson nodes are essentials.spawn and essentials.warp I think, put them in globalgroups.yml under Builder and default
  6. Offline


    Hehe, thats exactly what I need. I don't really like Essentials, or any other All-In-One-Pack. I like to build my own plugin list :D
  7. Hello, i've got a problem.

    Tekkit version: 2.1.0
    Bukkit version: 1.1-R4
    Operating System: Windows 7 (x86) Home Premium
    Version of Java: Java 7
    Description of Problem: Picaxes (and other tools ?) are disappearing when used for a short amount of time. There are no error logs on console or something. Anyone can tell how to prevent this?

    Using these plugins: SWatchdog, WorldEdit, Towny, Register, WorldSaver, Vault, Permissionsex, Questioner, WorldGuard, Essentials, ChatManager, AuthMe Permissions, Modifyworld, LWC, WorldBorder

    Error Messages:
    There are no error messages.

    Without bukkit plugins it doesn't break. I even tried to one plugin, remove it and add the other and etc and there were no pickaxes-bug. But when i turn on all plugins, booom.

  8. Offline



    I would suggest testing each plugin in hopes of pinpointing the culprit.

    Since you don't have too many plugins, this shouldn't be too tough a task - though it will be a bit rote and tedious.
    Start with no plugins and keep adding plugins, one-by-one, until you find the plugin that causes server mechanics to "break," as you put it.

    Then, after isolating the problematic plugin, remove it and check the plugin's thread. Optionally, notify the plugin dev. of the issue and they might fix it/make a work-a-round for Tekkit.

    Edit: Didn't see the part of your post where you said you tested plugins.
    Nonetheless, don't remove plugins when you test them. Just add plugins until you encounter the issue - don't add one plugin, remove it, and add another.

    There's probably some incompatibility between plugins - not necessarily Tekkit related, though it could be. Start with 0 plugins and add plugins (don't remove any!) until you encounter the plugin that seems to be responsible for the error.

    Removing that plugin should resolve your problem, but you could keep testing by starting with the first plugin you added and cumulatively removing plugins, until the problem disappears. This would indicate an incompatibility between two plugins.

    If you can't follow what I'm getting at (it's a bit convoluted, I know), I can try and clarify after you re-test like I've recommended.

    Post your permissions file on and provide us with a link if you want any accurate help.
    Also, please specify which permissions manager (permissions plugin) you are using.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  9. Offline


    We also need a plugin list.
  10. Offline


    After installing (then uninstalling) the 'Promotion' plugin, everyones rank went and doing any /manuadd command I get this
    2012-05-27 21:02:28 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'manuadd' in plugin GroupManager v1.9 (2.9.1) (Phoenix)
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.handle(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NullPointerException
    at org.anjocaido.groupmanager.GroupManager.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 12 more
  11. Offline


  12. Offline


    its: [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R1.3-20-g45703c2-b2195jnks (MC: 1.2.5) (Implementing API version 1.2.5-R2.0)

    EDIT: just updated to most recent
  13. Offline


    Soooo... 1.2.5-R3.0?
  14. Offline


    Your GM build, as displayed in the error, looks outdated; You should be on version 2.x.x if you're on a recent bukkit build.

    Remove your old GroupManager (and GroupBridge, if you're using it) and install EssentialsGroupManager.jar and EssentialsGroupBridge.jar, dowloading them from this link.

    The problem probably wasn't due to Promotions; it was most likely due to your GM being outdated.
    tyzoid likes this.
  15. Offline


    Deleting the groupmanager folder fixed it for me. It worked fine before I installed Promotions though
  16. Offline


    Glad you found the problem :)
  17. Offline


    Seems like basic server problem, but I am stumped.

    I was running vanilla minecraft server, and could connect localhost and other LAN users no problems. After install craftbukkit (downloaded two days ago), localhost works fine, but other LAN users cannot see the server. Switch back to vanilla server, LAN users work again; switch back to craftbukkit, LAN users can't see it.

    Searched quite a few forums, but not finding many ideas about how to investigate, as all the hits involve portforwarding, which I am not trying to do. So, sorry in advance if this is answered somewhere.

    Any advice or hints greatly appreciated. Running on Windows 7.
  18. Offline


    What do you have in the "server-ip" line of your Is it blank, like so:
    Since you're on a LAN, meaning the same network, I don't think port forwarding is necessary or pertinent.

    I don't have much experience with LAN networks and none what-so-ever in regards to minecraft (Xbox LAN, anyone?). What ip are your LAN users trying to connect with?
  19. Offline


    Does it bother you that I just reverse capitalized your name?
  20. Offline


  21. Offline


    Ah, good to know.
  22. Offline


    server-ip is blank, like you show. I also tried putting my server-ip in there just to see if that had any effect, but nada.

    I have since discovered that turning off the public firewall on my server box makes the bukkit server visible. Which is odd, because my users are all connecting internally on my home network. I mean, these computers can all access each other's hard drives etc.

    At least I have a starting point now, though still unsure whether this odd behavior is specifically bukkit related. As mentioned, vanilla minecraft server worked without changing anything on the firewall.
  23. Offline


    That is strange.

    I would suggest trying to port-forward your minecraft port and seeing if that accomplishes the same thing as turning off the entire firewall - making your server accessible to your LAN players.

    I can understand why you would not want to port forward, because it creates a potential exploit, but I would recommend you try it for the sake of testing.

    If you discover that port-forwarding doesn't solve the problem, then, by all means, re-block the port.

    But, if it does solve the problem, you'll have a more pin-pointed problem area. At this point, you could go ahead and re-block the port.

    I just think it would be conducive to locating the problem if you port-forwarded to see if your problem is directly related to blocked ports.
  24. Offline


    i figured out what the firewall problem is. My vanilla minecraft is configured to use javaw.exe, but bukkit is configured to use java.exe. Not sure why I did that - I probably copied those directly from their respective instructions, and one says javaw and the other java.

    The javaw file was permissioned on my firewall, but java wasn't.

    That doesn't answer the question about why the public network is being used and not the private one, but at least it is now consistent.

    I appreciate your responses, they helped get my brain working.
  25. Offline


    A logical explanation, I love those!
    Glad I could help, BossCraft , in whatever way I did :3

    What's the question you're still not sure about - could you clarify/specify it a bit more (getting late, so I'm a bit scatter-brained)? I'm not sure I'm more qualified to help you with it, but Im sure we could manage to come up with a solution as to why it's happening. It might not be crucial to your server, but understanding your network and how it fuctions is always a handy convenience.
  26. Offline


  27. Offline

    New Motion

    Would I be able to run a bukkit server on 6 GB of ram with a low download/upload speed?
    I have a 32 bit Window XP laptop
  28. Offline


    I originally posted this on the Something's not working post, but thought better of it:

    Hi, I'm using the file craftbukkit-1.2.5-R3.0 to set up a server.
    I have a Windows 7 64-bit system with a 32-bit version of Java 7 (Update 4) and JavaFX.
    I deleted JavaFX in case this was messing things up, but that doesn't seem to have helped.
    Java resides on my machine at C:\Program Files (x86)\Java\jre7\bin\java.exe.

    I'm still having the "unable to access craftbukkit.jar" error. Here are my files.
    ( )

    I've tried renaming craftbukkit-1.2.5-R3.0.jar to Craftbukkit (as above) and craftbukkit, and leaving it as-is, and changing the name in the bat file to match the long, versiony name of the craftbukkit filename.

    For the bat file, I've had it titled Run.bat (not with the .bat visible, but as in the screenshot in the Something's not Working post.) I've included several versions of the Java path, and
    "C:\Program Files (x86)\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar Craftbukkit.jar
    Seems to work best--it gets me to the "unable to access craftbukkit.jar" error.
    If I use
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" "%ProgramFiles(x86)%\Java\jre7\bin\java.exe" -Xincgc -Xmx1024M -jar "%~dp0craftbukkit.jar"
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86" java -Xincgc -Xmx1024M -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"
    It gives me a similar message (after I moved the BUKKIT folder to my desktop):
    "unable to access jarfile C:\Users\User\Desktop|?Minecraft Server -- BUKKIT\craftbukkit.jar"

    By contrast, using
    @Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
    @Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles(x86)%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
    @Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    java -Xmx1024M -Xms1024M -jar craftbukkit.jar
    the batch file seems to fail due to a path problem--they generate this error in the terminal window:
    The system cannot find the path specified.

    I looked for the GUI system mentioned in the Something's not working thread by ZeroZX4, and get a 404 error.
    His run2 j7 32b file gives me the same "cannot find the path specified" error.

    One thing occured to me as I edited the file over and over. I put my BUKKIT folder into my
    Program Files (x86) folder, so as I edited and reedited the bat file, I needed to run notepad as admin,
    and click through lots of user access dialogs. So I tried moving the whole BUKKIT folder to the desktop,
    in case some access/permission problem was at the root of things, but no joy.

    Any help is much appreciated, thanks! I'm sure I'm missing something silly, but can't seem to find it.

  29. Offline


    Low download/upload speed is not enough info.

    What's your CPU(Almost certainly good enough if you have 6gb ram) And what exactly is your d/u speed?
  30. Offline


    I looked here and found this--I can imagine Bukkit could me more resource intensive:
    Players RAM Upload Speed Download Speed
    2 500 MB or more 512 kbps 1 Mbps or more
    3 500 MB or more 1 Mbps 2 Mbps or more
    4 500 MB 2 Mbps 3 Mbps or more
    6 1 GB 2 Mbps 3 Mbps or more
    8 1 GB 3 Mbps 10 Mbps
    9 2 GB 3 Mbps 10 Mbps
    12 2 GB 4 Mbps 10 Mbps
    15 2 GB 5 Mbps or more 10 Mbps
    20 3 GB 10 Mbps 10 Mbps
    30 4 GB 10 Mbps
    10 Mbps
Thread Status:
Not open for further replies.

Share This Page