The Bukkit Consulting Firm - Solving all your Bukkit-related challenges! Thread #2

Discussion in 'Bukkit Help' started by Deleted user, Jun 21, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    How do I spawn a human entity without bukkit telling me I can't?
    I need to create a human entity, save it's Id (of course) and later call it's .teleport() frequently. And when i'm done .remove() it.
  2. Offline


    Hmm... have you checked out the source code of citizens?
  3. Offline


    my node's from my yaml file are not working i think.

    the groups all exsists as they should. but the groups don't have permission to use the commands that i did type out they could use. and also have acces to commands i dident give them permission for (EG /heal and /fly)

    config file of essentials :


    config file of World guard:

    if more is needed let me know!

    Plugins (8): GroupManager, WorldEdit, WorldGuard, Permissions, Essentials, EssentialsChat, EssentialsSpawn, EssentialsAntiBuild

    also there are allot of groups when i us the /grouplist command EG g:towny_admin and i can't seem to remove them (via server GUI or in game commands)
  4. Offline


    How do i turn off lava spread on my server without installing essentials protect. Protct isn't working on my server. Please i need a fast answer!
  5. Offline


    posted on your thread, no need to duplicate.

    essentialsprotect works fine? what error you get when trying to put it on server?
  6. Offline


    Most servers should have worldguard installed - it can disable firespread, disable tnt, and more. Check it out for more info.
  7. Offline


    *COUGH* already answered for this guy on another thread.

    EDIT: This should win an award for the most needlessly cryptic thread to traverse in the whole entire history of needlessly cryptic threads.
  8. Offline


  9. Offline


    Players in the end world cannot use any commands or chat.

    When they chat/use commands nothing happens it returns no error messages in console or in-chat. When I try to kill them or force them to the spawn nothing happens, they jump off into the void and they don't die either. The only way to fix this is to delete the world and generate a new one, this puts them back at spawn and they can return to the end and everything works fine for a few days until it happens again. Its not permissions, I tried it as an op and I still got stuck. Please help!

    Plugins(Bukkit RB 1.4.7-R1.0):
    • Votifier 1.9
    • Vault 1.2.22-b277
    • GroupManager 2.0 (2.9.6) (Phoenix)
    • Enjin Minecraft Plugin 2.4.1-bukkit
    • CoreProtect 1.75
    • WorldEdit 5.5.1
    • AntiCheat 1.5.5
    • Orebfuscator 1.8.7
    • Minigames 1.4.0
    • BKCommonLib 1.45
    • CraftBukkit on Bukkit 1.4.7-R1.0: WorldBorder 1.6.1
    • WorldGuard 5.7.1
    • PlotMe 0.13
    • Essentials Pre2.10.1.4
    • EssentialsSpawn Pre2.10.1.4
    • EssentialsAntiBuild Pre2.10.1.4
    • EssentialsChat Pre2.10.1.4
    • My Worlds 1.59
    • MaxBans 1.2
    • GriefPrevention 7.6
    • ProtocolLib 2.2.0
  10. Offline


    Website coding help any basic tips?
  11. Offline


    Learn HTML,then CSS. Don't forgot html5
    ethg242 likes this.
  12. Offline


    as the title says im looking for some help
    im running a dev build of 1.4.6 of bukkit with the following plugins:

    any help would be greatly appreciated
  13. Offline


    So I'm trying to disable enderman's pick up ability. Can someone point me in the right direction? Im trying to keep ram overhead small so here is what I've got installed so far...

    Multiverse-Core, Inventories, Portals, Sign-Portals

    Multiverse is the reason I need to keep the ram low. Also, what are some good values for bukkit spawn-limits/ticks-per? And is it per world or global? Thanks!
  14. Offline


    Have you tried to test without your plugins (rename the plugins folder and see if the issue is still there).

    Then add back plugins to the new plugins folder until the problem returns. (I know it is a slow process, but you can go in groups, the point is to narrow it down until you find the culprit.)

    This seems like it should do the trick:
    It is a very simple plugin, doesn't use practically any ram at all.

    and for your limits, unless I have misinterpreted what you are trying to ask: should work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  15. Offline


    Sorry I forgot to mention. It's a custom plugin made by my friend and I. We need to output data to a website.
  16. Offline


    Anyone who plays in our server that is not an OP is constantly getting this "Disconnect.spam" kick message when entering commands like warps quickly or typing quickly. (Quickly as in multiple lines per minute)

    Does anyone have a solution? I have searched google for hours trying to find one... No one can seem to fix this issue and there are quite a few people with it.

    Much appreciated if someone does!

    These are the plugins we are usng:[​IMG]
  17. Offline


    Does the problem occur with no plugins installed?

    If not, then add back plugins until the problem occurs again. Then, check that plugin's configuration file.
  18. Offline


    btrilla I see 2 disabled plugins in there, is that normal? If you didn't manually disable them, maybe you have errors in your log preventing them from loading.

    In any case, check for errors in your server log. Errors can lead to all kinds of unwanted behaviors.
  19. Offline


  20. Offline


    Great, you need help... what exactly with? You mention you need help... and give us your plugins...

    and never mention what the problem is...
    tyzoid likes this.
  21. Offline


  22. Offline


    Or pointing you to the place where the question has already been solved...
  23. Offline


    I'm not, I'm just tagging you so you are aware as well.

    It wasn't solved when I wrote the post. But anyway, it should be linked regardless so that someone browsing this thread can find the solution.
  24. Offline


  25. Offline


    Hey BCF guys,

    I have experience with multiple programming languages including: Python, Java, Lua, HTML, CSS, and some Javascript and C++. I also have experience with running and setting up both websites and Minecraft servers. I'm looking for somewhere to apply my knowledge. I'm currently writing a custom plugin for my friend's server, but I would like something else to do as well. May I join your group?


    P.S. I know that I just joined the forum and stuff, but I've been playing Minecraft since Beta 1.2 and setting up servers since Beta 1.6.
  26. Offline

    Deleted user

    Feel free to join :).
    I'll add you to the main post.
  27. Offline


    tyzoid or ShootToMaim I'm using bPermissions, and all other perms except build are blocked to non-ops. I'm 99.9% sure I have my nodes right(Primarily because I'm not getting any error messages). Also, everybody's rank just reads default in-game. Any suggestions?
  28. Offline


    Hey, I'm currently building a server (As in already up, but being constructed) that will involve teams fighting each other. Because of this I want everyone to be able to easily distinguish who is on what team so that they know who to fight etc. The (relevant) plugins I have installed are: TagAPI, NameTags, MCMyAdmin, GroupManager (w/ Essentials), SimpleCommandSigns, and HiddenCommandSigns.
    Simple and Hidden Command Signs work together to allow me to run commands through the player when they right click a sign. So for instance, typing, "/hcs create "/rocket Bob"" Then selecting a sign would cause any player who right clicked that sign to run the command "/rocket Bob". It also allows you to give a user temporary permissions necessary to run the sign, if you configure it to. I'm using this to set up picking which team you join.

    NameTags changes the color/format of player names by adding permissions to them. So adding to a user's permission changes their name tag to black. TagAPI is just a dependency of this.

    MCMyAdmin is a way to manage your server. It includes allowing the command "/pushcommand" to run whatever you type next as a command through the server.

    GroupManager is of course a permissions plugin.

    So on to my problem. I've tried several ways to set this sign to change a user's name color. First I tried using the MCMyAdmin command to push through to the server to run "/addmember:(group) (user)" with the proper info filled in. Each group would have it's permissions set to have a different name color. However, when I tested it with only the permissions of a normal player, it says that I don't have permission to run the command. So I tried adding the "*" permission to the sign for a temporary permission to any user who uses it. It still didn't work. I couldn't find any specific permissions for MCMyAdmin after a good bit of searching, so if anyone has any idea of any permissions for this that would be lovely and could solve my problem.
    However, just in case that's not possible, here's the other way I tried to do it. I set the sign to run "/manuaddp %p" The %p fills in with the name of the player who used the sign. I then added the "groupmanager.manuaddp" permission. When run it says that I cannot modify a user of equal or higher rank than me. So I added the permission "groupmanager.op" which supposedly allows a player to ignore hierarchy/inheritance and permissions if they're running a groupmanager command. For some reason it still won't allow it, saying that I cannot modify a player of equal or higher rank.

    So if anyone can tell me the permission nodes for MCMyAdmin, a way to give permission correctly in GroupManager, or a different solution I'd love you forever. Also, I see there's a plugin writing specialist on the first post. If you could write a plugin to modify player's name tags (Above their heads, not in chat) by using a command instead of permissions that would be great and I would love you forever as well. TagAPI allows you to draw from it to make things like that easier.
    Sorry for the long post, I just wanted to make sure I gave enough information.
  29. Offline

    Deleted user

    IT'S A TEST!
  30. Offline


    I am having this ugly bug:

    (Like that with all the new blocks)
    It happens when I start the server. Everything worked before, but now it doesn't. Also, permissions don't work… And console doesn't answer. It's like it doesn't get the commands…
Thread Status:
Not open for further replies.

Share This Page