Solved Strange problem with PermissionsEX

Discussion in 'Bukkit Help' started by TheOnlyRealTGS, Nov 15, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I'm (TheOnlyRealTGS line 1067) in the group Admin (on line 859) and i can't use /warp

    Admin have Default (line 0) as inheritance, which have the essentials.warp.list permission

    So why can't i use /warp to see all warps ?

    I've tried turn /pex toggle debug and this it was it shows in the server log:

    [INFO] User TheOnlyRealTGS checked for "worldguard.region.bypass.Lobby", no permission found
    [INFO] TheOnlyRealTGS issued server command: /warp
    [INFO] §cTheOnlyRealTGS §4was denied access to command.
    [INFO] [PermissionsEx] User matzefratze123 checked for permission 'flyflag.ignore', regex-matched a value of true from cache.
    PS: I can't use any warps like /warp spawn also.
  2. Offline


    Missing permission 'essentials.warp'
  3. Offline


    Should be on line 18 ?

    I've deleted my perm file and restarted the server.
    Looks like this now:
    I get the message: fromIndex = -20 every time i try to do /warp
  4. Offline


    What warps did you set, and can you do /ess debug, type /warp and paste console output?
  5. Offline


    85 warps. Output:
  6. Offline


    TheOnlyRealTGS Could not replicate the error, what were you typing? just '/warp'?
  7. Offline


    Yes just /warp
  8. Offline


    TheOnlyRealTGS Make sure essentials is 2.12.1 or above, also please paste warps.yml and try do '/warp 1' and see if result is different.
  9. Offline


    I really appreciate your help! Just letting you know :)
    I'm running Essentials version: 2.12.1 (Found in plugin.yml)
    Warps.yml: (a warp teleporting to my warp-hub)
    I'll try what you wrote :)

    You are welcome to see if for yourself on my server. (Can't provide link)​
    New perm file:​

    Another example with this perm file:
    2013-11-15 16:53:48 [INFO] pwninalday117 issued server command: /warp spawn
    2013-11-15 16:53:48 [INFO] [Essentials] checking if pwninalday117 has essentials.mail - false
    2013-11-15 16:53:48 [INFO] [Essentials] checking if pwninalday117 has essentials.warp - false
    2013-11-15 16:53:48 [INFO] §cpwninalday117 §4was denied access to command.
    The user get's the message from: noAccessCommand=\u00a74You do not have access to that command.

    New issue:
Thread Status:
Not open for further replies.

Share This Page