Solved [Severe] message

Discussion in 'Bukkit Help' started by Generation Blue, Apr 30, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Generation Blue

    Can someone please explain why these messages are happening and what i can do to solve this?

    1. What OS are you using (Brand and version - Ex. Windows XP SP3)?
    windows xp service pack 3
    2. What architecture is the OS you are running (x64 or x86)?
    3. What version and architecture is your java install? (Type: java -version in command prompt.)
    1.7 (v7)
    4. Are you running any wrappers? McMyAdmin, mcadmin, Hamachi, etc?
    only a GUI and the error occurs even without the GUI
    5. What build of CraftBukkit are you running? (do NOT say latest. Say the build number.)
    The build number is displayed in the top of the server.log.
    6. What command are you using to run your CraftBukkit server?
    Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit-1.2.5-R1.0.jar

    [SEVERE] java.lang.reflect.InvocationTargetException
    [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    [SEVERE] at java.lang.reflect.Method.invoke(Unknown Source)
    [SEVERE] at com.sk89q.wepif.PermissionsResolverManager.findResolver(
    [SEVERE] at com.sk89q.wepif.PermissionsResolverManager.<init>(
    [SEVERE] at com.sk89q.wepif.PermissionsResolverManager.initialize(
    [SEVERE] at com.sk89q.worldedit.bukkit.WorldEditPlugin.onEnable(
    [SEVERE] at
    [SEVERE] at
    [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    [SEVERE] at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    [SEVERE] at net.minecraft.server.MinecraftServer.t(
    [SEVERE] at net.minecraft.server.MinecraftServer.a(
    [SEVERE] at net.minecraft.server.MinecraftServer.init(
    [SEVERE] at
    [SEVERE] at
    [SEVERE] Caused by: java.lang.NoClassDefFoundError: org/bukkit/util/config/Configuration
    [SEVERE] at java.lang.Class.forName0(Native Method)
    [SEVERE] at java.lang.Class.forName(Unknown Source)
    [SEVERE] at com.sk89q.wepif.NijiPermissionsResolver.factory(
    [SEVERE] ... 18 more
    [SEVERE] Caused by: java.lang.ClassNotFoundException: org.bukkit.util.config.Configuration
    [SEVERE] at$ Source)
    [SEVERE] at$ Source)
    [SEVERE] at Method)
    [SEVERE] at Source)
    [SEVERE] at
    [SEVERE] at
    [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    [SEVERE] ... 21 more

    #the plugins im using are the following
    -world edit
    -world gaurd
    with permissions, essentialsgroupbridge and essentialsspawn
  2. Offline


    Don't use essentials, use Pex, bPermissions, or CommandBook. essentials sometimes conflit with other plugins.
    Im not good at understanding code for java but i assume that it is essentials. Prove me wrong though.
  3. Offline

    Generation Blue

    i was thinking about switching to another essentials plugin but i would appreciate it if i didn't have to re-do all of my shops (using essentials shop) and warps
  4. Offline


    You said "with permissions..". Are you using Group Manager and another Permissions plugin?
  5. Offline

    Generation Blue

    im using the stock permissions file with nothing in it, ill post my notepad++ setup if needed
  6. Offline


    Seems your WorldEdit is out of date.
  7. Offline

    Generation Blue

  8. Offline


  9. Offline

    Generation Blue

    thanks, ill try it and report back

    so far it hasn't worked, ill remove some plugins until the problem is fixed and then try to troubleshoot the plugin conflict

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  10. Offline


  11. Offline

    Generation Blue

    thanks for the advice but i just solved my problem! damn permissions was messing everything up so i simply reloaded World Edit, World Guard, and switched regular Permissions with BPermissions and everything went back to normal with no [SEVERE] problems!
Thread Status:
Not open for further replies.

Share This Page