[SEVERE] java.lang.NullPointerException

Discussion in 'Bukkit Help' started by Vettexl, Jan 27, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    What would cause something like this, and is there a way to fix/prevent it?

    Pastebin: http://pastebin.com/d4Cfu9td

        17:28:58 [SEVERE] java.lang.NullPointerException
        17:28:58 [SEVERE]      at net.minecraft.server.PlayerManager.flush(PlayerManager.java:34)
        17:28:58 [SEVERE]      at net.minecraft.server.ServerConfigurationManager.tick(ServerConfigurationManager.java:366)
        17:28:58 [SEVERE]      at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:537)
        17:28:58 [SEVERE]      at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:434)
        17:28:58 [SEVERE]      at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
        Severe exception detected! Attempting to restart the server...
        17:28:58 [SEVERE] Unexpected exception
                at net.minecraft.server.PlayerManager.flush(PlayerManager.java:34)
                at net.minecraft.server.ServerConfigurationManager.tick(ServerConfigurationManager.java:366)
                at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:537)
                at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:434)
                at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
        Forcing a save... (Shutdown delayed)
        17:29:03 [INFO] CONSOLE: Forcing save..
        17:29:04 [INFO] CONSOLE: Save complete.
        17:29:04 [INFO] [Server] **SERVER IS RESTARTING**
        17:29:09 [INFO] Connection reset
        17:29:10 [INFO] CONSOLE: Stopping the server..
        17:29:10 [INFO] Stopping server
  2. Offline


  3. Offline


    1. What OS are you using (Brand and version - Ex. Windows XP SP3)?
    Debian 6

    2. What architecture is the OS you are running (x64 or x86)?

    3. What version and architecture is your java install? (Type: java -version in command prompt.)
    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

    4. Are you running any wrappers? McMyAdmin, mcadmin, Hamachi, etc?
    Bukkit r1.1 with Remote Toolkit

    5. What build of CraftBukkit are you running? (do NOT say latest. Say the build number.)

    6. What command are you using to run your CraftBukkit server?
    sh ./rtoolkit.sh

    7. What plugins are you running?
    obuShutTheHellUp, GroupManager, WorldEdit, Spout, Vault, Glowstone Lanterns, WorldGuard, ecoCreature, NarrowtuxLib, RemoteToolkitPlugin, AutoMessage, iConomy, Showcase, Permissions, HawkEye, LimitedCreative, Tombstone, NoCheat, Essentials, EssentialsXMPP, EssentialsProtect, EssentialsSpawn, CreativeGates, EssentialsGeoIP, LWC, dynmap, ChestShop, EssentialsChat, VanishNoPacket

    8. What error are you getting (post your server.log file)?
    See first post

    9. What have you tried already?
    Nothing, server restarted itself.

    10. Have you tried any of the things below?
    No, that would require taking the server offline for some time.
  4. Offline


    We hit the same exception, on a server (in a network of other servers) with only one plugin that also restarts every 30 minutes or so. First time thus far.

    • Platform: Windows Server 2012 Release Preview (x64)
    • Java: Java 1.7.0_05 64-bit.
    • Wrappers: No wrappers.
    • Plugins: Our in-house plugin. Nothing else.
    • Version: CraftBukkit version git-Bukkit-1.2.5-R4.0-b2222jnks (MC: 1.2.5) (Implementing API version 1.2.5-R4.0)
    • Command: java.exe -Djava.ext.dirs=externals -Xms1024M -jar craftbukkit-1.2.5-R4.0.jar
    • Server log: http://pastebin.com/ZQnZLTdJ
  5. Offline


    Remove that one plugin, seems to be causing your issues.

    Also, you may want to add a maximum amount of RAM to your server, to stop Java eating up everything you have available and choking out your server.
  6. Offline


    There's no information to indicate there's anything wrong with our plugin. The exception is occurring from within Bukkit, not our code. Also we're not concerned about Java memory usage, thanks for the tip though!
  7. Offline


    Plugins can and do cause those errors. I am not trying to mislead you, I've seen various different plugins cause that exact error you see. When plugin change a great deal of how CraftBukkit works, such as NoLagg, SpoutPlugin (as well as others), errors like these can show up.

    The best way to be sure it is not a plugin is to run the server without any of them (and no server management tools either), and try to reproduce the error. Same goes for memory usage and CPU usage anomalies when they occur.

    The tip for memory is just following the best practices of Java. You do not need to set a max for the server to run.
Thread Status:
Not open for further replies.

Share This Page