server runs fine but keeps saying Can't keep up!

Discussion in 'Bukkit Help' started by McVitas, Jan 2, 2020.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, somebody explaing me this weirdness. I have just recently setup my little personal server and we have been playing for a few days already. It works fine. No lag. Everything happens instantly, but I wonder why the heck server keeps writing Can't keep up! Is the server overloaded? Running 5001ms or 100 ticks behind
    every 30seconds or so! Even right after starting it starts almost immediately even when there are no players logged on! The number of ms behind was ranging from 9000ms to 16000ms. And no, I really did not notice any 16seconds lag. The machine is Xeon 3.2GHz 6cores and 8GB of RAM. Hardly any noticable CPU load. I checked this old thread and changed command to this
    java.exe -Xmx5G -Xms5G -jar craftbukkit-1.14.4-R0.1-SNAPSHOT.jar
    but it did not make any difference. They mention some parameter -server but it does not work when I include it and says Cannot parse argument 'erver' of option s/max-players/size
  2. Offline

    timtower Administrator Administrator Moderator

    @McVitas Seems like an update checker, could you list your plugins?
  3. Offline


    This is just a little family server and I am not really familiar with plugins, so I didn't install any yet:
    [17:29:58] [Server thread/INFO]: There are 1 of a max 20 players online: MatesM
    [17:30:00] [Server thread/WARN]: Can't keep up! Is the server overloaded? Running 15794ms or 315 ticks behind
    [17:30:46] [Server thread/WARN]: Can't keep up! Is the server overloaded? Running 15674ms or 313 ticks behind
    [17:30:50] [Server thread/INFO]: Plugins (0):

    java version "1.8.0_171"
    Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
    Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)

    but now actually when I look at sheep and hostile mobs, they move kind of choppy... :-] Didn't notice that before. Maybe that's a sign something's wrong even when there is really no lag when building or crafting?

    somebody please test this world and tell me if you also see messages Can't keep up and if the sheep and cows move choppy.

    so guess what I have tried: I copied the world folder into %appdata%\.minecraft\saves, started it in singleplayer, then installed official MC server, copied the world there, started and it works fine! Animals movement is smooth and there are no messages about server overloaded :-\ Nether was regenerated though as it is a separate folder in bukkit

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited: Jan 5, 2020
  4. Offline


    So, nobody has 10 minutes to test this and help me? :-\

    I found out it's some problem with 1.14.4. If I convert the world into the same version vanilla server it behaves the same - CPU load 25% on 4 cores machine and "can't keep up".
    If I run it on 1.15.1 vanilla, there is no problem - CPU almost idle and cows move smoothly :)
    The problem is that there is no Optifine for this version yet and some players have rather slow computers to run vanilla Minecraft without OptiFine
    Last edited: Jan 8, 2020
Thread Status:
Not open for further replies.

Share This Page