Server Error

Discussion in 'Bukkit Help' started by wilsondc15, Jan 12, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    The error I have been getting is similar to this one in the FAQ:

    Error: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.kernel32

    "Full error:
    java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.kernel32
    at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode<
    at jline.WindowsTerminal.getConsoleMode<>
    at jline.WindowsTerminal.init<"80>
    at jline.TerminalFactory.create<>
    at jline.TerminalFactory.get<>
    at jline.console.ConsoleReader.<init><>
    at jline.console.ConsoleReader.<init><
    at net .minecraft.server.MinecraftServer.<init><>
    at net.minecraft.server.MinecraftServer.main<>
    at org.bukkit.craftbukkit.Main.main<Main:136>
    Press any key to continue . . .

    This error is caused by you not having Visual C++ 2008 Redistributable installed, or having the wrong version installed that matches your Java version.

    The version of Visual C++ 2008 Redistributable (x64 or x86) must match the version of Java you are using. If you are using Java x86 and have Visual C++ 2008 Redistributable x64 installed, it will not work. You must either use Java x64, or install Visual C++ 2008 Redistributable x86.

    Alternatively, add in the -nojline option which turns off jline."

    Here is my error:

    I am running Linux on a 32bit VPS
  2. Offline


    I have no idea what this is...What version of Java and what version of C++ are you using?
  3. Offline


    java version "1.7.0_45"
    Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
    Java HotSpot(TM) Server VM (build 24.45-b08, mixed mode)
  4. Offline


    And C++? That's needed too. Your Java shouldn't be giving you any trouble...
    wilsondc15 likes this.
  5. Offline


    I need C++ AND Java to run Craftbukkit? I don't think I have that installed. Can you tell me how to check if I have it or not please? Can you post a link to download?

    Thank you so much!
  6. Offline


    I have no idea for linux. I'm only experienced in Mac and Windows.

    Have you tried this?

    This was detailed in the original crash report.
  7. Offline


    I do not know what that means or how to use that
  8. Offline


  9. Offline


    It's just an argument. Add it to your startup script.
    If you don't know how, paste your startup script, and we can help you.

    As for:
    [14:36:15] [Server thread/ERROR]: Could not load 'plugins/TabAPI.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: ProtocolLib
    You need to download the plugin, ProtocolLib. TabAPI "depends" on it for some resources. Note the error name, "UnknownDependencyException"

    [14:36:19] [Thread-10/INFO]: [HideStream] A new version has been found! (HideStream v3.5)
    Go update HideStream.

    [14:36:23] [Server thread/ERROR]: Cannot load plugins/AutoMessage/config.yml
    org.bukkit.configuration.InvalidConfigurationException: unacceptable character '?' (0xFFFD) special characters are not allowed
    And lastly, fix AutoMessage's config.yml. [There's a question mark somewhere where it shouldn't be]

    DuoDex It's not C++ that's used, it's the libraries that are included that are needed and used by Bukkit.
    DuoDex likes this.
  10. Offline


  11. Offline


    Ok I did everything that you said to do. The server worked for a day, now I get this:

  12. Offline


    So what's the problem now? I'd also highly recommend transitioning from PermissionsEx to GroupManager, but that's just from past experiences.

    Also, ModifyWorld's current version is v1.19.7 & you are running v1.19.4
    [17:43:45] [Server thread/ERROR]: Could not pass event InventoryClickEvent to Modifyworld v1.19.4
  13. Offline


    PLease look at the end of the there is an error
  14. Offline


    [00:50:00] [Server thread/INFO]: [Modifyworld] Loading Modifyworld v1.19.4
    If you are running a version lower than the current one, you should go update it.
  15. Offline


    Ok I just went and did that. Ran the server, then got the error again 2 minutes of uptime :(

    Tahnk you for your help by the way! :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 6, 2016
  16. Offline


    Is ModifyWorld mandatory to your server?
  17. Offline


    Idk, it came with PEX. They were in the same package.
  18. Offline


    If you are not using modifyworld to prevent players from performing some sort of action, you can safely delete it to save the memory it would be using. No point in having it installed if you're not using it to block some sort of crafting, or block placing, or block breaking, etc.....
    MaliciousMan likes this.
  19. Offline


    These fixed it:

    This whole thing was caused when Asyncworldedit wanted to update blockphysics. So when something like snow was mid-air and someone broke it, server crash. But that plugin above disables blockphysics except for sand and gravel so thats perfect
    Thanks guys!
Thread Status:
Not open for further replies.

Share This Page