Server crashing anywhere from 3-5 minutes after startup; [INFO] Read timed out / [INFO] time is Up

Discussion in 'Bukkit Help' started by Latros, Jun 2, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    No other errors in the console besides those, and no error details below, just;

    [INFO] Read timed out

    and sometimes (more rarely)

    [INFO] time is Up

    Once we get one of those errors, ONE of two things happens;

    The server seizes up entirely for 10-15 seconds, then catches up with itself and is fine. 30-60 seconds after its fine, it happens again and usually it crashes this time. Sometimes it survives 2 of these "seizes" before it finally crashes.

    Yes, we have enough RAM, only using 4%.
    Yes, we have enough CPU, only using 8%.
    We have 1Gbit DEDICATED internet.
    It is a dedicated server box with over 20 Gigs allocated to the server alone, and a few Gigs used as a RAM disk for the world folder.
  2. Offline


    Oh Boy....

    O.k., this error is something that has existed exclusively as a Bukkit caused issue since 1.4. There is nothing you can do except to play with your plug-in set.

    Some versions of Craftbukkit have been really bad with that error causing iti to happen within minutes of a server being up regardless of number of plug-ins.

    Ram is not going to matter at all in this issue. Post your plug-in list. Read Timed Outs are definitely a plug-in issue as well as a compounded issue by Bukkit. However, I can for sure cause a server to Read Timed Out with certain plug-in combinations that basically over load the machines resources due to poor coding and management of those resources.

    Heavy scanners will cause this immediately. However in 818, I noticed that the server was able to recover from consecutive "read timed out" errors each time it has happened (2 times so far since yesterday) since switching to 818.

    Good Luck
  3. Offline


    Please do not mislead other people.

    There is no evidence this is a Bukkit issue or a vanilla issue. Many people are running Bukkit just fine without any issues and some have even said CraftBukkit b819 is the best build yet. We do not have any of these issues in our testing, on any of the many production servers we run and neither do many of our community members. With this little information, there is not much we can say or do. Also, "time is Up" is not a message I've ever seen before, so I think it might be caused by a plugin, but I am not sure.
  4. Offline


    yes yes...Same story, different day.

    Yet here: timed out&o=date

    195 posts on the issue of "Read Timed Out". So what do you call "many community members? 195 posts out of 70,000 members is not a lot. But the story is always the same, an inability to claim responsibility.

    There is no misleading. It is information, and what you are asking is for that information and an opinion based on experience and working hard at making a server behave properly given the conditions it must run under to be with held, or silenced because "there is no evidence"? So, though it may not be accurate according to you, it is not false, it is simply what it is, and that is an issue being suffered by many server Admins every day all day, and my opinion based on experience and working 16-21 hrs a day on my Bukkit server.

    Don't take it personal, this is software, thousands upon thousands of lines of code, and you nor your staff can expected to execute every line of code perfectly nor without error or issue. However, hasty denial, based on "there is no evidence", is hardly the path i believe you as the prime face of Bukkit wish to pursue. Simply acknowledging that the problem clearly exists by the posts on the forum (and huge lack of posts on google by Vanilla Admins reporting "read timed out"), is enough.

    People want to know that you acknowledge the problem and are working at it. Not "there is no evidence it exists"... therefore do not mention it or tell people of it or mislead people with that scary bit of unverifiable data. Well once again: timed out&o=date <---- it exists.

    De Nile, is not only a river in Egypt.
    PsychoNecrosis, OBudista and Saul R.W like this.
  5. Offline


    I'm having a hard time understanding what you're trying to say but I'll respond to whatever I can make out.

    Nowhere was I denying that it COULD be an issue with Bukkit. However, unless you have concrete evidence, you're misleading others by saying it absolutely, definitely, IS when you really do not know that this is the case. You're entitled to your opinion but you aren't allowed to blatantly mislead others by saying that "O.k., this error is something that has existed exclusively as a Bukkit caused issue since 1.4." because you have no proof of this. Once again, you're misleading others and blowing things out of proportion by claiming I'm flat-out denying that Bukkit is the cause when this is clearly not the case.
  6. Offline


    Sorry, i just had to come back and focus on this sentence i could not get out of my head.

    Over 10 pages of "Read Timed Out" errors, with people literally able to tell you what plug-in they pulled out which caused the error to stop happening, and you sit there and say: "There is no evidence this is a Bukkit issue or a Vanilla issue".

    I am sorry, but that confuses me.. Are you saying this issue 'does not exist'? Because clearly it exist AS a Bukkit issue when you do a search on and come up with over 195 posts pertaining to people having "Read Timed Out" errors on their Bukkit servers.

    Seriously, is your denial instinct so fast that you just blurt out something so plainly contradictory, and flat out impossible? Because Minecraft Server runs: Bukkit, and Vanilla, and "Custom Server"... And clearly: timed out&o=date <---- Bukkit is experiencing this error.

    So when you say it is not a Bukkit issue. What is it exactly are you saying?

    Edit: Oh ok. So "Semantics". My use of the word "exclusive" in conjuction with Bukkit, says that "only bukkit" has this issue and probably manifested it. Ok i can understand that. And you are correct, i cannot make such a statement as a fact. So, clearly i stand corrected.

    It is "my experience" that this has been exclusively a Bukkit issue, in my dealing with Read Timed Out Errors since 1.4. That in no way means beyond any doubt that the issue is solely created or manifested in Bukkit.
    - Ok Disclaimer posted. I stand corrected.
    KaleShadowWalker and OBudista like this.
  7. Offline


    Are you saying that people have fixed this issue by disabling various plugins? If so, that would be a PLUGIN issue, which obviously requires Bukkit, but is not an inherent Bukkit issue. For something to be considered as a Bukkit issue, it must be reproducible on a plain Bukkit server (no plugins), and NOT reproducible on a vanilla server.

    Granted, there could be some code within Bukkit that these plugins are all accessing that is causing the problem, but that would require more information.

    The problem with your response is that you make it sound as though this issue is being caused by Bukkit and happens to everyone. (that might not have been your intention, but that's how it comes across)
  8. Offline


    If you're going to state an opinion, do so as an opinion, not fact - that's all I have a problem with. You clearly do not know what you're talking about if you think doing a search for "Read Timed Out" is evidence of anything. Read Timed Out is a generic error that occurs whenever a socket read times can happen for any number of reasons and is not something we can easily diagnose, but we're definitely trying anyway. All I'm asking is you stop saying it's Bukkit's fault when you have no proof that it is. Yes, it may be Bukkit's fault, but it also may be vanilla's. In my experience, it is mainly caused by software running alongside the server that messes with network connections like a firewall, proxy or some antivirus applications and even this only applies to some instances of this problem. But really, the error is so generic it is very difficult for anyone to pinpoint the cause and claiming otherwise is misleading and just causing trouble, so please refrain from doing so.
  9. Offline


    I found that adding these these opts

    -XX:PermSize=128m -XX:+UseConcMarkSweepGC -XX:ParallelGCThreads=6 -XX:+CMSParallelRemarkEnabled -XX:+DisableExplicitGC -XX:MaxGCPauseMillis=500 -XX:SurvivorRatio=16 -XX:TargetSurvivorRatio=90 -XX:+UseAdaptiveGCBoundary -XX:-UseGCOverheadLimit -Xnoclassgc -XX:UseSSE=3 -XX:+UseLargePages
    And setting gc to verbose:gc

    Always fixed this problem but in 1.6 it stopped fixing this issue lets get back to the subject here, Kainzo I think you have lots of experience with this issue I seen you in many discussions about the cause and the solution to this do you mind sharing the conclusion you came to.
  10. Offline


    Things you need to check:

    1) Software Firewall - do you have any running? Have you made proper allowances? Have you tried removing it entirely?
    2) Router/Hardware Firewall - double check this - run your server directly connected to the internet if you so dare. Eliminate this as a potential problem.
    3) Antivirus - Double/triple and quadruple check this for the issue. I had a problem logging into one day for some Starcraft 2 - long story short, it was my Avast Antivirus. Never rule it out because it hasn't caused you issues before.

    Also, I've ran Bukkit since build 4 and never ran into this error. While this doesn't mean Bukkit's not to blame, it only means in my environment I haven't seen the problem.
  11. Offline


    People can play fine for 10-20 minutes but randomly the cpu usage will spike 100% out of no where and lag the server out than get the read timeout errors sometimes if you just wait it fixes it self but it kicks everyone out in the process.
  12. Offline


    See my post above yours. What antivirus are you running?
  13. Offline


    its a, Ubuntu 10.4 LTS and its on a Dedicated server so no anti virus and CSF is disabled.
  14. Offline


    Does your network card itself drop off?

    Try to keep a constant ping going while you run your server - see if you get any packet loss (or see if it just stops responding entirely).
  15. Offline


    Last 5 minutes I been almost spamming google with pings and everyone is 1-2ms I ran a packet loss test and I downloaded a 1GB file from my other server and they are in the same datacenter but apart still there on fiber together so i know it doesn't count but it went 90mbps it would go faster but hard drive limitations but again these lag spikes are strange it will work fine for 15 minutes 30 people on than randomly my cpu usage moves from 10% to 90 or 100% on one of the cpus and everyone just lags and people get dropped than after maybe 3 minutes of this it calms down or the server just takes a break and crashes.
  16. Offline

    Netto Hikari

    We're experiencing this error as well. Sometimes, the server runs smooth for like 12 hours or more... Almost no lag and then - suddenly - "Read Timed Out".

    I'm not sure what's causing the socket to time out, but many admins on say, it could be a plugin / map files issue.

    Here's a list of plugins we currently use: AuthDB, BananaChunk, BorderGuard, CommandBook, ecoCreature, FalseBookBlock, FalseBookCore, FalseBookIC, HeroChat, HeroicDeath, HeroicRebuke, iConomy, InvDelet0r*, LightningBox*, LogBlock, LogBlockQuestioner, LWC, mcMMO, MessageChanger, MinecartManiaCore, MinecartManiaSignCommands, Minequery, MultiVerse, MyHome, MyWarp, NaturalGiants, NoSpawn, NoWeather, p2aliases, PerformanceTweaks, PetitionPlugin, properTime, Towny, UnitedWeStand*, Vanilla, WorldEdit, WorldGuard

    Plugins marked with a * were made by me... All Plugins are up-to date and I'm using CB #819 (awesome build).
    I'm starting the server with following command: java -Xincgc -Xmx15G -jar craftbukkit.jar nogui

    I'm using Java 7 x64 b144 on CentOS 5.5 x64...

    Let's see what we have in common to narrow down this issue.
  17. Offline


    We've had this happen to our server a few times. Logs look something like "[Info] Read timed out.". As of recently we haven't had it happen but my guess is something using a database i.e. bigbrother or logblock causes the error. We weren't able to pinpoint it at the time because it seemed to occur at random and removing BigBrother was something we could not do (lot's of griefers out there).
  18. Offline

    Netto Hikari

    That's what I thought as well, but I think, I found the problem on my server: Integrated Cirquits. I've had a lot of them enabled for my users (ICs which were considered as not harmful)... After removing FalseBookIC, almost 18 hours without a mysterious "Read Timed Out" crash have been passed by and I'm happy.
  19. Offline

    Netto Hikari

    Okay, I definitely found the solution to the problem on my server. It wasn't FalseBookIC causing the problem.
    We just had some corrupt player.dat files in the players folder of our main world. I deleted them (kills inventory and spawn point of all players). 2 days without a single crash.

    I host a large server (rank 4-7 on and I recommend making a "sorry" kit with some nifty items as reinstatement for the lost inventories, otherwise you will have tons of mad players. ^^
Thread Status:
Not open for further replies.

Share This Page