Problem/Bug Server crashes with ">Killed" or "Killed"

Discussion in 'Bukkit Help' started by driver1848, Jan 21, 2021.

Thread Status:
Not open for further replies.
  1. Offline

    driver1848

    Hi there!

    I just installed Bukkit on my new server (4 cores, 4GB RAM, 80GB storage) and it wont start... It says ">Killed" or "Killed" when i want to start it and i have to reconnect to the server, because PuTTY wont react. My console gives me this output:
    Code:
    [email protected]:~/server/main$ ./craftbukkit.sh
    Loading libraries, please wait...
    [13:19:48] [main/INFO]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
    [13:19:48] [main/INFO]: Found new data pack file/bukkit, loading it automatically
    [13:19:49] [main/INFO]: Reloading ResourceManager: Default, bukkit
    [13:19:50] [Worker-Main-4/INFO]: Loaded 7 recipes
    [13:19:48] [main/INFO]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
    [13:19:48] [main/INFO]: Found new data pack file/bukkit, loading it automatically
    [13:19:49] [main/INFO]: Reloading ResourceManager: Default, bukkit
    [13:19:50] [Worker-Main-4/INFO]: Loaded 7 recipes
    [13:19:52] [Server thread/INFO]: Starting minecraft server version 1.16.5
    [13:19:52] [Server thread/INFO]: Loading properties
    [13:19:52] [Server thread/INFO]: Default game type: SURVIVAL
    [13:19:52] [Server thread/INFO]: Generating keypair
    [13:19:52] [Server thread/INFO]: Starting Minecraft server on *:25565
    [13:19:52] [Server thread/INFO]: Using epoll channel type
    [13:19:53] [Server thread/INFO]: This server is running CraftBukkit version 2991-Bukkit-f3f3094 (MC: 1.16.5) (Implementing API version 1.16.5-R0.1-SNAPSHOT)
    [13:19:54] [Server thread/INFO]: Preparing level "world"
    [13:19:59] [Server thread/WARN]: Unable to find spawn biome
    [13:20:01] [Server thread/WARN]: Unable to find spawn biome
    [13:20:01] [Server thread/INFO]: Preparing start region for dimension minecraft:overworld
    [13:20:01] [Worker-Main-5/INFO]: Preparing spawn area: 0%
    [13:20:02] [Worker-Main-6/INFO]: Preparing spawn area: 0%
    [13:20:02] [Worker-Main-5/INFO]: Preparing spawn area: 0%
    [13:20:03] [Worker-Main-5/INFO]: Preparing spawn area: 0%
    [13:20:03] [Worker-Main-6/INFO]: Preparing spawn area: 0%
    [13:20:04] [Worker-Main-5/INFO]: Preparing spawn area: 2%
    [13:20:04] [Worker-Main-5/INFO]: Preparing spawn area: 2%
    [13:20:05] [Worker-Main-9/INFO]: Preparing spawn area: 2%
    [13:20:05] [Worker-Main-5/INFO]: Preparing spawn area: 4%
    [13:20:06] [Worker-Main-5/INFO]: Preparing spawn area: 4%
    [13:20:06] [Worker-Main-5/INFO]: Preparing spawn area: 5%
    [13:20:07] [Worker-Main-9/INFO]: Preparing spawn area: 8%
    [13:20:07] [Worker-Main-9/INFO]: Preparing spawn area: 8%
    [13:20:08] [Worker-Main-6/INFO]: Preparing spawn area: 9%
    [13:20:08] [Worker-Main-5/INFO]: Preparing spawn area: 11%
    [13:20:09] [Worker-Main-9/INFO]: Preparing spawn area: 11%
    [13:20:09] [Worker-Main-5/INFO]: Preparing spawn area: 11%
    >Killed
    [email protected]:~/server/main$
    
    Do i have to do this as root? Is this a problem with my host? Am I dumb? And btw i never reached 3GB RAM or 3 cores...

    thx
    driver1848


    Fixed it: Didnt had enough RAM allocated in the start script... I just copied the start script from the bukkit wiki page...
     
    Last edited: Jan 21, 2021
Thread Status:
Not open for further replies.

Share This Page