Inactive [SEC] PermissionsPlus v3.2.5p - Alternative commands to modify Permissions in-game now w/MWS [1337]

Discussion in 'Inactive/Unsupported Plugins' started by DigitalTyrant, Mar 20, 2011.

  1. Offline


    PermissionsPlus - Adds ability to modify Permissions in-game

    Updated: 10/6/2011
    Version: 3.2.5p [jar]
    CraftBukkit: [b1337jnks]
    PermissionsPlus adds commands to allow administrators the ability to modify their Permissions config from within Minecraft client. The most complete Permissions editing plugin for Bukkit. Supports Multi-World. Updated for MultiPlay!​
    REQUIRES: Permissions 3.x - Permissions Thread

    Includes: P2Aliases updated 10/6/2011


    Get updates on TWITTER!

    Installation and Usage information and Permissions nodes
    are available at


    It appears that I am not the only server admin that stuck to Permissions v2.7.4 so, I have released PermissionsPlusLegacy v2.4. It is a RB1000+ compatible version of PermissionsPlus v2.3. You can download this in the change log below.
    • You can specify multiple worlds separated using a comma. Do not use any spaces after the comma.
    • You can specify all worlds using an asterisk.
    • You can specify multiple groups using commas for the /user -addgroup command.
      /user -addgroup u:Username s:Group1,Group2,Group3
    • All Usernames and Groups can be shortened. You will be notified if more than one possible match is found.
      digital = DigitalTyrant, adm = Administrator
    • With 2.x+ you must add the info variable 'rank' to your groups in order to enable promote, demote and some group functions. You can set this variable from within the game using the command:
      /group -setinfo g:GroupName i:rank s:1-100+
                         /rankset GroupName 1-100+ world 
      The higher the number the higher the rank. Make sure you use i:rank and not i:Rank it is case-sensitive.
    • You can now set Promote and Demote limits. The Promote limit is the highest rank they can promote to. Demote limit is the highest limit that they can demote from. You can set these using the commands:
      /group -setinfo g:GroupName i:dlimit s:50
                         /group -setinfo g:GroupName i:plimit s:75 
    If you use want to Permissions + PermissionsPlus while using Essentials plugins, make sure you do not have FakePermissions or EssentialsGroupBridge enabled.

    Not sure how long this will be useful with Bukkit's upcoming Permissions system, but it allows the Moderators of my server to give new members access without having to modify the .yml file directly. I will continue development until the new Bukkit Permissions system has widely replaced Permissions plugin.
    Thanks to Nijikokun, original author of Permissions.

    Thanks and Enjoy!
  2. Offline


    Its obviously not alphabetical order or "permissionsplus" would come after "permissions" anyway... I tried renaming everything and no success (Permissionsplus to zpermissionsplus, permissions to apermissions) Nothing worked.
  3. Offline


    did you try the depend: [Permissions] solution?
  4. Offline


    My mods have the permissions but Every time they use promote it gives an internal error and dose not work Me on the other hand it works for I get my permissions to promote from the mod group Because i inherit from them short of giving them op i have tried every thing else to get the command to work or them :/

    My permissions files are back a page i think as an attachment if you want to take a look.
  5. Offline


            default: false
                prefix: '&c(&3SA&c)'
                suffix: '&d'
                build: true
                rank: 8
                plimit: 4 # <--- Here
    simple mistake :) (at least it should be unless you changed that for another reason.)
    same for Admin and Mod
    although the internal error is interesting. try and post it. there seems to be a lot of unhanded cases. some pretty common.
    EDIT: scratch that i can promote a user as superadmin to owner. -_-
    EDIT2: well after realising that i was a OP -_- it is indeed completely broken. a non-OP with - '*' permissions is still unable to do anything, they can type the command but it fails with the NullPointerException which is posted several times above. (this is after stripping the groups.yml of all permission nodes and user.yml permission nodes as well. and just having - '*')
  6. Offline


    Unfortunately, not specifying the world fails too, in fact that's what lead me to try the world paramater. I only have the one world (plus its Nether counterpart) and I was in it trying those commands with no luck :((

    I'll give it a go as an Operator rather than relying on Permissions, see if that works for now.

  7. Offline


    just went and confirmed it (edit2 in above post) use with permissions is completely bugged atm unless your an OP, so yeah, it should work if your an op :)
  8. Offline


    Confirmed here, too. Adding myself as an Op it works a treat.
  9. Offline


    not the greatest solution though. @DigitalTyrant good luck fixing all these bugs :)
  10. Offline


    Hmmm. Let me try it out
  11. Offline


    You can always do, /user -addgroup blablabla
  12. Offline


    Can anyone give me the download for Permissions plus to work with permissions 2.7.4 on 860?
  13. Offline


    The error that is popping up when your mods attempt to promote/demote is due to a pLimit and dLimit check. It is a known bug and I have already fixed this. I have fixes for most of the bugs stated here. There will be an update released today that will address most if not all of them as well as adding the -remgroup action.

    PermissionsPlus 2.3.1

    All of the previous versions are available @

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  14. Offline


    You should a it so if a person where to right click on a sign with the group name on it they would be placed into that group.
  15. Offline


    Sorry buddy, that's outside the scope of this project.
  16. Offline


    Whenever I do
    /groupset IEclipseII Owner World
    Or just do it without putting "World" at the end I get this error message:
    [P2]You must specify the user and group(s) you would like to add the user to.
    I'm just starting this server and have only this, and permissions for 818 build (Possible problem? Couldn't find Permissions for 860 build though.) Theres no error in my console. It just shows that when I try to modify my group. Yes I am an OP on there.
  17. Offline


    This is one of the last bugs I am working on identifying and fixing before the release of 3.1
  18. Offline


    May be possible with command signs providing they have a player Var For who clicked it (should do its a pretty common need)

    You sure you are using permissions 3 and not permissions 2? Latest permissions 3 runs with 860 as i am using it and i am sure many many others are.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  19. Offline


    PermissionsPlus 3.1 has been released. Twitter followers and Donators had access before the public. Thanks for the support, everything helps :) Let me know which bugs persist.
  20. Offline


    i'll muck around with it tonight after work. thanks! :)
  21. Offline


    What have you done with this plugin, it was fun as well, and now it is not known what type ...
    It was best / group nickname rank
    For example: /group MrManiek Moderator

    You could change it, or update an old plugin under an old command, as they were in the former versions?
  22. Offline


    problem is that permissions now has multiple world permissions and a player can also be a member of multiple groups.
    so for the plugin to work correctly, the syntax has to change. thats just the way it is.
  23. Offline


    Due to the complexity of the permissions system I will not be reverting back to the original commands that I had previously released this plugin to handle. However, there are commands that I will provide shortcuts for and there are also other plugins available that you can designate your own shortcuts to suit your needs. For more information on all of the commands that are currently available, goto
  24. Offline


    Hey Digital,

    It's displaying the wrong world in the promote message. :)

    [P2] User SirHedgehog has been promoted to Group Gold in World utopia-r36
    When both the promoter and promoted was in "world".
  25. Offline


    Interesting. I will do some testing. thanks
  26. Offline


    Great update by the way, it's so nice to have "/promote" and "/demote" back! :)
  27. Offline


    Yes. I am on permissions 3.1.5 Which though, might support 860 still says [818] in the topic title. I couldn't find a 860 build, and I'm pretty sure the developers just update the topics, so there normally isn't two topics for two separate builds. I.E- A separate topic for 860 build, and then a second topic for 818 build at once.
    This is the permissions I am using right now:
    Though, DigitalTyrant already said it is a known bug that he is working on. I'm just going to wait. I need to re read a book for my server anyway. I'll just get that done, and in the mean time finish and configure any extra plugins that I need.
  28. Offline


    hehe, well it's just a semantics issue, I will have it fixed next update. The fun part is watching all of the people that will post complaints about this and not read this response lol. I'm sure another bug will pop up soon enough that requires an update to fix anyway.

    The issue has been fixed. Installing PermissionsPlus 3.1 should replace P2Aliases and allow that command to function as intended.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  29. Offline


    For me, /groupset still gives the "You have to specify" message. :(

    Do you need any certain info that would help you debug it?

    But promote/demote works perfectly now, thankyou!
  30. Offline


    Haha, yeah, I just changed my messages to not include the world for now. :)
  31. Offline


    I am absolutely stoked to say that /promote and /demote now work an absolute treat. Thankyouthankyouthankyou!!

Share This Page