[SEC] Orebfuscator 2.1.7 - Anti X-RAY [CB 1.4.5-1.7.10]

Discussion in 'Archived: Plugin Releases' started by lishid, Sep 24, 2011.

  1. Offline


    Orebfuscator - Anti X-RAY:

    Bukkit-Dev link here:
    All important information available here:


    Configuration guide and performance optimizations:

    Orebfuscator 2.1.7 for MC 1.4.5-1.7.10

    Legacy versions:


    CPU testing (open)

    Engine modes (open)


    Support the developer: [​IMG]

    Attached Files:

    • 1.jpg
      File size:
      217.5 KB
    • 2.jpg
      File size:
      131.8 KB
  2. Offline


    You did a full restart, right?
  3. Offline


    I think Thronk is seeing the same thing I am with regards to chests: If I TP to a location within range of chests, they all look like stone. They don't turn into chests until I start moving. Once I move just one block, all chests in range appear.

    It's not that big of a deal, since players could get used to it once they realize what's happening. They just need to move a bit.

    Good luck on your finals.
  4. Offline


    [19:36:19] [pool-3-thread-1/WARN]: [Orebfuscator] dev.bukkit.org rejected the API key provided in plugins/Updater/config.yml
    [19:36:19] [pool-3-thread-1/WARN]: [Orebfuscator] Please double-check your configuration to ensure it is correct.
    [19:36:19] [pool-3-thread-1/WARN]: java.io.IOException: Server returned HTTP response code: 403 for URL: https://api.curseforge.com/servermods/files?projectIds=32408
    [19:36:19] [pool-3-thread-1/WARN]: at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    [19:36:19] [pool-3-thread-1/WARN]: at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
    [19:36:19] [pool-3-thread-1/WARN]: at com.lishid.orebfuscator.utils.Updater.read(Updater.java:340)
    [19:36:19] [pool-3-thread-1/WARN]: at com.lishid.orebfuscator.utils.Updater.update(Updater.java:396)
    [19:36:19] [pool-3-thread-1/WARN]: at com.lishid.orebfuscator.utils.UpdateManager$1.run(UpdateManager.java:21)
    [19:36:19] [pool-3-thread-1/WARN]: at org.bukkit.craftbukkit.v1_7_R1.scheduler.CraftTask.run(CraftTask.java:53)
    [19:36:19] [pool-3-thread-1/WARN]: at org.bukkit.craftbukkit.v1_7_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    [19:36:19] [pool-3-thread-1/WARN]: at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    [19:36:19] [pool-3-thread-1/WARN]: at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    [19:36:19] [pool-3-thread-1/WARN]: at java.lang.Thread.run(Unknown Source)
    [19:36:19] [pool-3-thread-1/INFO]: [OFC] Update failed, reason: FAIL_APIKEY
    Should I be worried? This looks practically harmless in my opinion.
  5. Offline


    I had that API key error, too, so I just turned off the auto updates.
  6. Offline


  7. Offline


    Thanks Lishid!!
  8. Offline


  9. Offline


    If my members are mining, they're seeing "fake" ores all the time. How do i shut this down ? I Just want to hide Diaore from xraying thats all.
  10. Offline


    Are you using the default settings? They shouldn't see any fake ores with the default settings.
  11. Offline


    I got a load of problems with it. Still.
    Everytime they break a block, they see for like 0,5sec diaore all around them. It tried the clearcache but it doesnt work.
  12. Offline


    OFC seems to be making ores "Flash" while mining them. When setting "UpdateOnDamage" to "false", they no longer flash, but becomes hidden(turns back into stone) when a block is broken.

    Bukkit: Beta-RB0.2 #2974
    OFC: 2.05

    I've also tried clearing the cache, doesn't seem to fix.
  13. Offline


    I got big problems with this plugin.
    Everytime i enable it steps, water, wheat and other self builded things are invisible.
    When you step on it you are stucked.

    What can i do? :(
  14. Offline


    how d
    how does this work?
  15. Offline


    is there any way to make engine mode 2 work in blocks other than stone?

    heres an example, i have nether and end bioms that spawn in my world, ofc doesn't work at all in them. would there be a way to make engine mode 2 treat netherrack and endstone like it treats normal stone?

    also i noticed that you cant add certain block into your random blocks list, 2 of them would be sticky pistons and beacons, im assuming that pistons wont work either since sticky pistons wont. if would be helpful if that was added in an update or if i could fix it somehow.

    ive also noticed that ofc does what i call "ghosting" its config file, when i add blocks to the ProximityHiderBlocks list, i cannot remove them, i will have to remove the plugin completely along with deleting the config file, relaunch my server, close it again, and put ofc back in in order to have it stop thinking that the blocks i added are still in the config file. this isnt the first plugin to do this so it might be my server, but its only happened with 2 plugins out of the 20 something plugins ive used, if it helps im running Ubuntu 14.04 64-bit
  16. Offline


    Is this going to update to spigots 1.8 protocol? currently i cant get this plugin to work with it.

Share This Page