Inactive [SEC] Ore To Client Obfuscation v1.9.1.1 - Anti X-Ray (xray) [1.2.5-R4]

Discussion in 'Inactive/Unsupported Plugins' started by TyrOvC, Jul 12, 2011.

  1. Offline


    solarox5, DaveDee, kahlilnc and 27 others like this.
  2. Offline

    Nathan C

  3. I have Spout installed, but not forced.
    Do i use the 1060 install, the spout install, or do I get to choose?
  4. Offline


    If you have Spout, just use the spout install.
  5. Offline


    No source for rawcritics_ore_obfuscation_plugin_spout.jar ask the Author to add it to
  6. Offline


    I did everything correct... It doesn't work.. Well, it used to work, but when I got my rentgen client (just to see if still works) - nope.
  7. Offline


    The plugin still obfuscates ores for OPs regardless of the "disableforops=false" setting.

    Other then that, great as always :)
  8. Offline


    It doesn't work for me!! It worked awhile ago, now it doesn't.
  9. Offline


    Spout 1.0.5?
  10. Offline


    somethings gone wrong for me, it all installed correctly with no errors but i still see ores, tried all 4 engines and no change. Dont know what else to tell u. could it be that im running on mcmyadmin.
  11. Offline


    You should be using "disableforops=true"
  12. Offline


    I tried it both ways and it has no effect, it is still disabled for OPs.
  13. Offline


    Great plugin!, i just installed it on CB1060 and it works perfect.

    @others, if you do OPS on or off, you need to re-log for it to work.
    Login as OP, its disabled (you can xray)
    Login as No Op (normal) its enabled (you cannot xray)

    @ Developer:
    Can you make it so, that it has 2 layers of normal materials, instead of 1, when in Mode 4?
    Because now, when you break 1 stone, right behind that, comes all the iron obfus.
    However, if we would make it 2 layers of normal materials instead of 1, then you would never be able to see the iron obfus, even when its lagging, because when you broke the first, you could never break the seccond and notice the iron obfus.
  14. Offline


    this "bug" with the air is gamebreaking! /chunkme does not help. the only thing that helps is to disable this plugin.
    i have tried in mode 4 and mode 1 still reporting everything as air with this plugin. People were able to bypass protections in certain chunks with this plugin running. its like making chunk specific OPS :confused:
  15. Offline


    When "disableforops=true" is when ores should not be hidden from server ops.

    I've been searching for a workaround for the blocks reporting as air bug, and the cause of it. Also setting up one of those things (not finished yet).

    I think I'm going to do that in the next version actually. In Mode 4, make two layers of stone appear between the surface and the iron ore.

    It's probably best to use the Spout version, otherwise I can't promise that there won't be more errors caused by Spout
  16. Offline


    Hi there!
    Did you came across this message when starting up the server after a "Stop" command?
    When this happens, the Engine stays at mode 1. Using bukkit 1060.
    Best regards,
  17. Offline


    I am having the same issue. I wish he provided the earlier version of the plugin for spout as it worked fine for me.
  18. Offline


    I had to delete the config folder and let the plugin create a new onde.
    Weird that this happened twice and the config was default..
  19. Offline


    Is this because my Spout is 1.0.5 and not 1.0.2 ?
    Sorry if this isn't related.
    16:25:29 [INFO] [SEVERE] Ore Obfuscation Plugin Cannot Attach To The Engine:
    16:25:29 [SEVERE] java.lang.NoClassDefFoundError: org/getspout/spoutapi/SpoutMan
    16:25:29 [SEVERE]       at com.rawcritics.TyrOvC.OreObfuscationPlugin.Spout.OreO
    16:25:29 [SEVERE]       at
    16:25:29 [SEVERE]       at
    16:25:29 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    16:25:29 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    16:25:29 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.enablePlugins(Craf
    16:25:29 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    16:25:29 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    16:25:29 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    16:25:29 [SEVERE]       at
    16:25:29 [SEVERE]       at
    16:25:29 [SEVERE] Caused by: java.lang.ClassNotFoundException: org.getspout.spou
    16:25:29 [SEVERE]       at$ Source)
    16:25:29 [SEVERE]       at$ Source)
    16:25:29 [SEVERE]       at Me
    16:25:29 [SEVERE]       at Source)
    16:25:29 [SEVERE]       at
    16:25:29 [SEVERE]       at
    16:25:29 [SEVERE]       at java.lang.ClassLoader.loadClass(Unknown Source)
    16:25:29 [SEVERE]       at java.lang.ClassLoader.loadClass(Unknown Source)
    16:25:29 [SEVERE]       ... 11 more
  20. Offline


    The plugin have many exploits. When people teleports to another person, the ores show up for them. How does Spout make this plugin better? Do I NEED spout to make this plugin work? It worked perfectly fine before I updated to build 1060
  21. Offline


    Probably is, I'm going to have a new version that for sure works with 1.0.5 up later tonight.

    No, you do not need Spout for it to work (won't work any better, anyhow). There's an issue across the board with #1060 that I'm trying to figure out.

    It's just what it reported, it couldn't find the config file to load it. Totally forgot to make it say "defaulting to type 4" instead of "defaulting to type 1" way back when the default engine mode was changed though!
    Ritsbits likes this.
  22. Offline


    @TyrOvC awesome! Thanks so much :)
  23. Offline


    But do you know what can cause this?
    If I reboot my server almost sure that the error will happen...
  24. Offline



    2011-09-06 17:28:11 [INFO] RawcriticsOreObfuscationPluginSpout plugin enabled
    2011-09-06 17:28:11 [INFO] [WARNING]RawcriticsOreObfuscationPluginSpoutFailed to load engine config, defaulting to type 1
    2011-09-06 17:28:11 [INFO] RawcriticsOreObfuscationPluginSpout connected to the Ore Obfuscate Engine and turned it on! Using Engine: 2
    2011-09-06 17:28:11 [INFO] RawcriticsOreObfuscationPluginSpout: Spout Packet Manager found, assuming Spout version is 1.0.2

    Seeing that, despite my file being correct, thoughts?
  25. Offline


    Hello, Mode 4 (and by extension, 5) is inferior to Mode 1 in every possible way and should not be recommended.

    - mode 4 and 1 have exactly the same security when it comes to what an x-ray user could theoretically see, in both modes, an x-ray user can discover ores with revealed faces
    - mode 4 uses significantly more network resources then mode 1
    - mode 4 instantly alerts an x-ray user that there are anti-cheat mods on the server, which may cause them to not use any other cheats which are detectable

    And possibly, but something I have not confirmed:
    - mode 4 is more CPU intensive them mode 1, as the algorithm for checking and changing stone to ore (and back) is run more often then changing ore to stone (and back)
  26. Offline



    we use mode 2.
    but glowstone is visible, is there a way to make it transparent or make every block in the game transparent?
    i test it to put the id on the transparentIds but it doesnt work :(

    btw: mode 4 doesnt work correctly, xray plugin like cjb mod works fine fo find ores.
  27. Offline


    It's what's happening with me.
    I have to delete the config every time my server reboots for it to create a new config and use it :(
  28. Offline


    I see.. I'm using mode 4... that may be why its not correctly blocking xray.
  29. Offline


    the link for the current version w/ spout is broken :-/
    I could host a minor link for you if you would like
  30. Offline


    Mode 3, Bukkit 1060#, using latest version of this plugin. I can still see ores. No issues appeared in the server.log either.
  31. Offline


    Hi TyrOvC,
    First off... FANTASTIC mod! Congrats, Notch should do this by default!

    Secondly, I get the same problem as Kainzo:
    however for me it happens when the server restarts. So everytime I restart the server, I need to copy the net and org folders BACK into the craftbukkit jar.

    Do you have anyideas on that? Amazing plugin except for this one problem.

    UPDATE: Hmm, seems to not work at all now. :( so sad.

Share This Page