Inactive [SEC] Ore To Client Obfuscation v1.9.1.1 - Anti X-Ray (xray) [1.2.5-R4]

Discussion in 'Inactive/Unsupported Plugins' started by TyrOvC, Jul 12, 2011.

  1. Offline


    solarox5, DaveDee, kahlilnc and 27 others like this.
  2. On my server it works 'just' fine, except it doesn't update anything on block break.

    for example,
    mode 4, i break block, see iron, and it doesn't disappear,
    mode 1/2, i brake blocks, but i don't see if its an ore or stone until i break it or put torch next to it or even on it.

    few spout updates it was working just great, now :(
  3. Offline


    same here. what version of spout you are using?
    some chunk are bugged. check the image. a chunk update good, and another chunk no update the blocks.
    (cb1060, spout version, mode 4)
    chunk division:
    chunk division:
  4. Offline


    From a user caught xraying - even with our anti-xray (with spout) on .... thoughts @TyrOvC
    1. paneema

      part 3: all i wanted to do was pvp with my friends i recruited. I appreciate you even thinking about letting me repeal after both lying to you and xraying in the first place. Sorry I disrespected one of the few rules you had.
      14 minutes ago


    2. Ipaneema

      part 2 : so we figured it was an xrayer. We had a admin come down to check it out he didn't even check if they had xray. So I figured if he got away with it than screw it i will do it to without any research. So i was thinking, as punishment you could take away my stuff i earned from xraying, and to prove i will never do it again i hit 50 so i don't need exp anymore and
      14 minutes ago


    3. Ipaneema

      Okay, I searched up how you could prove i was xraying after i was banned and saw that you could see that i was pressing x to toggle on a mod, and that i had obvious mines without torches. I did it however because me and my friends i recruited (whom don't know I xray) got every last item stolen from us in a chest that was virtually impossible to find because it was covered in smooth stone"
  5. Offline


    DisableforOP's is not working for me.

    Im using CB 1060, running engine mode 4, have it set to update on block damage, and ore update radius of 3. OP's still seem to be getting obfuscated.
  6. Offline


    @TyrOvC I found out what the issue is. There is a bug in bukkit 1060 and has been in bukkit for a while but not as noticeable as in 1060, where bukkit shows plugins that the block is a AIR block and not block like stone ect. You can notice the glitch alot in plugins like MagicCarpet where it would destroy blocks of someons build. Or BigBrother would log airblock breaks. Not for sure what the cause of this glitch is but its annoying. But I would assume your plugin does not detect airblock hits. So when the block is being shown as air and is hit/broken your plugin is not detecting this and the blocks being hidden show up as the ore.

    Reason I know this is I was checking blocks via bigbrother log. The blocks where people would see the ore there block breaks were detected as air blocks and not stone or other type of block. I have reported the AIR block issue to the bukkit redmine but maybe you can push for a fix for this.
  7. Offline


    nice work. I've had this issue in certain chunks as well. Hopefully this is a step forward toward getting the problem fixed.
  8. Offline


    Great find! Probably can make the plugin compensate for that in the meantime.

    I'm thinking it may be related to how the worldedit compass teleporter, etc, somehow sends the blocks without being obfuscated. I'm trying to figure it out! I have no idea how it would just quit working randomly and a player actually be able to walk around and xray in a case of only this plugin and the server (so checking out interactions with other plugins).
  9. Offline


    These players do not have teleport compass ability and NoCheat is also enabled.
    Note - using the same xray - I was unable to reproduce the issue like my other admin, however, this player fessed up and said he was using it as a indicator (he would mine and then see the blocks pop up as he went along)
  10. Offline


    It may or may not be obvious (chances are you already have, and it's a real bug), but make sure to update your server's class files with the updated classes in the update, not just the plugin.

    Actually, oh sorry! I said I was going to always say whether those modified classes have been updated with each update, but completely forgot to this time. My bad
  11. Offline


    I 2nd the issue with the op thing not working on spout version as well.
  12. Offline


    Im using the spout version not the regular version.
  13. Offline


    I am getting this message on server startup
    2011-08-31 22:30:13 [INFO] RawcriticsOreObfuscationPlugin plugin enabled
    2011-08-31 22:30:13 [INFO] RawcriticsOreObfuscationPlugin connected to the Ore Obfuscate Engine and turned it on! Using Engine: 1
    2011-08-31 22:30:13 [INFO] [SEVERE] Ore Obfuscation Plugin Cannot Attach To The Engine:
    2011-08-31 22:30:13 [INFO] Ore Obufuscate Engine is not installed, please add the required class to the server jar
    I am using CB1060 and the lastest ore download.
    Any ideas on what to do with this?
  14. Offline


    Mode 5 doesn't work at all. Am I doing something wrong? Here is my config:

    #Choose the obfuscation engine you want to run.
    #1 Hides all ores and chests that don't have a transparent block next to them.
    #2 Hides all ores regardless of whether they have a transparent block next to them, and hides chests that don't have a transparent block beside them. Ores reappear when dug, or when they are right clicked on.
    #3 (Deprecated, do not use! Instead, Mode 1 and Hide Chests False) Same as Mode 1, but leaves chests alone. Might use if Lockette, etc. is already protecting chests.
    #4 (default) Turns all stone AND ores without adjacent transparent blocks into iron ore above height 20, and diamond ore below. Turns chests without adjacent adjacent transparent blocks to stone.
    #5 Randomly turns stone without adjacent transparent blocks into Ore. Slighly more process intensive then 4.
    #List of block ids to count as transparent, seperated by commas.
    #Radius around removed blocks that block updates are sent for ores. Higher values use more processing power and bandwith but are nicer for players with bad connections. Default 2, recommended no higher then 4.
    #When to send player ore updates. 0 (default) is on block break events. 1 is on block damage, which can make latency slightly less noticable, but uses more proccessing power in the main server thread.
    #Checks for exposed ores after explosions if true. If you have a plugin for disabling block damage from creepers, depending on how the plugin is written in might save processing power to disable this.
    #Hides chests in all engine modes by turning chests without adjacent transparent blocks into stone until uncovered.
    #If true, Ops (players in ops.txt) will not have the obfuscator ran for them.
  15. Offline

    Lunar Delta

    Is it possible to make it so that stuff like the PickaClient can't see the ores? Because it certainly can now. Using the latest Ore plugin (spout version).
  16. Offline


    The error is self explanatory. Are you using spout? If not you should get it. Not only have I found that this plugin works great, but instant load teleporting! XD
  17. Offline


    Everything works fine, just fine... but... there's a bug... When I or someone else (with normal clients, no hacks) try to dig straight down, all of the ores (inc. stone) becomes iron ore!
  18. Offline


    That's not a bug. Read the full OP

    "Engine Modes"
  19. Offline



    we've a problem with your plugin. I think godsyn reported the same issue before.

    Our problem is that there appear regions on our map where nearly no plugin works.
    When we try to use a falsebook ic in an affected chunk it says that the sign must be placed on a wall wich matches the hole-in-floor-issue of godsyn. I've made a screenshot of these:

    Our Stargates from WormholeXTreme also dont work in such chunks and our dynmap is unable du render these parts of the map and show black holes:


    We also tried to replicate this bug on our server with and without the ore-obfuscation plugin and it appears with the plugin but without it installed we were not able to produce such black holes on the map.

    Maybe the most importent information is that we find out that these damaged chunks appear when teleporting.
    Is there a problem with chunkloading during teleport?
    We hope that problem will be solved soon.
  20. Offline


    @Aganor That's a problem within Bukkit itself, and the bug has existed for quite a while. There is no known fix for this yet other than forcing the chunks to reload (By everyone in the area logging out and logging back in)

    The bug is that every block in that chunk is reporting itself as 'AIR'
  21. Offline


    Okay but why does this not happen when ore-obfuscation is not running?
  22. Offline


    @Aganor I guarantee it does, but it may happen much less frequently.
    We never have the issue

    Nobody knows exactly what's causing the bug, so it hasn't been fixed yet. :X
  23. Offline


    this problem exist on our server since the usage of spout, there possibility that this is only a coincidence. But i dont think so.
  24. Offline


  25. Offline


    You can also install a plugin like BananaChunk and do /chunkme when the bug occurs, the command forces a chunk reload. Easier then logging in / out :p
  26. Offline


    No, you're wrong. The problem is that the server has loaded the wrong chunk. Not the client.
    Your plugin simply resends the chunk to the client.
  27. Offline


    Actually you're wrong. It's not that the server loaded the wrong chunk, it's that the server's reporting everything in the chunk as 'AIR' and a chunk reload will fix it, and that plugin actually -DOES- reload the chunk.
  28. Offline


    that's exactly what I meant. If I force the server to send this 'buggy' chunk again. I dont change somthing.

    However, I can say with certainty: If the player leaves the field and this
    chunk is no longer held in the RAM of the server. Next time when the player comes back the same Chunk is loaded correctly. But Only if the server REloaded the Chunk again.

    @but2002 I'm experimenting with O2CO without Spout on a test environment which has only Essential installed. I noticed that the option"disableforops" turns the anti-X-Ray effect for OPs always off regardless of whether the setting is "true" or "false".
    if I reload the chunk without OP rights it does work. (yes .. i reloaded the client chunk everytime i changed somthing)..

    More about the error
    which Aganor has reported, i can not say yet but try to exclude spout as a source of his reporded problem.
  29. Offline


    @blackbinary The command actually forces the server to completely reload the chunk, not JUST resend it.
  30. Offline


    okay, that is somthing else ;)

    BUT @Aganor and @but2002 I have the soluiton or more a workaround.. the SPOUT version of O2CO is realy the problem .. the normal version has no Black holes. I remember the Bukitcontrib .. it was a pain to in the past ;)

    never spout again ! :mad: the only thing we used spout for was Logblock-chestlogging.. i can live without this .. LWC ftw ;)

    @but2002 will you continue with the version without Spout in the future?
    & can you confirme the bug with the "disableforops" option ?
  31. Offline


    @blackbinary I'm not the plugin author. ;)

    I've been using Spout for a while now, as well as this and I have the issue no more frequently than when I had it before.

Share This Page